Occasional Visitor
blanchardc
Posts: 1
Registered: ‎10-12-2012
(1,597 Views)
EliteBook 8770w mass storage issue in RAID/AHCI mode (WinXP)

We're currently evaluating an EliteBook 8770w to use in our Windows XP environment. I got all the drivers for it in order to create a driver pack, but the Mass Storage drivers are not cooperating at all. 

 

I tried the Intel RST F6 drivers provided by both HP and Intel and neither of them will see the drive in RAID mode, and it causes a BSOD before setup can even launch in AHCI mode.  This scenario is from a simple Windows XP cd install and providing the drivers via F6 on a floppy. 

 

Seeing that there is still Windows XP support offered for this model, I'm assuming this has been tested before? Is there something I'm missing here? I'd rather not have to dumb down the system and force it to use IDE mode, as the client will most likely ask for full functionality.

 

The pre-installed Windows 7 sees two controllers under the RAID category:

- Intel Mobile Express chipset (hardware ID: 282A)

- JMicron JMB36X

 

I even tried some F6 drivers for the JMicron RAID controller, to no avail.

 

Some help would be greatly appreciated, as I'd hate to tell them we can't support these machines and return them.

Who Me Too'd this topic
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.