Re: Z600 6Gbit/s SSD boot drive upgrade (445 Views)
Reply
Occasional Visitor
max---
Posts: 4
Registered: ‎01-17-2014
Message 1 of 5 (478 Views)

Z600 6Gbit/s SSD boot drive upgrade

I have a Z600, dual Xeon 5530 2.4Ghz, 12 Gb RAM.
A few months ago I installed a Kingston HyperX 240Gb Rev 3.0 (6Gb/s) SSD on a Sunix SATA2600 6Gb card.
Things worked well for a few weeks until I started to get random freezes, requiring a hard reboot each time.
I then removed the SATA2600 card, plugging the SSD directly onto the motherboard SATA port-0. The problem became less frequent but I still have a freeze every couple of days.
Today I came across an HP advisory (c02711513) which I think explains my problem - basically "Third party 6Gb/s hard disk drives will more than likely not include the fix that allows proper operation on 3Gbp/s and 1.5Gbp/s ports. Third party 6Gb/s (Non HP) drives are not expected to work correctly."

Is there a work-around to get my expensive SSD working properly on the Z600?

Thank you.

Please use plain text.
Respected Contributor
Alex Geroulaitis
Posts: 269
Registered: ‎07-08-2009
Message 2 of 5 (460 Views)

Re: Z600 6Gbit/s SSD boot drive upgrade


max--- wrote:

Is there a work-around to get my expensive SSD working properly on the Z600?


No workarounds needed, to my knowledge. They just work. 840 Pro, 840 Evo, Intel 520 series, even Corsair Force GS - all work fine w/o crashes or special workarounds. On native SATA or SAS 3G ports though - haven't tried add-on controllers.

HP VAR, Systems Integrator
(if my post was helpful, please "mark as a solution" or give "kudos" - thanks)
Please use plain text.
Occasional Visitor
max---
Posts: 4
Registered: ‎01-17-2014
Message 3 of 5 (445 Views)

Re: Z600 6Gbit/s SSD boot drive upgrade

Thanks for your reply, Alex - but it doesn't entirely answer my question.

 

HP has acknowledged that my 3rd party 6Gb/s SSD is "not expected to work correctly" - and as I explained, my Kingston HyperX is not working correctly.

Since there has been no update on the known problem from HP, I was hoping for a workaround or confirmation that my SSD simply would not work.ie. "No workarounds needs...They just work" is not a solution to my problem.

 

Max

Please use plain text.
Respected Contributor
Alex Geroulaitis
Posts: 269
Registered: ‎07-08-2009
Message 4 of 5 (435 Views)

Re: Z600 6Gbit/s SSD boot drive upgrade

[ Edited ]

Sorry, should have been more specific:

 

I don't know of a workaround for your specific SSD other than

  • try it on a SAS port,
  • try a different SATA/SAS driver (Intel RST if it's SATA, for instance),
  • try an HP-approved add-on SAS/SATA controller,
  • try forcing 3G mode on the SSD (on SSD itself via management tools or firmware, not on a controller),
  • try a different SSD (borrow, buy with a good return policy)

The reason I mentioned that no workaround was needed for other SSDs is not to muddy up the waters but to perhaps give you additional information that might help you zero in on a solution.

HP VAR, Systems Integrator
(if my post was helpful, please "mark as a solution" or give "kudos" - thanks)
Please use plain text.
Occasional Visitor
max---
Posts: 4
Registered: ‎01-17-2014
Message 5 of 5 (432 Views)

Re: Z600 6Gbit/s SSD boot drive upgrade

Thanks Alex, much appreciated - you've given me a good list of things to try.

 

Max

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation