T410 and Smart client services bug (943 Views)
Reply
Advisor
AmanaLiving
Posts: 21
Registered: ‎02-12-2012
Message 1 of 2 (943 Views)

T410 and Smart client services bug

Hello

 

We are reviewing the T410 series of devices, I have installed the smart client services and as per the documentation, the client tries to contact http://auto-update:18287. Using wireshark I can see that the client does this,  but it then tries to request /t410/Image/ for example, and gets a 404 returned.

 

the correct path is auto-update/t410/Image/. As far as I can tell either the iis server is has the wrong virtual directory or the firmware is requesting the wrong path.

 

Has anyone else seen this or are you using DHCP options?

Please use plain text.
Regular Advisor
Matthew Ingram
Posts: 74
Registered: ‎04-20-2007
Message 2 of 2 (843 Views)

Re: T410 and Smart client services bug

The problem is the IIS config. HP's installer creates an IIS site and adds an IIS virtual directory 'auto-update' that points to the c:\program files.... of the hp smart client software. This means the true url to the site is http://auto-update/auto-update but the clients look for http://auto-update. Check it using a browser. I corrected the issue by changing the properties of the IIS site home directory from c:\inetpub\.... to the program files directory for the hp smart cleint software. That fixed it. GJ HP.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation