Re: CTLR-ALT-DEL Passing Through to VDI (5441 Views)
Reply
Advisor
dibbstibbs
Posts: 39
Registered: ‎08-20-2012
Message 1 of 11 (5,560 Views)
Accepted Solution

CTLR-ALT-DEL Passing Through to VDI

I've run into an issue where pressing CTLR-ALT-DEL doesn’t process on the XenDesktop session but rather the Thin Client itself.  I was given the attached package by one of our HP contacts which fixed the issue and worked pretty well until I joined the T510 to our domain.  What happens is if I attempt logon is as admin (on the thin client) or and hit control-alt-del, absolutely nothing happens.  I'm wondering if there's another fix out there or a know issue that's beeing looked into.

Visitor
hafid_uk
Posts: 3
Registered: ‎09-24-2012
Message 2 of 11 (5,554 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

Is that a fix for WES 7? I posted a message on this forum about 2 post before yours regarding the keyboard filter thats missing in HP WES 7 SP1 build. I was hoping to use that to disable CTRL ALT DEL, but if this fix actually passes through the keys to the Xendesktop thats better.

 

 

Advisor
dibbstibbs
Posts: 39
Registered: ‎08-20-2012
Message 3 of 11 (5,550 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

Yes, this works for WES7 as I'm new to the Thin Client-VDI world and that's all I've used.  This package was sent to me by my counterpart in Australia but before that, I wasn't able to find anything related to this which is a bit suspiring considering other folks have to had this issue as well.  

 

As far as the keyboard mapping, just run the install.bat file and you should be all set.  You have to install this logged in as admin on the Thin Client and in my case, I'm using two models (T5570e & T510) both running Windows Embedded and if the EWF is enabled, commit and you should be all set. 

 

Even after joining to the domain this fix works as it still passes through via the Thin Client but it doesn't let me log on to the TC locally.

Visitor
hafid_uk
Posts: 3
Registered: ‎09-24-2012
Message 4 of 11 (5,527 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

I installed this yesterday and it doesn't work on our T510 which have the latest wes7 build. Any advice?  

Valued Contributor
vgernyc
Posts: 102
Registered: ‎10-25-2010
Message 5 of 11 (5,511 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

Have you tried CTRL-ALT-END?   This is what RDP and ICA both use.  Not sure about Vmware View.

Advisor
dibbstibbs
Posts: 39
Registered: ‎08-20-2012
Message 6 of 11 (5,442 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

I tried CTRL-ALT-END and CTRL-ALT-HOME but they don't seem to work.  Strange that this works fine until I join the TC to the domain.   

Advisor
dibbstibbs
Posts: 39
Registered: ‎08-20-2012
Message 7 of 11 (5,441 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

Sorry for the delayed response as I've been on vacation.  I'm using the latest build as WES7 build as well so not sure what the differences could be.  I assume that you committed the change before restarting the TC device? 

Advisor
dibbstibbs
Posts: 39
Registered: ‎08-20-2012
Message 8 of 11 (5,361 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

We've decided to go with the Citrix Desktop Lock solution as this way the credentials will be passed through to Xendesktop.  Thanks to everyone who replied.  On another note, is there a way to close these issue or at they left open?   

Advisor
michaeltfus
Posts: 20
Registered: ‎07-12-2011
Message 9 of 11 (5,153 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

dibbstibbs - I've not heard of the Citrix Desktop Lock solution.  I am going to look on Citrix web now...  do you have a link for more info?  This may actually be a solution that we have been looking for.

Regular Advisor
Davy Priem
Posts: 121
Registered: ‎02-06-2009
Message 10 of 11 (5,125 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

For Citrix Desktop Lock to work, you have to put the tc in your Windows domain.

 

FYI: Yesterday I flashed the latest available WES7 image (6.1.7601.252) to a t610 and tried the fix that was posted here. Tc connects to a Citrix Webinterface and when a user is connected to a desktop and hits ctrl+alt+del it was being sent to the virtual desktop. So the fix still works for WES. 

Occasional Collector
BlueBerry_Jamz
Posts: 1
Registered: ‎11-24-2013
Message 11 of 11 (2,883 Views)

Re: CTLR-ALT-DEL Passing Through to VDI

Hello All,

 

I am looking to acheive the same thing on HP t610's running WES7 SP1 but the only difference to what you have been discussing is we are connecting to a Windows 2012 RDS Session Collection farm.  Does anyone know if the fix posted originally works in this type of environment? 

 

Also I am curious what the behaviour of the local thin is when in kiosk mode if the ctrl+alt+del is redirected.  If we have the thins in kiosk mode and persistent logon, then how does one exit to the admininistrator logon?  Do you have to restart the thin and hold down the left shift key to stop the auto logon?

 

Regards,

Nick

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.