BIOS-Upgrade fail for t5545 (531 Views)
Reply
Frequent Visitor
Willis73
Posts: 4
Registered: ‎06-30-2011
Message 1 of 6 (531 Views)

BIOS-Upgrade fail for t5545

Hello,

we have in our business about 20 HP thin-client type: t5545.
The access to a new patch Windows 2003 Terminal Server. The virtual server is runningon a XenServer host.
If I start a session with the devices and then start Internet Explorer, there will open a web page for example Flash contains elements of the browser are suddenly left me and I cannot do! The RDP session even crash completely on me and I have to log in again!
This happens only when I access this server with the HP product!
When I connect with RDP to Windows 7 with the same virtual server, these problems do not occur!
At first I thought it might be due to the virtual server, but with all other RDP connections, itworks!

I then installed the latest image from HP on the device. But has not helped!
Dan wanted to upgrade I also have the BIOS. It was but an error message: "Not correct kernel"!
Now I do not even really know what to do!
Does anyone have an idea of certification, or at least a suggestion on how I can stillupgrade the BIOS?
Have the image and the BIOS from a USB key installed.

My present data for t5545:
BIOS version: v.1.00 786R5
Build-A: T5X32112
Kernel version: 2.6.27-17-generic

Thank you for your help!
Yours sincerely

Willis73

HP Pro
Rong
Posts: 1,447
Registered: ‎10-30-2005
Message 2 of 6 (519 Views)

Re: BIOS-Upgrade fail for t5545

Do not believe upgrade the bios will help you but you can try to flash with DOS instead with Linux.

I believe the Linux flash utility is not compatible with the new image with the new kernel.  You might want to contact HP services to see if they have a new Lflash for you and see if they have any other fix for your other issue,

 

Although I am an HP employee, I am speaking for myself and not for HP
Frequent Visitor
Willis73
Posts: 4
Registered: ‎06-30-2011
Message 3 of 6 (506 Views)

Re: BIOS-Upgrade fail for t5545

Hi Rong,

Thank you for your feedback.
By using DOS I could now perform the BIOS upgrade!
Unfortunately, this has not fixed but my primary fault!

The RDP session still falls on me whenever I try to open web pages with Flash content!
Unfortunately I have not found a solution yet from HPorGoogle.

It must also give what they have to do with the XenServer virtual server!

Willis73

Valued Contributor
Kite Runner
Posts: 216
Registered: ‎03-31-2010
Message 4 of 6 (497 Views)

Re: BIOS-Upgrade fail for t5545

Willis73,

 

Try this:

1. on the thin client login as root
2. Exit the eztools gui
3. go to advanced tab
4. open an X Terminal
5. start a text editor (mousepad)
6. Edit the file /etc/hptc-display-prefs/Templates/Driver0Section
7. add the following line ‘Option “ShadowFB”
8. Overwrite the file with those changes
9. add the same line to the Driver1Section file

After the two files have been changed then the xorg.conf file has to be update with the change. To do so follow these instructions

1. Closed the mousepad executable
2. run the following ‘hptc-display-prefs –update’
3. change anything (e.g resolution...) in the display settings.
4. press Save, apply and close
5. open the /etc/X11/xorg.conf and check under the Section "Device" that the "ShadowFB" has been added.
6. exit the mousepad
7. then reboot the client

When it works you can change back to the needed display settings.

 

Kite

 

If you found this helpful please Kudos

Although I am an HP employee, I am speaking for myself and not for HP


Although I am an HP employee, I am speaking for myself and not for HP
Frequent Visitor
Willis73
Posts: 4
Registered: ‎06-30-2011
Message 5 of 6 (483 Views)

Re: BIOS-Upgrade fail for t5545

Hi Kite,

Thank you for your guidance.
I've gone through the instructions exactly.
But I am not sure at 2-3 points!

At Section 1, in item 6:
6. Edit the file / etc/hptc-display-prefs/Templates/Driver0Section
I have now made ​​the change this (see screenshot).
Ok?

Then the second section, point 3:
Since I can save anything! I can only widget (see screenshot)!

At point 5:
There I see the entry "ShadowFB" no! (see screenshot)

Can you please tell me what am I doing wrong?

PS: Sorry, my English is not good, I have the texts translated by Google!

Thank you.
Willis73

Frequent Visitor
Willis73
Posts: 4
Registered: ‎06-30-2011
Message 6 of 6 (472 Views)

Re: BIOS-Upgrade fail for t5545

Hi,
I think I've found the solution to my problem! :-)

In a Citrix forum I have found the following discussion:

http://forums.citrix.com/message.jspa?messageID=1454401
There are "Christian Hühnlein", 3rd Post in the mail the following registry entry to create on the server:

 

"Yeah!
I found a solution for this. I just added the following key to the registry:
HKLM \ SYSTEM \ CurrentControlSet \ Services \ Tcpip \ Parameters
Add there the DWORD key "DisableTaskOffload" with the value "1".
Such a little key and such a big problem, that has gone now.
Regards,Chris "

 

This request is for me so complete.
Thank you again to all involved.
Willis73

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.