Can't use login macro recorder in WebInspect 10.10 (332 Views)
Reply
Occasional Collector
chris_sirhc
Posts: 1
Registered: ‎03-20-2014
Message 1 of 2 (332 Views)

Can't use login macro recorder in WebInspect 10.10

Hi guys,

 

Maybe you can help me with the following problem i have with WI ver.10.10 and our javascript web application.

We are developing a single page application (with responsive design) in javascript but we can't manage to make the login macro recorder load the login page. It just displays a blank page, no matter if i use IE or Firefox in the recorder.

The app loads fine in IE9 and Firefox 27.0, installed on the same machine as WI.

I understood that i can use the Web Proxy tool to record a login macro using whatever browser i like, but i couldn't figure it out how to do that as the web proxy tool saves the traffic catched in a different file format which i can't use as a login macro.

 

Any help will be kindly appreciated.

 

Cheers,

Chris

Respected Contributor
HansEnders
Posts: 613
Registered: ‎07-01-2008
Message 2 of 2 (294 Views)

Re: Can't use login macro recorder in WebInspect 10.10

The best way to understand any failing of the Web Macro Recorder would be to run it through the Web Proxy tool.  Launch the Web Proxy, then alter the WMR settings to use it as its proxy.  You will then see all traffic being requested by the WMR in Record mode and Playback mode.  This may expose what is wrong with the javascript load.

 

To generate a Login Macro with the Web Proxy, you need to choose the option to Create Macro on the File menu.  If you only choose the Save option it does save the data in its own *.PSF format and not the *.webmacro format.


-- Habeas Data
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.