Re: When test is 'PAUSED' in UFT, a message box 'The corresponding file doesn't exist' pop's up (109 Views)
Reply
Occasional Visitor
Arunprasad
Posts: 2
Registered: ‎07-11-2014
Message 1 of 3 (148 Views)

When test is 'PAUSED' in UFT, a message box 'The corresponding file doesn't exist' pop's up

When the test is paused, UFT is not taking me to the appropriate library file where it is currently executing. Instead it just pop's up this information message with

'OK' button - 'The corresponding file doesn't exist'.

The test actually does pause, but couldn't find the current line of execution.

My test is located locally and all the associated library files are in ALM.

Please use plain text.
Valued Contributor
Ruddy10
Posts: 129
Registered: ‎05-30-2014
Message 2 of 3 (122 Views)

Re: When test is 'PAUSED' in UFT, a message box 'The corresponding file doesn't exist' pop's up

[ Edited ]

Hi Arunprasad,

 

Hope you are doing well.

 

Searching information i found that this is a known problem.

 

An Enhancement Requests has been created for this, please find it here:

 

http://support.openview.hp.com/selfsolve/document/KM01035595

http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_QCCR1J22286

http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_QCCR1J22286

 

However, as you can see there, R&D opinion is that QTP/UFT debug capability is designed to be performed via the IDE while execution from ALM purpose is to run and manage the test execution and results.

 

Possible workarounds are:

- Once the test is paused it can be continued using Step into and Step over options from the Debug menu; or

 

- by pressing F10 and F11 that are representing them.

 

Hope this will help you, also please mark this answer as accepted solution or correct answer if this answered your question.

 

Best regards,

Ruddy Alvarez Hernandez.
HP Support.
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

[Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.]
Please use plain text.
Occasional Visitor
Arunprasad
Posts: 2
Registered: ‎07-11-2014
Message 3 of 3 (109 Views)

Re: When test is 'PAUSED' in UFT, a message box 'The corresponding file doesn't exist' pop's up

Hi Ruddy,

 

Thanks for the Info.

 

I have already tried the workarounds that you suggested. Pressing 'F10' and 'F11' also gives me the subjected pop - up with 'OK' button on it.

 

However, I can debug the same test when all the resources associated with it are located locally. 

 

Is there a way to 'Debug' when your resources are located in ALM? Please assist.

 

Also, it would be of great help if you could point me towards other known issues of UFT. I just recently migrated to UFT from QTP.

 

Thanks,

Arun

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation