Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8 (2970 Views)
Reply
Frequent Visitor
mageshs05
Posts: 1
Registered: ‎11-08-2011
Message 1 of 15 (7,255 Views)

Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Hi,

 

We need to use QTP11 with Windows7 Enterprise Edition/IE 8.0. But in Windows7, QTP11 is not recognizing Web objects and identifying as Window objects.

 

Kindly provide suggestion/any patch information to resolve this issue. FYI, we have opened QTP first and then recorded in Browser.

 

Thanks

Magesh S

Please use plain text.
Valued Contributor
DaveTheTank
Posts: 58
Registered: ‎07-27-2010
Message 2 of 15 (7,220 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Install patches man. There are at least 2 critical patches that you want to install to work with Win7 and IE9

------------------------------------------------------
QTP vs Robot vs Silk vs Selenium vs ...
Guess who won
Please use plain text.
Regular Advisor
Geethika Enakulapati
Posts: 106
Registered: ‎03-31-2011
Message 3 of 15 (7,217 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Hello,

 

Can you please lets us know what are those patches and where we can get those.

 

 

 

Regards,

Geethika

Please use plain text.
Valued Contributor
DaveTheTank
Posts: 58
Registered: ‎07-27-2010
Message 4 of 15 (7,204 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Well if you have a valid SAID, you can go to patch section for QTP to download it.

 

If you don't have a valid SAID, you are not going to get to the pages.

------------------------------------------------------
QTP vs Robot vs Silk vs Selenium vs ...
Guess who won
Please use plain text.
Regular Advisor
Geethika Enakulapati
Posts: 106
Registered: ‎03-31-2011
Message 5 of 15 (7,202 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

I Assume SAID is available if we have a partner ship with HP? But I'm trying to get this patches updated for Evaluation Version. I've installed Evaluation version of Entreprise Edition. So i'm looking for QTP Patches which can support me to automate web application.

 

Do let me know if there is any way to get those patches for QTP Evaluation Version.

 

 

Cheers!

Geethika

Please use plain text.
Valued Contributor
DaveTheTank
Posts: 58
Registered: ‎07-27-2010
Message 6 of 15 (7,200 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Well so you don't have a SAID

 

You have to find someone who'd email you those patches but, sorry I can't do that.

------------------------------------------------------
QTP vs Robot vs Silk vs Selenium vs ...
Guess who won
Please use plain text.
Valued Contributor
DaveTheTank
Posts: 58
Registered: ‎07-27-2010
Message 7 of 15 (7,196 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

[ Edited ]

Do let me know if there is any way to get those patches for QTP Evaluation Version.

 

Try this see if you can get to it

http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_QTPWEB_00078

 

------------------------------------------------------
QTP vs Robot vs Silk vs Selenium vs ...
Guess who won
Please use plain text.
Occasional Visitor
Lalima
Posts: 1
Registered: ‎03-30-2012
Message 8 of 15 (6,820 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE9

I am facing the same problem and unfortunately I can't download the patch since I am using the trial version. There has to be a solution or some way to get the patch. I am not sure how

Please use plain text.
Honored Contributor
Trudy Claspill
Posts: 3,559
Registered: ‎09-09-2010
Message 9 of 15 (6,804 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE9

If you are using the eval version I suggest you contact HP directly. I would guess that it would be a poor business practice on the part of HP to allow folks who haven't paid for the product to get patches for same. However, if you tell them that you can't properly evaluate the product without this fix, perhaps they will send it to you.
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Please use plain text.
Occasional Visitor
AshwaniBhat
Posts: 1
Registered: ‎11-14-2012
Message 10 of 15 (5,210 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

You need to install all the patches. I tried installing all of them and found that "QTPWEB_00078" is the one which is controlling this. Installing this should fix the problem. Please try. Thanks!!

Please use plain text.
Frequent Advisor
aros
Posts: 51
Registered: ‎08-20-2012
Message 11 of 15 (5,193 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Hi,

 

Please ensure the UAC is disable, also as you cannot download patches please ensure to have IE 8, that version will not require patches if you run it as 32 bits, please execute the iexplorer.exe that is located under C:\Program Files (x86)\Internet Explorer

Please let me know if it helps.

 

Kindly,

 

Aileen

Please use plain text.
Trusted Contributor
MisterT1968
Posts: 107
Registered: ‎04-19-2012
Message 12 of 15 (5,184 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Dear Mageshs05,

 

How are you? I hope you are fine :)

 

In general there is no need to install patches or hotfixes in order to test web applications in Internet Explorer 8. It is supported by default. The mentioned patch is for the support of Internet Explorer 9 as well as the protected mode of Internet Explorer 8.

 

In general, please make sure about the following:

 

1. Is the BHOManager Class AddOn in Internet Explorer 8 enabled? This is essential.

2. Was the Internet Explorer opened after QuickTest Professional? Please note, that there should be no instance of the Internet Explorer open when QuickTest Professional is opened.

3. Is the Internet Explorer in Protected Mode? This can be checked in the status bar, which will tell you whether it is on or off. The pretected mode is related to the User Account Control (UAC) and can only be disabled when the UAC is switched off.

 

Please let us know, whether or not this helps.

 

Best regards,

 

Tino Pacholski

Functional Testing Support Engineer

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]
Please use plain text.
Occasional Visitor
SimranT
Posts: 2
Registered: ‎08-25-2013
Message 13 of 15 (3,074 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Hi

 

I am using QTP trial version and i have installed all the patches came along with it.

 

Now my issue is QTP is identifying the browser but its not identifying its components.

 

QTP 11 AND firefox 23.0

 

like for eg. in gmail if i am recording the scenario of entering username its coming in qtp as

Browser("Mozilla Firefox").type"username"

 

Please help. I have all the ways described above

Please use plain text.
Occasional Visitor
SimranT
Posts: 2
Registered: ‎08-25-2013
Message 14 of 15 (3,072 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Sorry , for me QTP is not even recognising browser.

 

Window("Mozilla Firefox").type"username"

 

Please use plain text.
Occasional Advisor
pencilshree
Posts: 9
Registered: ‎10-29-2012
Message 15 of 15 (2,970 Views)

Re: Web Objects not identified in QTP11 with Windows7 Enterprise Edition - IE8

Hi,

 

  • I have followed the steps that 

  • HP QuickTest Professional 11
  • Internet Explorer 8
  • Windows 7 32-Bit

And my settings on IE 8 are as follows

  • Protected Mode is disabled (See IE_Protected_Mode.png)
  • Third-party add-ons are enabled (See IE_Third_Party_Extensions.png)
  • BHOManager Add-on is enabled (See IE_BHOManager_Addon.png)

And on Windows 7, I have UAC disabled (See Win7_UAC_Disabled.png)

 

I first run QTP as administrator. Once QTP is launched, I run IE8 as administrator, then navigate to my AUT.

Then, I use QTP's Object Spy to spy on a WebEdit, and what I see is a Window("xxx").WinObject("xxx").

 

Note:


This issue DOES NOT happen on my personal laptop, but does occur on multiple team-members' laptops. I have ensured the above settings are properly put in place on those laptops, but still I get the issue.

 

I have attached screenshots. Can anyone help me out? Any little help is appreciated.

 

Thank you very much.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation