Re: UFT12.0 does not recognize 64 bit ActiveX components (285 Views)
Reply
Occasional Visitor
Satishsundar_KT
Posts: 1
Registered: ‎05-06-2014
Message 1 of 2 (328 Views)

UFT12.0 does not recognize 64 bit ActiveX components

[ Edited ]

I am running UFT12.0 on Windows 7 (X64) OS. My UAT is a windows application with custom built FarPointGrid (ActiveX object). The Problem I face is, UFT could not identify activeX objects of 64 bit version of the application, while activeX objects of the same app for 32 bit has no problem in identification.

 

I guess Since ProgID for the object is read from registry, by default it looks from its native registry i.e  Wow6432Node. Has anyone encountered the same problem and resolved it?

 

Highly appreciate your inputs.

HP Expert
vzamoraz
Posts: 502
Registered: ‎04-12-2012
Message 2 of 2 (285 Views)

Re: UFT12.0 does not recognize 64 bit ActiveX components

[ Edited ]

Hello Satish,

 

        The reason is that for now UFT supports ActiveX only on 32bits.

 

Regards.

If you find that this or any post resolves your issue, mark it as an accepted solution.

 

Also remember if you have a valid contract with HP feel free to visit our FT/QTP Support Customer Forums: http://h30499.www3.hp.com/t5/Functional-Testing-QTP/ct-p/sws-Fun_Test 

You can create an account with your HP credentials

 

Note: The Opinions expressed in my post are mine alone, and do not reflect the opinions of my employer. No warranties express or implied for any answered posted.

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.