Re: UFT 11.52 - objects disappearing from the OR overnight! (448 Views)
Reply
Valued Contributor
CPTLaura
Posts: 274
Registered: ‎12-13-2012
Message 1 of 5 (522 Views)

UFT 11.52 - objects disappearing from the OR overnight!

Hello!

 

This is so strange...

 

I can record scripts, add objects to the OR, everything is great.

 

Come in the next day and the objects I added to the OR are gone.  so the scripts don't run, and I have to readd the objects. 

 

The issue is intermittent.  It doesn't always happen, and sometimes I get a save entry failure error.

 

any thoughts???

HP Expert
vzamoraz
Posts: 502
Registered: ‎04-12-2012
Message 2 of 5 (498 Views)

Re: UFT 11.52 - objects disappearing from the OR overnight!

Are you saving into a shared drive?

Do you have that saving error message that you mention(screenshot, exact message)?

Occasional Advisor
Shruti_Sagar
Posts: 17
Registered: ‎02-13-2013
Message 3 of 5 (458 Views)

Re: UFT 11.52 - objects disappearing from the OR overnight!

I had the similar issue in my Project too.
We use application area in BPT fraework, which is used accross the team.
SO i believe it is the similar case with you too.
What I did is before leaving for the day, disconnect the QTP with QC after saving the OR.
Then connect again and verify ..if you find it,,, disconnect and goto home
Next day.. you wont find the objects missing..
Believe me ,, it worked.... I cant explain howcome.. may be there is some sync issue... but after this I never came accross this situation again
Regards:
Shruti Sagar Mishra
Software QA Analyst
################
Please Mark kudos on left , if this answers your question
################
Honored Contributor
john scarpino
Posts: 1,344
Registered: ‎02-15-2008
Message 4 of 5 (448 Views)

Re: UFT 11.52 - objects disappearing from the OR overnight!

Hi Laura,

 

Are you currently using QC/ALM to save your scripts? If not you may want to do this.  Attached is 'Version Control Add-in Guide.' This should give you a good start if not.

 

Best regards,

John Scarpino, D.Sc.

Valued Contributor
CPTLaura
Posts: 274
Registered: ‎12-13-2012
Message 5 of 5 (439 Views)

Re: UFT 11.52 - objects disappearing from the OR overnight!

Thank you, Everyone, this is a good start.

 

I will take a screenshot f the error that we get internittently when we lose objects from the OR.

 

And your suggestion, Shruti, is interesting.  I will work with that and let you know what I find.

 

Also, Thank you, John, I am reading the Versioning Guide now. 

 

It is funny that you ask if I save tests to ALM...because I do...but it isn't working either.   I will attach the screenshot of the error we are getting from time to time, but it reads, "Failed to Post Simple Key Entity".  It seems to still save the code when I re-open though.  

 

We don't get this message when we are losing OR changes, I am just wondering if they are related.

 

Thnak you again, I will update with what I find.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.