Re: Siebel 8.0 with QTP 11 (2340 Views)
Reply
Occasional Visitor
NamanB
Posts: 3
Registered: ‎12-09-2012
Message 1 of 4 (2,363 Views)

Siebel 8.0 with QTP 11

Hi,

 

I am trying to work on Siebel 8.0 (High-interactivity FW) with QTP 11 but QTP is not able to identify Siebel objects. Instead it identifies them as Web objects.

 

I have loaded Siebel add-in successfully. Is there any specific patch required for this to work?

 

Please provide any possible cause and solution.

 

Thanks.

 

Regards,

Naman

Please use plain text.
Occasional Visitor
nikhilgangwar23
Posts: 2
Registered: ‎07-28-2011
Message 2 of 4 (2,359 Views)

Re: Siebel 8.0 with QTP 11

What are the points to take care before starting with automation on Siebel 7.7.x app?

* Verify the Siebel Test Automation module is installed and enabled

From the Siebel add-in 8.0 readme file (in the "Supported Environment" section):
"The QuickTest Professional Siebel Add-in supports recording and running tests and components on the following versions of Siebel eBusiness applications:
- Siebel 7.7.x, only when the Siebel Test Automation module is installed and enabled.

Note:
There is an entry in a Siebel server side config file that must be set to TRUE. Make sure the correct entry is set:

EnableAutomation = TRUE
not:
EnableWebClientAutomation = TRUE

* Also Make sure the URL for the log-in page of your Siebel server includes the SWECmd=AutoOn token.

Example:
http://hostname/callcenter/start.swe?SWECmd=AutoOn.

If you do not append this token, the Siebel Web Engine (SWE) does not generate test automation information.

If you select the "Open the following application when a record or run session begins" option in the Siebel tab of the "Record and Run Settings" dialog box, QuickTest Professional automatically appends the Siebel Test Automation information to the URL (you do not need to specify it manually in the URL).

How to verify that the Siebel Test Automation module is installed?

Check that the list of running processes in the Windows Task Manager includes a process named SiebelAx_Test_A (or SiebelAx_Test_Automation_18306.exe). This process will appear only after you have logged into the Siebel application.

Does Mercury QTP care what mode the Siebel application is in (HI vs. SI)?
Support for High Interactivity applications is different from support for Standard Interactivity applications. When recording a script against a HI application, the script mostly contains calls into the Siebel-provided test automation API. In contrast, when recording a script against a pure SI application or against a SI component that is embedded within an HI application (e.g. customer dashboard, query assistant, search center), the script mostly contains calls that use Mercury’s native scripting syntax.

 

Please let me know If you have any queries in this.

Please use plain text.
Frequent Advisor
aros
Posts: 51
Registered: ‎08-20-2012
Message 3 of 4 (2,349 Views)

Re: Siebel 8.0 with QTP 11

Hi,

 

Confirm the Siebel Test Automation Process is running on your machine:

 

  1. With QTP closed, open the task manager
  2. Search for the process: Siebel Test Automation.exe

 

  

 

 

If you don’t find the process: “SiebelAx_Test_Automation” in your QTP machine task manager this should be the reason of the recognizing fail, since according to the Siebel Add-in documentation,  QTP support Siebel based on the Siebel Test Automation API, so you need to have this process running in your machine.

 

If it´s not running, you need to modify the Siebel Test Automation module configuration in your Siebel Server side since that module is not part from QuickTest Professional and it ´s not supported by HP Software Support.

 

The SiebelAx_Test_Automation is not lunched by QTP, is completely handled by the Siebel Server and QTP only uses it to connect with the Siebel CASAPI.

 

So you should contact your Siebel Administrator and set your Siebel Server to enabled the SiebelAx_Test_Automation.

 

I have found the following documentation about, but the settings are different depending of the Siebel version you are using, so if it´s not helpful I recommend you to contact Siebel and ask about how to enabled the Siebel Test Automation module for your Siebel Version.

 

http://support.openview.hp.com/selfsolve/document/KM187732 (How to verify that the Siebel Test Automation module is installed)

  • Server Side Configuration:

     A) Add/Change the .CFG file for the Siebel AUT. Add the following to the [SWE] section

       [SWE]
        ....
       EnableAutomation = TRUE
       AllowAnonUsers = TRUE
       AutoToken = <SecretWord>

    B) Restart the Siebel Server

    C) (optional) Add Automation Token
  • Then launch QuickTest Professional with the Siebel add-in and record against the Siebel 7.7.0 – 7.9.x application.
  • Bring up the Task Manager and look for the following procees: “SiebelAx_Test_Automation”.

 

 

Please put this as solved if you find the feedback helpful.

 

Kindly,

 

Aileen

 

Please use plain text.
Occasional Visitor
NamanB
Posts: 3
Registered: ‎12-09-2012
Message 4 of 4 (2,340 Views)

Re: Siebel 8.0 with QTP 11

Thanks guys for your responses. I had found solutions on simlar line. The problem is everything (QTP, APP) is on Citrix side so we don't have control. So configuration changes are requested to Admin. Once they are done I will check and update.

 

Note: working with QTP and App being on Citrix is a challenge itself and reduces the performance drametically. Avoid it if you can.

 

ReEgards,

Naman

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation