Re: QTP 11 fails to recognise objects when switching add-ins (through application areas) (93 Views)
Reply
Occasional Visitor
robinweller
Posts: 1
Registered: ‎01-13-2014
Message 1 of 2 (103 Views)

QTP 11 fails to recognise objects when switching add-ins (through application areas)

I have a BPT test that uses multiple application areas, each of which use different add-ins for QTP.

 

When I run a component using both the Oracle and Web add-ins, it interacts with a browser to log in to an Oracle ebiz system. The following component uses just the web plug-in and is used to click a link on the oracle homepage.

 

When running the second component, QTP can no longer recognise the browser, which when using the object spy appears simply as a Windows application.

 

The same thing happens when I reverse the roles, so starting with web only components to access the oracle system results in oracle components failing to be recognised when we access oracle forms.

 

This only happens in test lab and runs fine in test plan.

 

Any suggestions?

 

Thanks,

Robin

Please use plain text.
Occasional Visitor
Nick_Poxon
Posts: 1
Registered: ‎01-13-2014
Message 2 of 2 (93 Views)

Re: QTP 11 fails to recognise objects when switching add-ins (through application areas)

Hi Robin,

Great question. I have the same issue.

Cheers, Nick

 

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation