QTP 11.0 Script stops automatically on windows server 2008, IE8 it doesn’t navigate from one tab (936 Views)
Reply
Occasional Visitor
JayaSehgal
Posts: 1
Registered: ‎10-01-2013
Message 1 of 6 (936 Views)

QTP 11.0 Script stops automatically on windows server 2008, IE8 it doesn’t navigate from one tab

QTP 11.0 Script stops automatically on windows server 2008, Sometimes IE8 is not launched; sometimes it doesn’t navigate from one tab to other after launching IE8. I uninstall QTP completely and reinstall it, it works fine for first run, then stops again. I scheduled it using a vbscript file with  simple code to launch QTP application and the the script. Not sure, qtp gets corrupted or what happens in background that script stops. I tested the script in other environments like windows 7 on a standalone machine, it works fine without any issue. Pls help me asap.

Please use plain text.
HP Expert
vzamoraz
Posts: 497
Registered: ‎04-12-2012
Message 2 of 6 (882 Views)

Re: QTP 11.0 Script stops automatically on windows server 2008, IE8 it doesn’t navigate from one tab

Is the operating system Server 2008 or Server 2008 R2?

Please use plain text.
Collector
JayaSehgal1
Posts: 2
Registered: ‎10-02-2013
Message 3 of 6 (872 Views)

Re: QTP 11.0 Script stops automatically on windows server 2008, IE8 it doesn’t navigate from one tab

Hi vzamoraz , This is windows server 2008 R2 Enterprise. 

Please use plain text.
HP Expert
vzamoraz
Posts: 497
Registered: ‎04-12-2012
Message 4 of 6 (847 Views)

Re: QTP 11.0 Script stops automatically on windows server 2008, IE8 it doesn’t navigate from one tab

1) -Remember to launch always QTP first then the browser

    -When QTP is Opening and the add-ins manager window appears ensure to have checked the Web Add-in

           

 

2)  Launch QTP Click on the menu Automation>Record and run Settings

    -A popup window appears so click on the Web tab.

    -Ensure that the option “Record and run test on any open Browser” is selected.                      

 

 

3)Lunch Internet Explorer

-Click on Tools>Options>Programs, click on Manage Add-ons

-Ensure that the BHOManager Class is enabled.

-Disable all the other add-ons

-Close Browser

-Launch QTP then Browser and check the recognition.

-If issue persists enable the add-ons again

-If recognition is present then you can enable one by one the add-ons in order to see which one cause the problem.

 

4) Lunch Internet Explorer

Click on Tools>Options>

Click on the Advanced Tab and confirm that

Enable Third-party browser extension is checked and

Disable Script Debugging (Internet Explorer) is checked

 

5)  Close QuickTest Professional.

- Close all instances of Internet Explorer.

- Open the mic.ini file (located in the \bin directory of QTP).

- In the [acx_hook] section, change IEXPLORE.EXE = yes to IEXPLORE.EXE = no.

- Save mic.ini.

- Restart QuickTest Professional.

- Launch the browser

- Run the Test

- If this don't works restart the mic.ini value "change IEXPLORE.EXE = yes"

 

5) Click on IE Options

-Select Security Tab.

-Set it to low

 

6) If the machine has Windows 7, server 2003 or 2008 disable the User account control

-Go to User Account Control Settings.

-Type in UAC, or go to the System and Security applet.

-Click on the "Change User Account Control Settings" link.

-BTW, you can also type in this command from the Run menu:

-C:\Windows\System32\UserAccountControlSettings.exe

-To turn off UAC, move the slider to the Never notify position, and then click OK.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

-To turn UAC back on, move the slider to choose when you want to be notified, and then click OK.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

-You will need to restart your computer for UAC to be turned off.

 

 

7) Repair QTP

- Close QTP

- Open Windows Registry Editor (Go to the Start menu, select “Run”, type “regedit” and click “Ok”)

- Navigate to HKEY_CURRENT_USER\Software\Mercury Interactive

- Right click on “QuickTest Professional” folder, select “Export” and save the file prompted

- Right click on “QuickTest Professional” folder and select “Delete”

- Navigate to HKEY_LOCAL_MACHINE\Software\Mercury Interactive

- Right click on “QuickTest Professional” folder, select “Export” and save the file prompted

- Right click on “QuickTest Professional” folder and select “Delete”

- Browse to profile’s application data (Go to the Start menu, select “Run”, type “%appdata%\HP” and click “Ok”) and rename folder called “QuickTest Professional” to “QuickTest Professional.BAK”

- Go to Control Panel -> Add/Remove Programs -> QTP -> Repair.

     If you cannot see it

     Launch QTP's Setup.exe like if you want to install it again.

     Select the option install QTP

     On the installation wizard you will see the option Repair.

     Check it and continue with the wizard

     Finish the repair process and launch QTP again

 

 

Note: The Opinions expressed in my post are mine alone, and do not reflect the opinions of my employer. No warranties express or implied for any answered posted.

Also remember if you have a valid contract with HP feel free to visit our FT/QTP Support Customer Forums: http://h30499.www3.hp.com/t5/Functional-Testing-QTP/ct-p/sws-Fun_Test
You can create an account with your HP credentials.

Please use plain text.
HP Expert
Ana_Noncheva
Posts: 245
Registered: ‎08-06-2013
Message 5 of 6 (846 Views)

Re: QTP 11.0 Script stops automatically on windows server 2008, IE8 it doesn’t navigate from one tab

Hi,

 

Following article suggests some fixes for similar IE automation problems, can you please try them? -> http://support.openview.hp.com/selfsolve/document/KM538333

I would also recommend you try optimizations in following article: http://support.openview.hp.com/selfsolve/document/KM177647

 

Hope they help,

Regards,

Ana

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Please use plain text.
Collector
JayaSehgal1
Posts: 2
Registered: ‎10-02-2013
Message 6 of 6 (824 Views)

Re: QTP 11.0 Script stops automatically on windows server 2008, IE8 it doesn’t navigate from one tab

Thanks a lot, this worked. My Script is working fine as of now. Need to check if it continues to be stable.

 

Thanks again

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation