Re: QTP 10 and IE 8 - Unable to Navigate URL. (2239 Views)
Reply
Advisor
Automation_lear
Posts: 21
Registered: ‎04-19-2012
Message 1 of 3 (2,251 Views)
Accepted Solution

QTP 10 and IE 8 - Unable to Navigate URL.

 

Hi Friends

 

I have Installed QTP 10.0 and IE 8.0. I installed the patch for IE8.0 from

http://knowledgeinbox.com/forums/hp-quicktest-pro-​patches/(qtp-10)(patch)-support-for-internet-expl...

 

Now, when I try to run the below script , Iam unable to navigate to URL ( www.google.com). I am able to get the handle of the browser , the third step executes successfully but still the www.google.com page does not appears, instead I still see the "About:blank"

 

  SystemUtil.Run "iexplore.exe", "about:blank"
  handle = Browser("title:=Blank Page.*").GetROProperty("hwnd") 
  Browser("hwnd:="& handle).Navigate "www.google.com"

 

 

earlier , These were working fine properly ,but then Since I wanted to test on IE 7 , I uninstalled IE 8 , then when I tried to install IE 8 and ran again, it gives me problem. I have uninstalled and installed QTP 10 also , but still no luck

 

Help me guys

HP Expert
bvalerio
Posts: 174
Registered: ‎04-13-2012
Message 2 of 3 (2,245 Views)

Re: QTP 10 and IE 8 - Unable to Navigate URL.

Hi,

Make sure the BHOManager Add-on is enable.

1) Close all instances of Internet Explorer.
2) Open a new browser window.
3) Go to Tools > Manage Add-ons > Select BHOManager Class > Click on the "Enable" button.

Hope this helps.
"HP Support
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution and give KUDOS to the author for their assistance".
Advisor
Automation_lear
Posts: 21
Registered: ‎04-19-2012
Message 3 of 3 (2,239 Views)

Re: QTP 10 and IE 8 - Unable to Navigate URL.

Wonderful, That worked .... Thanks a lot !!!!!!!

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.