Re: QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine (8353 Views)
Reply
Occasional Contributor
SubramanianKU
Posts: 8
Registered: ‎11-14-2011
Message 1 of 8 (8,400 Views)

QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine

[ Edited ]

We are trying to automate the actions performed in the SAP Net Weaver(SAP GUI for Windows) installed in Windows XP machine. But QTP is not recognizing the objects at all. We have SAP and Active-X add-ins with QTP10.0. When we try to spy (Object Spy) the objects, the objects are getting displayed but the corresponding properties are not displayed in the Object Spy window.

 

We also tried adding the objects to the Object Repository, but the objects are not getting added.

 

Please help us in resolving this issue As Soon As Possible.

 

Thanks in Advance!!

 

 

P.S. This thread has been moved from Quality Center Support and News Forum to Unified Functional Testing (formerly QTP) News and Support Forum.
-HP Forum Moderator

Regular Advisor
Geethika Enakulapati
Posts: 106
Registered: ‎03-31-2011
Message 2 of 8 (8,387 Views)

Re: QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine

Hello,

 

I too have the same problem. 

 

This was the reply we got from HP thru' SAP :-

"We have reviewed the SAP Netweaver Business Client (NWBC) product
in the past and found that this component is a rich desktop client
that provides a single point of entry for SAP and non-SAP application
including Web Dynpro and SAP GUI applications. Thus NWBC in itself
does not directly interact with the SAP server, it only provides
client side services or what is called a "canvas" in which SAPgui
applications run. For instance to run SAP GUI applications the latest
SAP GUI must still be installed.

As NWBC is a client side only component, it does not itself generate
server transactions and hence no recordable activity.

HP QuickTest Pro will also not record such client side only activity.
Within this context the recommended approach for load or functional
testing is to work directly with the SAP application you wish to
test, be that a SAP GUI or SAP Web based application. While this will
bypass NWBC it is unlikely that there is a need to directly test NWBC
component functionality."

 

 

Hope this answered your question. In case if you get to know the solution...Please let me.

 

 

Regards,

Geethika

Occasional Contributor
SubramanianKU
Posts: 8
Registered: ‎11-14-2011
Message 3 of 8 (8,376 Views)

Re: QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine

Hi ,

 

Thanks a lot Geethika for your response!!

 

We tried this earlier, when the SAP NetWeaver application was installed(as Build 1) for us. Using that build the objects were recognized by QTP 10.0 and we even automated one scenario. After this scenario got over, we got a fresh build for SAP NetWeaver application installed (Build 2). Now the objects not recognized by QTP.

 

Any idea why we are facing this issue. What changes could have been made in the application?

 

Also we checked the SAP GUI configuration settings in Control Panel and the 'Accessibility and Scripting' part is enabled.

 

Pls help in resolving this issue.

Regular Advisor
Geethika Enakulapati
Posts: 106
Registered: ‎03-31-2011
Message 4 of 8 (8,368 Views)

Re: QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine

Initially when I did the POC, it was recognizing couple of objects in NWBC and couple of them weren't. But later it completely stopped identifying. I'm really not sure what could have gone wrong. All we can do is just wait for HP or SAP to get back to us with a solution for the same.

 

 

In the meanwhile if you guys get a solution, please do let me know. 

 

Regards,

Geethika.

Occasional Contributor
SubramanianKU
Posts: 8
Registered: ‎11-14-2011
Message 5 of 8 (8,366 Views)

Re: QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine

Thanks a lot for your response.

 

Sure!! we will post any solution we get in this forum.

Occasional Contributor
SubramanianKU
Posts: 8
Registered: ‎11-14-2011
Message 6 of 8 (8,353 Views)

Re: QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine

Hi,

 

We requested the SAP development team (which they call the SAP Basis team) to expose the objects for scripting. It was done and QTP is now recognizing the objects.

 

We got the response that the objects were just exposed for it to be recognized by QTP.

 

Thanks a lot for you help!!

Regular Advisor
Geethika Enakulapati
Posts: 106
Registered: ‎03-31-2011
Message 7 of 8 (7,771 Views)

Re: QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine

Hello Subramanian,

 

Could you be more sepcific about this solution?? How did you get this fixed?? 

 

 

 

 

 

Thanks & Regards,

Geethika

Occasional Visitor
Guru_QTP
Posts: 1
Registered: ‎12-17-2013
Message 8 of 8 (7,476 Views)

Re: QTP 10.0 not recognizing the SAP Net Weaver objects installed in Windows XP machine

[ Edited ]

Hi Subramaniam / Geethika,

 

How difficult it would be for a QTP guy to work on SAP TAO?

 

I was placed on a SAP project for 2 weeks, during which Ive used PFA to create scenarios and then upload them to ALM for execution.

 

How far do u reckon I am to be a full fledge SAP TAO tester .

 

Does a SAP TAO user needs to be equipped with loads of SAP functional knowledge ?

 

 

 

 

 

 

thnx in advance

 

Regards

Srikar

 

 

 

 

 

 

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.