Internet Explorer 8 crashes when creating a QTP 11 test (1103 Views)
Reply
Occasional Contributor
andygagliardi
Posts: 5
Registered: ‎11-19-2012
Message 1 of 7 (1,103 Views)

Internet Explorer 8 crashes when creating a QTP 11 test

I am running QTP 11 (build 1018) and trying to record a test script with Internet Explorer 8.  When I get to a certain point in the recording, Internet Explorer crashes.  This happens at the same point every time and I have been able to reproduce the issue on another team members workstation with the same setup.  Any help would be most appreciated.

Please use plain text.
Occasional Visitor
ecavalcante2
Posts: 4
Registered: ‎02-21-2013
Message 2 of 7 (1,096 Views)

Re: Internet Explorer 8 crashes when creating a QTP 11 test

This error occurs to any WebSite or to a specific URL with a specific technology?
Please use plain text.
Occasional Contributor
andygagliardi
Posts: 5
Registered: ‎11-19-2012
Message 3 of 7 (1,092 Views)

Re: Internet Explorer 8 crashes when creating a QTP 11 test

It is a specific website/environment behind our firewall that we use for UAT testing.  When I am NOT recording on the same URL, internet explorer works fine and does not crash.

Please use plain text.
Occasional Visitor
ecavalcante2
Posts: 4
Registered: ‎02-21-2013
Message 4 of 7 (1,086 Views)

Re: Internet Explorer 8 crashes when creating a QTP 11 test

[ Edited ]

Try open your application manually and goes to the point where IE crashed, now, open the QTP and put the Spy pointer in the object that generated the crash, check if this object is identified correctly.

Please use plain text.
Occasional Contributor
andygagliardi
Posts: 5
Registered: ‎11-19-2012
Message 5 of 7 (1,078 Views)

Re: Internet Explorer 8 crashes when creating a QTP 11 test

The spy identifies the object correctly.

 

The issue I am having is not when my script is running.  It only happens when recording for the first time.  If I am not recording, the application and functions work perfect.

Please use plain text.
Occasional Visitor
ecavalcante2
Posts: 4
Registered: ‎02-21-2013
Message 6 of 7 (1,073 Views)

Re: Internet Explorer 8 crashes when creating a QTP 11 test

Well, try do this: Close the QTP and click in the menu Start -> HP QuickTest Professional ->Tools -> Additional Installation Requirements (If your OS is Win7, then run as administrator).

 

enable the first option (Configure Internet Explorer Settings) and disable the other options. Click in Run button, retart your OS and retest the scenario.

 

Can be some problem in the IE configuration or on your application, if is possible, upgrade your IE and check for updates of HP to update the QTP to new IE.

 

Sorry, i already saw this issue but don't remember the exact solution.

 

 

Please use plain text.
Occasional Contributor
andygagliardi
Posts: 5
Registered: ‎11-19-2012
Message 7 of 7 (1,069 Views)

Re: Internet Explorer 8 crashes when creating a QTP 11 test

OK, I'll give it a try. It's weird because a similar type of functionality works fine. It's just this one specific instance. It's too bad this is something I can not publicize to provide screenshots ( it's a governmental portal, plus behind firewall), otherwise I would post some.
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation