Re: Does QTP 10 support IE9? (4561 Views)
Reply
Visitor
georges123
Posts: 2
Registered: ‎06-28-2011
Message 1 of 13 (8,476 Views)

Does QTP 10 support IE9?

Hello,

 

I wrote some scripts on QTP 10 using IE 8. After I upgraded to IE 9, I can't run the scripts, even i could not record anything using IE 9.

Does QTP 10 support IE9?

 

 

Thank you,

Please use plain text.
Honored Contributor
Trudy Claspill
Posts: 3,384
Registered: ‎09-09-2010
Message 2 of 13 (8,449 Views)

Re: Does QTP 10 support IE9?

You may get a faster response if you post this question in the QTP forum - Product Families > Functional and Business Process Validation > Functional Testing/QTP
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Please use plain text.
Honored Contributor
Trudy Claspill
Posts: 3,384
Registered: ‎09-09-2010
Message 3 of 13 (8,447 Views)

Re: Does QTP 10 support IE9?

It does not appear that QTP v10 or v11 support IE 9 yet. I have QTP v11, and its documentation lists up to IE8 only, and there are no patches availble for that release yet.
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Please use plain text.
Honored Contributor
Trudy Claspill
Posts: 3,384
Registered: ‎09-09-2010
Message 4 of 13 (8,443 Views)

Re: Does QTP 10 support IE9?

[ Edited ]

I was mistaken.  QTP v11 apparently does support IE 9 with a patch

 

http://h20230.www2.hp.com/selfsolve/document/FID/DOCUMENTUM_QTPWEB_00078

 

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Please use plain text.
Occasional Contributor
wolfman_1
Posts: 5
Registered: ‎03-16-2011
Message 5 of 13 (8,435 Views)

Re: Does QTP 10 support IE9?

Link:

http://h20230.www2.hp.com/selfsolve/document/FID/D​OCUMENTUM_QTPWEB_00078

 

Does not work. Need IE9 patch urgently.

 

Thanks in advance

wolfgang

Please use plain text.
Honored Contributor
Trudy Claspill
Posts: 3,384
Registered: ‎09-09-2010
Message 6 of 13 (8,424 Views)

Re: Does QTP 10 support IE9?

Link works for me from my post, but not from your post.

 

Regardless, go to HP Support Online and go to the Self-Solve Advancece Search.  Check the box for Patches and enter the document ID as the keyword - KM1166929.  That should get you a link to the right patch.

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Please use plain text.
Visitor
georges123
Posts: 2
Registered: ‎06-28-2011
Message 7 of 13 (8,378 Views)

Re: Does QTP 10 support IE9?

Trudy,

 

Thanks for the information. But I could not find the patch, I was looking for the Patch in this page:

http://h20565.www2.hp.com/portal/site/hpsc/template.PAGE/public/kb/search/?spf_p.tpst=kbSearchMain&s...



 

 

Please use plain text.
Honored Contributor
Trudy Claspill
Posts: 3,384
Registered: ‎09-09-2010
Message 8 of 13 (8,363 Views)

Re: Does QTP 10 support IE9?

You won't find the patch by looking in the Patches area.  You have to look through the Self-Solve area for the Knowledge article.

 

I don't know why, but it seems that not all patches get listed in the Patches area.

 

I go to this site: http://support.openview.hp.com/

 

Sign in with HP Passport credentials (same as you use for this forum).

 

Click Self-Solve tab, and so on, as described in previous post.

 

Hope that helps.

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Please use plain text.
Occasional Visitor
Schuay
Posts: 2
Registered: ‎08-13-2011
Message 9 of 13 (8,133 Views)

Re: Does QTP 10 support IE9?

I got the below error i try  to access the page ....

 



Unable to access the page you requested

Contracts » List contracts » Investigate contract » Contact HP sales » Help Related links:   » Support home » Site map

Content starts here

Information

We were unable to access the page you requested due to one of the following reasons. 
*Additional Assistance options are located at the bottom of the page to submit a Trust case.

Reason Solution You do not have any support contracts in your HP Passport profile. Add a contract below. Support contract is invalid (e.g. hardware contract) Review your support contracts or initiate acontract investigation. Support contract has expired. Review your support contracts or contact HP sales for assistance. Contract identifier was entered incorrectly. Add a contract below. Support contract level is insufficient to access the page. Contact HP sales to obtain a higher level support contract. Add a contract to your profile Contract identifier (SAID)*  Add »  Assistance options
Please use plain text.
Acclaimed Contributor
Dennis Handly
Posts: 24,757
Registered: ‎03-06-2006
Message 10 of 13 (8,129 Views)

Re: Does QTP 10 support IE9?

>I got the below error i try  to access the page ....

 

You have to have a support contract:

http://support.openview.hp.com/access_level.jsp

Please use plain text.
Honored Contributor
Trudy Claspill
Posts: 3,384
Registered: ‎09-09-2010
Message 11 of 13 (8,111 Views)

Re: Does QTP 10 support IE9?

Well, it is true that if you want to get patches and "support" from HP you need a support contract with them.  I can't help you with that.  I'm just another HP customer.  You should contact HP or the company from which you purchased the product.

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Please use plain text.
Occasional Visitor
SarojBehera
Posts: 2
Registered: ‎11-04-2012
Message 12 of 13 (4,573 Views)

Re: Does QTP 10 support IE9?

Hi,

 

I am working on Windows 7 having QTP version 10.0(Concurrent Lincense) with IE8 but i am not able to download both of the supporting file qtp_0037 to support IE8 and qtp_664 to support Windows 7 from HP site. Can any one help me? 

 
Thanks,
Saroj Behera
Please use plain text.
Honored Contributor
Trudy Claspill
Posts: 3,384
Registered: ‎09-09-2010
Message 13 of 13 (4,561 Views)

Re: Does QTP 10 support IE9?

SarojBehera,

QTP specific questions need to be posted on the QTP specific forum.
http://h30499.www3.hp.com/t5/Functional-Testing-QTP/ct-p/sws-Fun_Test
And I would suggest that when you repost this question there you provide some specific information about what is not working when you try to download the patches.
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation