Re: Cannot retain the comment alignment when I open the script in QTP 11 (290 Views)
Reply
Advisor
adityasrinivasb
Posts: 55
Registered: ‎01-19-2011
Message 1 of 2 (327 Views)
Accepted Solution

Cannot retain the comment alignment when I open the script in QTP 11

Hi 

 

For every test script or Function, I first annotate them like this before writing the actual script

 

'======================

'TestName:        Test1

'Action Name:   Action 1

'======================

 

I write the above in UFT 11.5 and when I open the script in QTP 11, the aligment in the annotations are gone. 

It is something like this

 

'================

'Test Name :           Test 1

'ActionName: Action 1

'AUT:                         AUT

'Date Modified: Date
'===================

 

Why is this happening? Is it because the editors in both versions are different? How can I have a consistent aligment of text in the annotations I write. Can somebody please answer?

 

Regards

Srinivas

Regular Advisor
AnkurJain
Posts: 84
Registered: ‎06-05-2013
Message 2 of 2 (290 Views)

Re: Cannot retain the comment alignment when I open the script in QTP 11

[ Edited ]

As far as possible, try not to work backwards with QTP. While your scripts are compatible with the higher version but backward compatibility can sometimes be an issue.

 

Also, to save your time, try to take help of Action Templates in QTP

This will automatically insert a piece of text at the top of every action you create in UFT (QTP)

 

For some unknown reason, UFT 11.50 does not have Action Template feature, you should download 11.52 patch or get the latest version - UFT 12.

------------------------------------------------------------
Please make sure to "Kudos" on the left and mark the thread as resolved if this has answered your query.
------------------------------------------------------------
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.