Re: Tape Encryption Active. Huge Performance Hit. (199 Views)
Reply
Regular Advisor
L1nklight
Posts: 153
Registered: ‎01-30-2012
Message 1 of 2 (235 Views)

Tape Encryption Active. Huge Performance Hit.

I have an MSL2024 with an LTO5 drive attached via SAS. I am writing to tape via HP Data Protector 7.01. We decided to go with hardware based encryption via the MSL figuring that offloading the encryption piece to the MSL tape library would result in a smaller performance hit then doing software based encryption from data protector. Also we are probably going to be dumping Data Protector in the near future so having the encryption based off the tape library is probably a smarter idea in the long run. 

 

I have worked with IBM's TS4800 Express system and a few devices from Overland before with regard to hardware based encryption. I do know that there is occasionally a marginal hit to write speeds when you do encryption from a hardware perspective. My problem is that the MSL2024 seems to be incuring a 40+% performance hit with encryption turned on. Nothing has really changed from the Data Protector side of things. I am sending the exact same amount of data to the exact same target. I have a 1.6 TB job that used to run in about 12 to 14 hours and it's now on track to come in at 23 hours. I also had a 1.3 TB job that used to run about 10 to 13 hours and it ran in about 19 hours on Sunday. I went ahead and upgraded the firmware to both the library (6.00 / 3.20e) and the tape drive (Z65W) and that did not seem to help. 

 

Is this normal to incur such a huge performance hit with HP Tape Writers? This seems hugely inconvenient. This will force me to rework every one of my backup jobs and it looks like it's going to add like 20 hours total to my back up to tape schedule which, I am not certain I have. 

Valued Contributor
CLEB
Posts: 367
Registered: ‎11-11-2004
Message 2 of 2 (199 Views)

Re: Tape Encryption Active. Huge Performance Hit.

I have a mixture of MSL4048 and MSL2024 libraries attached via FC or Parallel SCSI.  I've enabled encryption on these via the USB encryption kit and have not noticed any speed decrease at all.

 

1.6TB should not take anywhere near the amount of time you seem to be experiencing, providing of course the data is streaming quickly enough to the tape drives.

 

Have you run Library and Tape Tools for performance and hardware testing?

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.