Re: 9B C4 error code (5693 Views)
Reply
9b
Visitor
9b
Posts: 3
Registered: ‎12-02-2013
Message 1 of 5 (5,733 Views)

9B C4 error code

Hi,

 

My device is a 1/8 G2 - Ultrium 448.

 

When I turn on the initial test finishing with the 9B C4 error code.

 

I have opened the device and I see the sled is skipping between the 3rd and 4th slot, far away from any sensor.

 

When I login via serial line, and send the ScanRange command the result is correct:

FLMON> scr 0 7 10
Slot: 00, Label: 000393L2
Slot: 01, Label: 000394L2
Slot: 02, Label: 000395L2
Slot: 03, Label: 000396L2
Slot: 07, Label: 000397L2
Slot: 06, Label: 000398L2
Slot: 05, Label: 000399L2
Slot: 04, Label: 000400L2
Command executed successfully

I think this is a firmware problem in the init routine.

 

The current firmware is:

FLMON> stat

Loader Information:
-------------------
HW Revision         : FF                Upgrade Personality : 02.16.02
HW Variant          : 00                OS Major Version    : 1
Firmware Revision   : 4.20              Firmware Build date : 09-05-2013
Robotic FW Revision : 2.50n             Robot FW Build date : 09-24-2012
Firmware Checksum   : 88A2              Bootcode Revision   : 0.60
Vendor ID           : HP                Product ID          : 1x8 G2 AUTOLDR
Serial Number       : MXA733003R        Library WWI         : 500110A00090CE4C
Library height      : 1U
Connection          : LUN               Language            : English
Network enabled     : Yes               DHCP enabled        : Yes
IP Address          :   192.168.10.99   Netmask             : 255.255.255.0
Gateway Address     :    192.168.10.3   MAC Address         : 001B787B634E
Network active      : Yes               Hostname            : FLX7B634E
Protocol Stack      : IPv4 only         SNMP enabled        : No
SNMP Target 1 Adr.  : 0.0.0.0
SNMP Target 2 Adr.  : 0.0.0.0
SNMP Target 3 Adr.  : 0.0.0.0
SNMP Community Name : public
Number of Powerups  : 6                 Minutes of Operation: 201
Odometer            : 0                 Robotics Temperature: 35.4
Inventory valid     : No                Robotic Conn. Speed : 57600 Baud
Barcode Reader      : CSE600
LED Status:
Ready               : Off               Clean               : Off
Attention           : Blinking          Error               : Blinking

Drive No. 0 Information:              ( LUN, SEQ )
------------------------
Vendor ID           : HP                Product ID          : Ultrium 2-SCSI
Product Revision    : S63W              Firmware Revision   : 010.704
Serial number       : HU10728VPU        Personality         : 2C 0B
Drive Temperature   : 35.0              Data compression    : Yes
Interface type      : SCSI              SCSI-ID             : 0

Media loads         : 4381              Cleaning operations : 5
Power on hours      : 22748             Media motion hours  : 695
Tape meters         : 9418414

Command executed successfully

Any idea?

 

Regards

 

Zoltan

 

Please use plain text.
Acclaimed Contributor
Torsten.
Posts: 23,253
Registered: ‎10-02-2001
Message 2 of 5 (5,726 Views)

Re: 9B C4 error code

The code means (as you surely already know):

 

9B - Sled position sensor not found

 

C4 - Sled movement to sensor during check on magazine type failed

 

 

This means, the sled did not move as expected while reading the magazine type or even it did not find the magazine type.

 

First I would inspect the magazine.

 

 

 

 

It was my plan to explore the serial connection, but I have never done this so far.

What type of cable and connection settings did you use?


Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! star in the left column!   
Please use plain text.
9b
Visitor
9b
Posts: 3
Registered: ‎12-02-2013
Message 3 of 5 (5,709 Views)

Re: 9B C4 error code

Hi Torsten!

 

Thank you for your reply.

 

I know what is this error code, as I wrote "I think this is a firmware problem in the init routine."

The firmware move the sled to a wrong position, of course in this case never will find the plastic sensor.

 

The serial cable is very simple.

Take a 4 pin RJ-11 plug, 4 pole telephony cable with enough lenth and a DB-9 or DB25 conenector.

 

Cable pinout is the follow:

RJ11   RS232

2 ----- RX

3 ----- TX

5 ----- GND

 

Set your terminal to 115200,8,N,1 and GO.

 

Regards

 

Zoltan

 

Please use plain text.
Acclaimed Contributor
Torsten.
Posts: 23,253
Registered: ‎10-02-2001
Message 4 of 5 (5,702 Views)

Re: 9B C4 error code

Thank you for information.

I never opened such box, because warranty will be void and there are no parts to replace inside.

I don't think there is a firmware problem, but likely a kind of mechanical problem (after 4381 tape loads).

I know such kind of problems from the older libraries (wrong step counting because of encoder disk/strip problems, etc.). The only spare part provided is the chassis...

Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! star in the left column!   
Please use plain text.
9b
Visitor
9b
Posts: 3
Registered: ‎12-02-2013
Message 5 of 5 (5,693 Views)

Re: 9B C4 error code

I think, you ingnore the first part of my post.

 

The ScanRange command is an autonomus command whis is scan the cartridges.

As you can see, this executes without any error.

In this case the robot firmware is know how to find the correct position for scanning.

 

Zoltan

 

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation