Re: opctrapi crashes in 8.60.501 OVO agent(HP UX) (688 Views)
Reply
Honored Contributor
Posts: 1,421
Registered: ‎04-19-2011
Message 1 of 3 (729 Views)
Accepted Solution

opctrapi crashes in 8.60.501 OVO agent(HP UX)

We have OMU 9.x server running and we are planning to use intermediate HP UX server to receive SNMP traps and forward messages to OMU 9.x server. Intermediate server has OVO agent 8.60.501. HP UX server does not have NNM installed.

 

We had done following,

 

1. Open up ports 161,162 on intermediary server

2. Ran "ovconfchg -ns eaagt -set SNMP_SESSION_MODE NO_TRAPD" and restarted OVO agent using ovc -kill, ovc -start

 

but in system.txt of intermediary server we are finding following errors,

 

0: ERR: Mon Apr 23 02:33:15 2012: ovcd (29435/34): (ctrl-45) Component 'opctrapi' with pid 29726 exited. Restarting component.
0: ERR: Mon Apr 23 02:38:56 2012: opctrapi (29818/1): [opcevti.cpp:1148]: Can't connect the OV daemon 'pmd' to open SNMP session: connect() failed: Connection refused (OVEvent Se
rver: blast.ux.com. Note that you can set the 'SNMP_SESSION_MODE' config variable to 'NO_TRAPD' or 'TRY_BOTH' to let opcevti work without the OV daemon.
Not owner (OpC30-202)

0: ERR: Mon Apr 23 02:44:36 2012: ovcd (29435/36): (ctrl-95) Component 'opctrapi' exceeded the automatic restart limit. Use 'ovc -start opctrapi'.

 

Not sure why opctrapi is still trying to connect through pmd process, since SNMP_SESSION_MODE is set to NO_TRAPD.

If this parameter is set I hope it should directly contact trapd process if I am not wrong.

 

If the problem lies with SNMP agent not started in node, can you please give me the commands to start SNMP agent on HP UX server.

 

Please help..

Trusted Contributor
Posts: 378
Registered: ‎11-23-2011
Message 2 of 3 (698 Views)

Re: opctrapi crashes in 8.60.501 OVO agent(HP UX)

SNMP

To Start

/sbin/init.d/snmpd

 

To Stop

/sbin/init.d/SnmpMaster stop

 

Make sure that SNMP port is not being used any anyother application.

Highlighted
Honored Contributor
Posts: 1,421
Registered: ‎04-19-2011
Message 3 of 3 (688 Views)

Re: opctrapi crashes in 8.60.501 OVO agent(HP UX)

Thanks for the reply.

 

Actually the problem happened because port 161 was blocked by some other process. Killed the process and then started opctrapi and it worked fine.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.