Upgrading OA 8.60.501 to 11.13 (685 Views)
Reply
Frequent Advisor
Brett Folkerth
Posts: 66
Registered: ‎03-07-2010
Message 1 of 13 (685 Views)

Upgrading OA 8.60.501 to 11.13

Hello,

 

I recently upgraded an OML installation from 9.01 to 9.11.040  (OML_00071).  While I was downloading the ISOs I decided to grab the Operations Agent 11.10 ISOs and upgrade them as well. I didnt see ISOs for 11.13 at the time and assumed that I would need to patch the agents to get them to this level

 

I ran  ./oainstall -i -m  to install the agent files into the repository but when I tried to deploy the agent to the management server itself  ( via oainstall.sh -i -a)  I got the error:

 

STATUS:   The product bundle selected is not supported on this node.

 

My agents are currently at 8.60.501.

 

So I did some more reading and saw that you could upgrade the 8.60.501 agent directly to 11.13 if you had the media. So I went back to the HP software site and found the 11.13 ISOs.  I tried to install these on my system and got the following error

 

ERROR:    An incompatible version of the HP Operations agent deploy component was found on the HPOM management server. Minimum Version required for registering the patch deployable packages is 11.02

 

So now I am at a bit of a loss.  What process do I need to follow to get my 8.60.501 agents updated to 11.13?

 

Any help would be greatly appreciated.


Thanks!

 

Brett

 

 

Please use plain text.
Regular Advisor
Raymond Meijer
Posts: 87
Registered: ‎02-20-2008
Message 2 of 13 (678 Views)

Re: Upgrading OA 8.60.501 to 11.13

What it says.

Upgrade to 11.02+ first, and then to 11.13.
11.00 is a media installation, 11.0x are patches.
11.10 is a media installation as well.
Please use plain text.
Frequent Advisor
Brett Folkerth
Posts: 66
Registered: ‎03-07-2010
Message 3 of 13 (674 Views)

Re: Upgrading OA 8.60.501 to 11.13

Thanks for the info!

 

However, even if I have the 11.10 and 11.13 media I need to go back to 11.00 to upgrade to 11.02?  I just read the Release notes again, and it states that:

 

By using the consolidated media version 11.13, you have an option to upgrade from Operations agent 8.53, 8.60. 11.0x or 11.10 to the following version in a single step:   Base media version (11.11)

 

How do I do that if it is trying to use a component that it detects as being out of date?  I feel like it is a catch-22.

 

I inherited this installation and it was out of date, but this is crazy!

 

Brett

Please use plain text.
HP Expert
Ramkumar Devanathan
Posts: 1,534
Registered: ‎07-31-2002
Message 4 of 13 (664 Views)

Re: Upgrading OA 8.60.501 to 11.13

Brett, just upgrade the agent on the server first to the latest versions. this is done using oainstall -i -a

 

Then attempt the deployable agent's registration on the OM server - done using the command you used - oainstall -i -m

 

The hint is in the error message you got...

 

"Minimum Version required for registering the patch deployable packages is 11.02"

 

Is this clear now?

 

- ramd.

HP Software Rocks!
Please use plain text.
Frequent Advisor
Brett Folkerth
Posts: 66
Registered: ‎03-07-2010
Message 5 of 13 (655 Views)

Re: Upgrading OA 8.60.501 to 11.13

Hi ramd

 

I did try and install the latest (from the mounted 11.13 ISO)   with the oainstall.sh -i -a  and I get the message

 

STATUS:  The product bundle selected is not supported on this node.  I looked at the oainstall.log and it doesn't tell me what pre-reqs it didn't meet!

 

Do I need to remove the local agent completely?

 

Brett

 

 

Please use plain text.
HP Expert
Ramkumar Devanathan
Posts: 1,534
Registered: ‎07-31-2002
Message 6 of 13 (651 Views)

Re: Upgrading OA 8.60.501 to 11.13

What's the OS you are running on the server?
HP Software Rocks!
Please use plain text.
Frequent Advisor
Brett Folkerth
Posts: 66
Registered: ‎03-07-2010
Message 7 of 13 (649 Views)

Re: Upgrading OA 8.60.501 to 11.13

RHEL 5.4 (Tikanga)

Please use plain text.
HP Expert
Ramkumar Devanathan
Posts: 1,534
Registered: ‎07-31-2002
Message 8 of 13 (646 Views)

Re: Upgrading OA 8.60.501 to 11.13

Worth checking the support matrix. I don't think RHEL 5.4 is supported with the latest agents. Then you can upgrade to the 11.00.044 agent first and then upgrade to a patch like 11.04.
HP Software Rocks!
Please use plain text.
Frequent Advisor
Brett Folkerth
Posts: 66
Registered: ‎03-07-2010
Message 9 of 13 (643 Views)

Re: Upgrading OA 8.60.501 to 11.13

I checked the SUMA.  The oldest version of RHEL that is supported for OA 11 or 11.1  is RHEL 5.7!   However, it shows that it is compatible with Cent-OS 5.4  (which is nearly identical).

 

This definitely leaves me with a problem.  I didn't even think that the server software would be compatible (9.10) but not the agent software.

 

Thanks!

 

Brett

Please use plain text.
HP Expert
tobias_m
Posts: 152
Registered: ‎05-06-2010
Message 10 of 13 (637 Views)

Re: Upgrading OA 8.60.501 to 11.13

Hello,

 

The problem is, that RHEL 5.4 is no longer supported by Red Hat, and therefore RHEL 5.4 is "supported with limitations".

That doesn't mean it doesn't work. But since Red Hat no longer supports this version, we only can offer limitted support.

 

Here is the extract from SUMA for OA 11.0x with all the notes:

 

RHEL5.4-OA11.0x-support.JPG

 

I would recommend you install the 11.00 Agent and then the 11.05 Agent patch.

RHEL 5.4 was still supported when OA 11.00 was released and thus it will install without problems.

 

If you absolutely want to use OA 11.11 or OA 11.13, you could install them with the "-minprecheck" option.

But then you're completely on your own, as OA 11.1x is not even supported with limitations on RHEL 5.4.

 

Best regards,

Tobias

 

Please use plain text.
Frequent Advisor
Brett Folkerth
Posts: 66
Registered: ‎03-07-2010
Message 11 of 13 (630 Views)

Re: Upgrading OA 8.60.501 to 11.13

Thanks a ton! 

 

This is super useful. I will grab the 11.00 agent ISOs and patches, and intall those until I can get the approvals to upgrade my OS!

 

Brett

Please use plain text.
Frequent Advisor
Brett Folkerth
Posts: 66
Registered: ‎03-07-2010
Message 12 of 13 (629 Views)

Re: Upgrading OA 8.60.501 to 11.13

Tobias,

 

Is it possible to load the 11.00 agent on the server ( oainstall -i -m) after I have already installed a later version?  Do I need to run the oacleanall.sh script?

 

Thanks

 

Brett

Please use plain text.
HP Expert
tobias_m
Posts: 152
Registered: ‎05-06-2010
Message 13 of 13 (626 Views)

Re: Upgrading OA 8.60.501 to 11.13

Hello Brett,

 

I don't think you can directly install the older 11.00 agent deployables when you already installed the 11.1x ones.

But I see no need to do that anyway. The version of the agent to deploy is independent of the agent version

on the management server. I would just keep the 11.1x deployables.

 

If you want to have the 11.00 deployables, you would need to first de-install the 11.1x deployables using

"oainstall -r -m" and then install the 11.00 agent deployables.

 

Best regards,

Tobias 

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation