Re: Unable to see virtual appliance in HP OMW 9.0 (1598 Views)
Reply
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 1 of 27 (1,623 Views)
Accepted Solution

Unable to see virtual appliance in HP OMW 9.0

Hello,

 

Hoping someone can direct me to the points I need to check. I have HP virtual appliance 11.11.025.0 and its integrated with HP OMW 9.0 but I dont see this in OMW. Can someone help here please.

 

Regards,

Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
HP Expert
KBerger
Posts: 171
Registered: ‎04-13-2010
Message 2 of 27 (1,621 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

What do you mean you do not see it. Did you add it as managed node?

 

Keith

HP Support

If you find that this or any post resolves you issue, please be sure to mark it as an accepted solution.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 3 of 27 (1,614 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Virtual appliance does not need to be added in OMW. It comes with the OM agent installed and all you have to input is the management server name and it should pop up in OMW console which is not happening...

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
HP Expert
KBerger
Posts: 171
Registered: ‎04-13-2010
Message 4 of 27 (1,607 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

The VA will do a certificate request and you should see this in the OMW GUI. But you will need to add a node otherwise you will have nothing to map it against.

 

 

HP Support

If you find that this or any post resolves you issue, please be sure to mark it as an accepted solution.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 5 of 27 (1,601 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Are you sure on this?

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
HP Expert
Rotax
Posts: 171
Registered: ‎03-21-2011
Message 6 of 27 (1,598 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Hello Sujith,

 

Yes, absolutely positive.

You deploy the VA as an OVF template to your ESXi host. When you start it up, it autoactivates itself and sends a certificate request to OMW. Unless you have setup OMW to auto-add nodes upon receiving a certificate request (which you probably would not), you will need to manually add the node, map the certificate request to it and grant the request.

Next, you will connect to the VA web console or to the VA terminal to configure the vCenter targets and any other configuration you may want to setup. And from OMW, you will deploy the related VISPI policies.

 

Br,

Thierry.

 

If you find this or any post resolves your issue, please make sure to mark it as an accepted solution

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 7 of 27 (1,597 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Forgot to add, already OM management server is there as certitficate server in ovconfchg file.

 

--Sujith

 

 

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
HP Expert
Rotax
Posts: 171
Registered: ‎03-21-2011
Message 8 of 27 (1,591 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Yep, when you deploy the VA, you specify the management server and certificate server. This is needed because the agent on the VA needs the information to perform the activation on the first boot.

 

Have you been able to add your VA to your OMW management server?

 

Br,

Thierry.

 

If you find this or any post resolves your issue, please make sure to mark it as an accepted solution

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 9 of 27 (1,587 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Thank you Rotax and KBerger. I added the node and manually triggered a certificate request from VA to management server and granted certificate. Now things seems to be fine.

 

I saw in the VA guide that once this done, virtual infrastructure policies needs to be deployed on management server. Is this correct? If at all you can let me know what needs to be done for the VA to work properly let me know.Thanks again!

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
HP Expert
KBerger
Posts: 171
Registered: ‎04-13-2010
Message 10 of 27 (1,584 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Once the VA is in OMW you can deploy the VCenter policies and VI-Discovery.

 

These policies are available under the

Infrastructure Management > en >

Virtualization Infrastructure > Policies grouped by vendor > VMware

vCenter - Quick Start

and Infrastructure Management > en >

Virtualization Infrastructure > Policies grouped by vendor > VMware

vCenter - Advanced

groups in the console tree of the HPOM console after you install the

Virtualization Infrastructure SPI on the HPOM management server. Deploy these policies on the

virtual appliance to start monitoring the vSphere environment

 

Keith

HP Support

If you find that this or any post resolves you issue, please be sure to mark it as an accepted solution.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 11 of 27 (1,567 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Thanks and sorry for not updating the thread. I have deployed the policies as you said but I get different errors as mentioned below. On my OMW server agent version is 11.02 and on virtual appliance agent version is 11.11 I guess. Sorry cant get the exact agent version on appliance now as the user I have is unable to login to the VA.

 

1.

At least one source of policy VI-VMwareVMFSUtilizationMonitor failed and could not
not reinitialized for 3 times. The evaluation of the
policy is stopped. (OpC30-3400)

 

2.
An error occurred in the processing of the policy 'VI-VMwareHostPhysicalMemoryHealthMonitor'. Please check the following errors and take corrective actions. (OpC30-797)
Initialization of collection source "OperationalState" failed. (OpC30-724)
Cannot find object 'MEMORY_HEALTH' in Coda object list. (OpC30-761)
Initialization of collection source "MemoryName" failed. (OpC30-724)
Cannot find object 'MEMORY_HEALTH' in Coda object list. (OpC30-761)
Initialization of collection source "MemoryCapacity" failed. (OpC30-724)
Cannot find object 'MEMORY_HEALTH' in Coda object list. (OpC30-761)
Initialization of collection source "MaxMemorySpeed" failed. (OpC30-724)
Cannot find object 'MEMORY_HEALTH' in Coda object list. (OpC30-761)
Initialization of collection source "HostUUID" failed. (OpC30-724)
Cannot find object 'MEMORY_HEALTH' in Coda object list. (OpC30-761)
Initialization of collection source "HostName" failed. (OpC30-724)
Cannot find object 'MEMORY_HEALTH' in Coda object list. (OpC30-761)
Initialization of collection source "HealthState" failed. (OpC30-724)
Cannot find object 'MEMORY_HEALTH' in Coda object list. (OpC30-761)

 

3.
An error occurred in the processing of the policy 'VI-VMwareTotalVMCPUUtilMonitor'. Please check the following errors and take corrective actions. (OpC30-797)
Error during evaluation of rule "Monitor host instances", threshold level "Critical threshold level" (OpC30-729)
Execution of instance filter script failed. (OpC30-714)
Perl Script execution failed: Can't locate OvTrace.pm in @INC (@INC contains: /opt/OV\lbin\eaagt\perl /opt/OV/lbin/eaagt/perl /var/opt/OV/bin/instrumentation /opt/OV/nonOV/perl/a/lib/5.8.8/x86_64-linux-thread-multi /opt/OV/nonOV/perl/a/lib/5.8.8 /opt/OV/nonOV/perl/a/lib/site_perl/5.8.8/x86_64-linux-thread-multi /opt/OV/nonOV/perl/a/lib/site_perl/5.8.8 /opt/OV/nonOV/perl/a/lib/site_perl .) at PerlScript line 56.
BEGIN failed--compilation aborted    (in cleanup) Can't locate OvTrace.pm in @INC (@INC contains: /opt/OV\lbin\eaagt\perl /opt/OV/lbin/eaagt/perl /var/opt/OV/bin/instrumentation /opt/OV/nonOV/perl/a/lib/5.8.8/x86_64-linux-thread-multi /opt/OV/nonOV/perl/a/lib/5.8.8 /opt/OV/nonOV/perl/a/lib/site_perl/5.8.8/x86_64-linux-thread-multi /opt/OV/nonOV/perl/a/lib/site_perl/5.8.8 /opt/OV/nonOV/perl/a/lib/site_perl .) at PerlScript line 56.
BEGIN failed--compilation aborted at PerlScript line 56.
. (OpC30-750)

 

Regards,

Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
HP Expert
Rotax
Posts: 171
Registered: ‎03-21-2011
Message 12 of 27 (1,563 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Hello Sujith,

 

The policies that you list were designed for the VMA, not for the VA.

You should deploy the policies that keith mentionned in an earlier post of this thread.

 

Br,

Thierry.

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 13 of 27 (1,557 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Thanks for opening my eyes Thierry. I went through the Vmware monitoring guide and it says "The Virtualization Infrastructure SPI 11.11 can be installed on the HPOM management server at the time of registering the deployment packages of the HP Operations agent 11.11". This step was not done because I do not see the SPI in OMW console. So I went to HP downloads section and see two things 1)Software, HP Operations Agent v11.11 - OA Virtual Appliance and 2)Software, HP Operations Agent v11.11 - Infra SPI Only. Which one needs to be downloaded here to monitor vsphere through virtual appliance?

I have started to getting confused as OMW is fairly new to me and have not done the administration of this tool before. Some questions for now?

1. My current agent version is 11.02 on OMW 9.00, so will the agent must get updated if at all I have to install SPI/policies for virtual appliance
2. Should I have to download just the infra SPI file and follow the instructions from page 56 in the attached PDF.

 

Many thanks,

Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
HP Expert
Rotax
Posts: 171
Registered: ‎03-21-2011
Message 14 of 27 (1,554 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Hello Sujith,

 

The short answer to your first question is:

 

  • VA requires VISPI 11.11
  • VISPI 11.11 is a subproduct of ISSPI 11.11
  • ISSPI 11.11 requires OA 11.11

To provide a little bit more context:

 

The Virtual Appliance (VA) came with OA (Operations Agent) version 11.11.

The VISPI (Virtual Infrastructure Smart Plug-In) developments for this VA were also delivered with VISPI 11.11

The VISPI is a subproduct of the ISSPI (Infrastructure SPI).

 

So, if you deploy the VA and you want to deploy the VISPI to this VA, you need to install the ISSPI 11.11 on your OMW server, in order to deploy the VISPI 11.11 policies to your VA.

 

Now, since the ISSPI is highly dependent on OA, it requires that OA be at a certain level. For ISSPI 11.11, the requirement is that OA be also at version 11.11 (or higher, even though no higher version has released yet). That's ok for your VA, since it is automatically version 11.11. But you will eventually redeploy the ISSPI to your whole environment, including your local agent on your OMW server. Therefore, you should plan to upgrade your environment to OA 11.11 before you adopt ISSPI 11.11.

 

Now to your second question: given the above, you would download the full OA 11.11 media, and register the OA 11.11 on your OMW 9.0 server along with the installation of ISSPI 11.11 so that you can deploy the OA 11.11 in your environment to start using ISSPI 11.11.

 

The installation guide documents how to install ISSPI 11.11 alone, but that is under the assumption that you previously registered and deployed OA 11.11. Indeed, you may continue to use an older version of ISSPI until you have completed the deployment of OA 11.11 in your environment. So you can have the following stepwise approach:

 

  1. Use an older version of OA and ISSPI
  2. Register OA 11.11 on your OMW server
  3. Deploy OA 11.11 in your environment
  4. Install ISSPI 11.11 on your OMW server (the page 56 of the installation guide that you refer to)
  5. Deploy ISSPI 11.11 in your environment

I hope I did not confuse you more.

 

Br,

Thierry.

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 15 of 27 (1,548 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Thank you again Thierry. Things are little clear now but has few more questions

 

1. Can the existing agent version 11.02 co-exist with 11.11 in OMW?

2. VA is already on agent 11.11 but on OMW, agent is running on 11.02 so can I deploy the existing SPI 11.02 on VA and will it work

3. Would you mind sharing the document which has step b step instructions to upgrade the current agent version to 11.11

4. Should I have to be very cautious when doing this upgarde? Any precautionary measures/checks that I need to take for this upgrade?

5. I can see Vcenter policies under "infrastructure management" policy group. Is this something that I can install on VA?

 

I am downloading Software, HP Operations Agent v11.11 - Windows ISO and Software, HP Operations Agent v11.11 - Infra SPI Only ISO as I am writing this comment.

 

Regards,

Sujith

 

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 16 of 27 (1,547 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Here are the current vcenter polices I can see

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 17 of 27 (1,536 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

I installed agent/ISSPI 11.11 on QA OMW server and registered it but still do not see VMware
vCenter - Quick Start or VMware
vCenter - Advanced under Infrastructure Management > en >Virtualization Infrastructure > Policies grouped by vendor

 

Regards,

Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
Frequent Advisor
PrzemekK
Posts: 39
Registered: ‎07-31-2012
Message 18 of 27 (1,531 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

[ Edited ]

did You run and Could you provide output and result of

 

cscript oainstall.vbs -i -a
cscript oainstall.vbs -i -m
 
 
cscript oainstall.vbs -inv -listall -includespi
did you use ISO Software_HP_Operations_Agent_v11.11_TC097-15012.iso
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 19 of 27 (1,521 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Sure! Here is the info you asked

 

******************************

I used Software_HP_Operations_Agent_v11.11_-_Windows_ISO_TC097-15019

C:\Users\svcacct-sitescope\Downloads\Software_HP_Operations_Agent_v11.11_-_Windo
ws_ISO_TC097-15019>cscript oainstall.vbs -i -a
Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.

INFO: Parsing and validating options for HP Operations agent on the node
INFO: Refer log file for progress details
INFO: Running the command: CMD /C C:\Users\svcacct-sitescope\Downloads\Software_
HP_Operations_Agent_v11.11_-_Windows_ISO_TC097-15019\packages\WIN\Windows_X64\oa
setup.exe  -install
CMD /C ""C:\Users\svcacct-sitescope\Downloads\Software_HP_Operations_Agent_v11.1
1_-_Windows_ISO_TC097-15019\packages\WIN\Windows_X64\oasetup.exe " -install "
INFO: Installer has detected the  LCore/shared component(11.11.25)on the system.

INFO: Checking if the pre-requisites for installation are met...
Prerequisites checked for: Windows6.1

Requirements:
-------------
[ PASS  ] Check if platform architecture is x64.
[ PASS  ] Check if DCE agent is not installed.
[ PASS  ] Check if Perfomance agent (Emulation mode) is not installed.
[ PASS  ] Check if XPL component is installed in emulation mode.
[ PASS  ] Check if 100MB of additional disk space is available for agent upgrade
.
[ PASS  ] Check if 50MB of disk space is available for agent runtime.
[ PASS  ] Check if Administrators group have default launch permissions.
[ PASS  ] Check if MSI engine version is greater than 2.0.
[ PASS  ] Check if Operations agent version installed is supported for upgrade [
version>=8.17].
[ PASS  ] Check if Performance agent version installed is supported for upgrade
[version>=4.7].
[ PASS  ] Check if Event Log Service is configured.
[ PASS  ] Check if Remote Procedure Call (RPC) Service is configured.
[ PASS  ] Net Logon Service
[ PASS  ] Check if Security Accounts Manager Service is running.

Recommendations:
----------------
[ PASS  ] Check if Windows Management Instrumentation Service is running.
[ FAIL  ] SNMP Service
SNMP Service is not running or installed. SNMP service is required for MIB monit
oring, to collect SNMP events and discover node properties.
-----------------------------------------------------------------------
STATUS: All requirements are OK; at least one recommendation has failed.
================================================================================
==
        HP Operations agent installation started on Wed Mar 27 08:15:20 2013
================================================================================
==
INFO: Log file for the installation is at :
E:/ProgramData/HP/HP BTO Software/log/oainstall.log.
INFO: Windows Installer log file for the current operation is at :
C:/Users/SVCACC~1/AppData/Local/Temp/2//oainstaller.log.
INFO: Installing the component HPSharedComp ...
INFO: Found the packages to be of the version HPSharedComp(11.11.025)
INFO: Found HPSharedComp(11.11.25) installed. Skipping installation...
INFO: Installing the component HPOvPerlA ...
INFO: Found the packages to be of the version HPOvPerlA(05.08.096)
INFO: Found HPOvPerlA(5.8.96) installed. Skipping installation...
INFO: Installing the component HPOpsAgt ...
INFO: Found the packages to be of the version HPOpsAgt(11.11.025)
INFO: Found HPOpsAgt(11.11.25) installed. Skipping installation...
INFO: Performing the activation for the product...
INFO: Product activation completed successfully for the product.
INFO: HP Operations agent install operation completed successfully at Wed Mar 27
 08:15:35 2013
.
INFO: Changes made in system environment variables will be effective in new shel
l

C:\Users\svcacct-sitescope\Downloads\Software_HP_Operations_Agent_v11.11_-_Windo
ws_ISO_TC097-15019>cscript oainstall.vbs -i -m
Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.

INFO: Registering the HP Operations agent deployment packages on the management
server
INFO: Backing up older version of the HP Operations agent packages for Windows_X
86 platform
INFO: Backing up older version of the HP Operations agent packages for Windows_X
64 platform
INFO: Successfully backed up all the packages
INFO: Registering the HP Operations agent [11.11.025] packages of Windows_X64 pl
atform for deployment
INFO: Successfully registered the HP Operations agent packages for the Windows_X
64 platform
INFO: Registering the HP Operations agent [11.11.025] packages of Windows_X86 pl
atform for deployment
INFO: Successfully registered the HP Operations agent packages for the Windows_X
86 platform

C:\Users\svcacct-sitescope\Downloads\Software_HP_Operations_Agent_v11.11_-_Windo
ws_ISO_TC097-15019>cscript oainstall.vbs -inv -includespi
Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.

Active Versions
===============
AIX     :PowerPC(64)    :11.00.044
HP-UX   :IPF32          :11.00.044
HP-UX   :PA-RISC        :11.00.044
LIN     :PowerPC(2.6)   :11.00.044
LIN     :x64(2.6)       :11.00.044
LIN     :x86(2.6)       :11.00.044
SOL     :SPARC          :11.00.044
SOL     :x86            :11.00.044
WIN     :x64            :11.11.025
WIN     :x86            :11.11.025

Active Agent Patches Installed
==============================
OAAIX_00002     :AIX            :PowerPC(64)    :11.01.003
OALIN_00002     :LIN            :PowerPC(2.6)   :11.01.003
OALIN_00002     :LIN            :x64(2.6)       :11.01.003
OALIN_00002     :LIN            :x86(2.6)       :11.01.003
OASOL_00002     :SOL            :SPARC          :11.01.003
OASOL_00002     :SOL            :x86            :11.01.003

***************************

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 20 of 27 (1,520 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

C:\Users\svcacct-sitescope\Downloads\Software_HP_Operations_Agent_v11.11_-_Windo
ws_ISO_TC097-15019>cscript oainstall.vbs -inv -listall -includespi
Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.

Active Versions
===============
AIX     :PowerPC(64)    :11.00.044
HP-UX   :IPF32          :11.00.044
HP-UX   :PA-RISC        :11.00.044
LIN     :PowerPC(2.6)   :11.00.044
LIN     :x64(2.6)       :11.00.044
LIN     :x86(2.6)       :11.00.044
SOL     :SPARC          :11.00.044
SOL     :x86            :11.00.044
WIN     :x64            :11.11.025
WIN     :x86            :11.11.025

Active Agent Patches Installed
==============================
OAAIX_00002     :AIX            :PowerPC(64)    :11.01.003
OALIN_00002     :LIN            :PowerPC(2.6)   :11.01.003
OALIN_00002     :LIN            :x64(2.6)       :11.01.003
OALIN_00002     :LIN            :x86(2.6)       :11.01.003
OASOL_00002     :SOL            :SPARC          :11.01.003
OASOL_00002     :SOL            :x86            :11.01.003

 

Backed-up Versions
==================
AIX     :PowerPC(32)    :08.60.005
AIX     :PowerPC(64)    :08.60.005
HP-UX   :IPF32          :08.60.005
HP-UX   :PA-RISC        :08.60.005
LIN     :IPF64(2.6)     :08.60.005
LIN     :x64(2.6)       :08.60.005
LIN     :x86(2.6)       :08.60.005
SOL     :SPARC          :08.60.005
SOL     :x86            :08.60.005
WIN     :IPF64          :08.60.010
WIN     :x64            :08.60.010
WIN     :x86            :08.60.010
WIN     :IPF64          :11.00.044
WIN     :x64            :11.00.044
WIN     :x86            :11.00.044

Backed-up Agent Patches Installed
=================================
OAWIN_00002     :WIN            :IPF64          :11.01.003
OAWIN_00002     :WIN            :x64            :11.01.003
OAWIN_00002     :WIN            :x86            :11.01.003

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
Frequent Advisor
PrzemekK
Posts: 39
Registered: ‎07-31-2012
Message 21 of 27 (1,514 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

[ Edited ]

I see that SPI was not installed.
That iso have about 2 GB ? Do you have integration\infraspi folder ?

Please verify if folders exists

echo %temp% & echo %OVCSL_USER_TMP%

Check -i -m logs at %OvOWShareInstallDir% \ server \ log oainstall.log

 

AHh you used Software, HP Operations Agent v11.11 - Windows ISO ( TC097-15019.iso )

This iso dont have SPI as i know

Try Software_HP_Operations_Agent_v11.11_TC097-15012.iso

 

Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 22 of 27 (1,505 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

The zipped file size is 215 MB. I do not see integration folder. Can you please pin point me the exact location of this folder in your environment. I am using OMW by the way.

 

The oainstall.log looks clean. No errors

 

I see Software, HP Operations Agent v11.10 ( TC097-15012.iso ) in downloads list but in file name it says 11.10 but it also says

Version: 11.11

and file size is 1.98 GB by the way. Do you think I should try this?

 

Also, can I directly install the agent on top of the existing agent?

 

If at all I want to revert back to previous agent which is 11.02 how can I fo it?

 

Regards,

Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
HP Expert
Rotax
Posts: 171
Registered: ‎03-21-2011
Message 23 of 27 (1,497 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Hello Sujith,

 

You used the media for the Windows agent.

There is a seperate media for each media platform and a consolidated media with all agent platforms.

The ISSPI cannot be broken down by platform, hence it is only available from the consolidated media.

 

Do take note that 11.11 is a media release, hence you are doing an upgrade (not an update as you would with an OA patch like 11.05). You should plan this appropriatly. For instance carefully read the OA 11.11 and ISSPI 11.11 release notes, and verify in our support matrix that this version supports the platforms in your environment, and interoprates with any other HP software installed on the nodes where you will deploy this OA and ISSPI version.

 

Best regards,

Thierry.

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please use plain text.
Frequent Advisor
PrzemekK
Posts: 39
Registered: ‎07-31-2012
Message 24 of 27 (1,487 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

You should look at your polices. What version of SPI is used. In perfect case i would recommend:

 

Uninstall instrumentations from nodes

uninstall polices

uninstall spi if any

install agent 11.11 and spi on OMW

deploy new agent, instrumentations and polices on nodes

remove old agent binaries

 

Its complex and i think you should plan in carefully

 

 

Please use plain text.
Honored Contributor
Sujith Kumar C.S
Posts: 868
Registered: ‎04-07-2010
Message 25 of 27 (1,480 Views)

Re: Unable to see virtual appliance in HP OMW 9.0

Thanks Thierry. I downloaded the other iso file I spoke about which is of size 2 GB and it had all the SPI and agent upgrade for all platforms and installed it. Now I can see ISPI policies have been upgraded and do see vcenter policies in OMW. Thanks much!

 

Another question? Can both the agents 11.02 and 11.11 co-exist on OMW? If not, I will be forced to upgrade agent version on nodes currently running on 11.02 to 11.11 if I am depliying ISPI policies as they are on 11.11

 

Also, if I am deploying other policies like AD, DB SPI which are still on older version I do not have to upgrade the agent on node..correct?

 

Regards,

Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation