Opcmona daemon aborted on RHEL 5.4 (530 Views)
Reply
Occasional Visitor
wanare
Posts: 2
Registered: ‎12-16-2013
Message 1 of 3 (530 Views)

Opcmona daemon aborted on RHEL 5.4

 Hi ,

 

I am facing some problem with opcmona daemon was abortd on RHEL 5.4. Please any one provide solution for that issue.

 

Please check below details.

 

OS : RHEL 5.4 (64 bits)

HPOM agent version :  HP Software Control 11.05.005
Service status :

 

coda        OV Performance Core                 COREXT       (25156)  Running
opcacta     OVO Action Agent                    AGENT,EA     (25163)  Running
opcle       OVO Logfile Encapsulator            AGENT,EA     (25124)  Running
opcmona     OVO Monitor Agent                   AGENT,EA              Aborted
opcmsga     OVO Message Agent                   AGENT,EA     (25133)  Running
opcmsgi     OVO Message Interceptor             AGENT,EA     (25168)  Running
ovbbccb     OV Communication Broker             CORE         (24922)  Running
ovcd        OV Control                          CORE         (24914)  Running
ovconfd     OV Config and Deploy                COREXT       (24945)  Running

logs :

 

0: INF: Mon Dec 16 10:55:56 2013: ovconfd (24945/47499611498144): (conf-390) Configuration and Deploy process 'ovconfd' started.
0: ERR: Mon Dec 16 10:56:03 2013: ovcd (24914/1095338304): (ctrl-94) Component 'opcmona' exited after very short runtime, therefore it will not be automatically restarted. Use 'ovc -start opcmona'.
0: INF: Mon Dec 16 10:56:04 2013: coda (25156/47498145662592): Waiting to initialize SCOPE ...
0: INF: Mon Dec 16 10:56:10 2013: coda (25156/47498145662592): SCOPE datasource initialization succeeded
0: WRN: Mon Dec 16 11:01:30 2013: ovcd (24914/1095338304): (ctrl-208) Component 'opcmona' with pid 2422 exited with exit value '1'. Restarting component.
0: ERR: Mon Dec 16 11:01:35 2013: ovcd (24914/1122523456): (ctrl-42) Initialization of component 'opcmona' failed. Stopping component.
0: ERR: Mon Dec 16 11:01:35 2013: ovc (2418/46998143965680): (ctrl-7) Error in the target component.
0: WRN: Mon Dec 16 11:01:35 2013: ovcd (24914/1095338304): (ctrl-208) Component 'opcmona' with pid 2444 exited with exit value '1'. Restarting component.
0: ERR: Mon Dec 16 11:01:40 2013: ovcd (24914/1107822912): (ctrl-42) Initialization of component 'opcmona' failed. Stopping component.
0: WRN: Mon Dec 16 11:01:41 2013: ovcd (24914/1095338304): (ctrl-208) Component 'opcmona' with pid 2486 exited with exit value '1'. Restarting component.
0: ERR: Mon Dec 16 11:01:46 2013: ovcd (24914/1107822912): (ctrl-42) Initialization of component 'opcmona' failed. Stopping component.
0: WRN: Mon Dec 16 11:01:46 2013: ovcd (24914/1095338304): (ctrl-208) Component 'opcmona' with pid 2526 exited with exit value '1'. Restarting component.
0: ERR: Mon Dec 16 11:01:51 2013: ovcd (24914/1107822912): (ctrl-42) Initialization of component 'opcmona' failed. Stopping component.
0: ERR: Mon Dec 16 11:03:51 2013: ovcd (24914/1107822912): (ctrl-41) Timeout while starting component 'opcmona'.

 

Esteemed Contributor
J. Maestre
Posts: 282
Registered: ‎01-07-2010
Message 2 of 3 (495 Views)

Re: Opcmona daemon aborted on RHEL 5.4

I'd suggest (if possible) to upgrade the agent to version 11.12 or 11.13.

I haven't had much luck with the 11.0x agent: subagents aborting, process monitors not working, javaUI tools failing to run...

 

Other than that, if updating is not an option, I would try stopping the agent and deleting the message queues (/var/opt/OV/tmp/OpC/*). 

If opcmona still keeps aborting, disable all policies and see if agent remains stable. If it does, re-enable the policies one at a time to check if there's a specific policy causing issues.

 

IIRC there's a know problem with the OM agent (fixed in 11.12 or 11.13, I don't remember which exactly) where opcmona would abort frequently when deploying policies with embedded perl scripts. 

Occasional Visitor
wanare
Posts: 2
Registered: ‎12-16-2013
Message 3 of 3 (477 Views)

Re: Opcmona daemon aborted on RHEL 5.4

Hi ,

 

I will proceed for upgrade the HPOA from 11.05 to 11.11 but still I was facing some issue to perquisite not matched.

But from server side I have checked enough space available on /var and /opt filesystem. Also verified require library is higher version on server. I hope issue not with library files.  Even I can't indentified cause on basis of log.

 

Kidnly please check below logs .

 

Fri Dec 20 13:07:13 CET 2013:  Setting up command line arguments
Fri Dec 20 13:07:13 CET 2013:  Args used: -upgrade <Manager IP> -force
Fri Dec 20 13:07:14 CET 2013:  Agent upgrade with activation for new OM server: <Manager IP>
Fri Dec 20 13:07:14 CET 2013:  Skipping port and DNS check - force option specified.
Fri Dec 20 13:07:15 CET 2013:  Old DIS configuration found in /etc/opt/osit/ESAR, backup to /var/tmp/old_ESAR_bkp/etc/ESAR
Fri Dec 20 13:07:15 CET 2013:  Backup of old datasources list file(s) to /var/tmp/old_ESAR_bkp folder.
Fri Dec 20 13:07:15 CET 2013:  Backup of /var/opt/OV/conf/perf/datasources to be done.
Fri Dec 20 13:07:16 CET 2013:  Verifying <Hostname> is ready for Agent 11
Fri Dec 20 13:07:16 CET 2013:  FAIL
Fri Dec 20 13:07:16 CET 2013:  Prequisite Check on bbnapp01 failed
Fri Dec 20 13:07:16 CET 2013:  Fix the failed prechecks listed in /var/tmp/HPOA_11_Inst.log and try installation again.
INFO:    HP Operations-agent install options are:  -install -precheckonly
INFO:    Validating pre-requisites for installation on <Hostname>

STATUS: The product bundle selected is not supported on this node.

ERROR:   <Hostname> does not meet all pre-requisites. Refer log file /var/opt/OV/log/oainstall.log for details

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.