Re: OVO composer circuit ( .fs ) installed but not working (112 Views)
Reply
Honored Contributor
ramesh9
Posts: 1,061
Registered: ‎04-19-2011
Message 1 of 4 (168 Views)
Accepted Solution

OVO composer circuit ( .fs ) installed but not working

Operations Manager for Unix

 

We developed OVO composer circuit using ovocomposer tool ( ovocomposer -ui ) for enhancing severity of OVO messages.

It is installed and when the message comes it is not working which means severity is not enhanced.

 

On checking I checked following,

 

1.  Server MSI is enabled

2.  ECS process is running ( opcsv -status )

3.  /var/opt/OV/conf/OpC/mgmt_sv/ contains 3 files ( ec, ecs_comp.eco, ecs_comp.fs )

4.  "ecsmgr -i 11 -info" output shows following,

 

        engine environment - Standalone Engine 

        engine instance - 11 
        engine version - ECS 3.31 (A.03.31) 
        time last started - Tue Mar  4 04:05:58 2014 
        engine trace mask - 0x0 
        engine log mask - 0xffffffff 
        maximum engine log size - 512 KBytes 
        maximum event log size - 512 KBytes 
        input event logging - off 
        default drill info logging - off 
        default drill event logging - off 
        automatic configuration saving - on  

        stream name - default 
        stream policy - output (unless discarded by a circuit) 
        stream event logging - off 
        stream policy event logging - off 
        stream drill info logging - off 
        stream drill event logging - off 
        circuits enabled in stream - <none>

 

When I checked in another server, I am seeing the last line,

 

         circuits enabled in stream - circuit ecs_comp

         circuit name - ecs_comp
         circuit date - Thu Apr 29 15:59:48 2004

 

Does it mean ecs_comp is not installed on problematic server? If yes what are the steps to resolve?

 

Please help.

Please use plain text.
HP Expert
GTrejos7
Posts: 200
Registered: ‎07-14-2011
Message 2 of 4 (133 Views)

Re: OVO composer circuit ( .fs ) installed but not working

Hello Ramesh,

 

Please to make sure that you assigned the Correlation Composer policy to the OM management server itself which has been assigned and distributed.  You can check with:

 


# ovpolicy -list -targetovrg server
       * List installed policies for host 'localhost'.

     Version            Status
 -------------------------------------------------

-------------------
  ec                "Correlation Composer"      enabled    0009.0000

 

Best regards,

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
If you liked it I would appreciate KUDOs.
Please use plain text.
Honored Contributor
ramesh9
Posts: 1,061
Registered: ‎04-19-2011
Message 3 of 4 (125 Views)

Re: OVO composer circuit ( .fs ) installed but not working

Hi

 

Thanks for your reply.

 

We checked and we found it is deployed and enabled.

 

Thanks

Please use plain text.
Honored Contributor
ramesh9
Posts: 1,061
Registered: ‎04-19-2011
Message 4 of 4 (112 Views)

Re: OVO composer circuit ( .fs ) installed but not working

Hello Everyone

 

Solved this issue, the issue was Server ECS was not enabled.

 

If you run "ecsmgr -i 11 -info" and if the output shows a line like,

 

circuits enabled in stream - <none>

 

 

this means that Server ECS is not enabled.

 

To solve it do following,

 

1.    Make sure /var/opt/OV/conf/OpC/mgmt_sv/ecs_comp.fs file is present

2.    Make sure /var/opt/OV/conf/OpC/mgmt_sv/ directory contains the files ec, ecs_comp.eco, ecs_comp.fs

3.    Run following commands,

 

        ecsmgr -i 11 -disable ecs_comp
        ecsmgr -i 11 -circuit_reload ecs_comp /var/opt/OV/conf/OpC/mgmt_sv/ecs_comp.eco 0 ecs_comp
        ecsmgr -i 11 -enable ecs_comp
        ecsmgr -i 11 -update ecs_comp /var/opt/OV/conf/OpC/mgmt_sv/ecs_comp.fs

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation