Re: OMW9.0 Integration with SM9.30 Using SC Auto (928 Views)
Reply
Occasional Advisor
Shuvankar
Posts: 15
Registered: ‎08-30-2013
Message 1 of 16 (1,027 Views)
Accepted Solution

OMW9.0 Integration with SM9.30 Using SC Auto

Hi,

  

I'm using OMW9.0 and my scauto version is 4.0.3. I have installed SCAuto for OMW 1.5.0. But after installation there is no default policy for service manager under omw console. So, tried to deploy the policy config.mm file manually with command "ovpmutil" which is located at SCAuto installation directory and it's shows the following error--

 

 

"Wrong syntax of .mm file. Probably you are using .mm file generated with older version of OvPmad."

 

i think its need .xml file for this omw version. But i don't know how it will be generate as there is no config.xml. Plz help me

 

 

Rgrds

Shuvankar

Honored Contributor
m_vidyasagar
Posts: 628
Registered: ‎04-21-2011
Message 2 of 16 (998 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

(a) Have you properly used the double quotes ??

 

(b) Send the command which you have used ..

 

(c) attach the screenshot of the SCAuto policy contents , just to check what files are listed in it ..

 

 

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Occasional Advisor
Shuvankar
Posts: 15
Registered: ‎08-30-2013
Message 3 of 16 (993 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

thnx for the rply

 

yes i have properly used double quotes for the path. Plz find the attachment for that config file and the screenshoot

 

rgrds

Shuvanakar

Honored Contributor
m_vidyasagar
Posts: 628
Registered: ‎04-21-2011
Message 4 of 16 (989 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

can you attach the policy folder of scauto , so that i can try in test machine ??

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Occasional Advisor
Shuvankar
Posts: 15
Registered: ‎08-30-2013
Message 5 of 16 (984 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

plz find the attachment 

Honored Contributor
m_vidyasagar
Posts: 628
Registered: ‎04-21-2011
Message 6 of 16 (970 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

Hi Shuvankar,

 

I'm able to import without any error , see the below pic ..

 

Capture.JPG

 

I have used the same command : C:\Users\om.admin>ovpmutil cfg pol upl "c:\Users\om.admin\Desktop\Policies

\Policies\config.mm"

 

What's ur mgmt server patch level ( use "vpstat -p" command ) ..??

 

The possible reason for the error which you are getting , you are running with the older ovpmad version , update the mgmt server patch level and it shall resolve your issue ..

 

fyi : I'm running on the latest patch on my mgmt server ( i.e. OMW_00184 )

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Occasional Advisor
Shuvankar
Posts: 15
Registered: ‎08-30-2013
Message 7 of 16 (954 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

i have installed the patch OMW_00184 but my issue is not solved. When i run the command its still showing that error --

 

"Wrong syntax of .mm file. Probably you are using .mm file generated with older version of OvPmad"

 

 

Shuould i need to installed OMW_00178 patch prior to OMW_00184?

Honored Contributor
m_vidyasagar
Posts: 628
Registered: ‎04-21-2011
Message 8 of 16 (951 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

[ Edited ]

Patch OMW_00184  ???  I'm really sorry , my apolozies for wrong patch name ..

 

There are 2 types of patch for OMW : Mgmt patch and SrvAcc  ..

 

Patch OMW_00184 is related to the SrvAcc , You need not to worry as it will update your tomcat and other components :) ..

 

Install the OMW_00178 , this should resolve the issue ..

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Occasional Advisor
Shuvankar
Posts: 15
Registered: ‎08-30-2013
Message 9 of 16 (940 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

after the installation of OMW_178 patch still i'm getting the same error. But one new file has generated as config.mmTEMP under the SCAuto policy folder. I already run that file with "ovpmutil" comand but the error is same

Honored Contributor
m_vidyasagar
Posts: 628
Registered: ‎04-21-2011
Message 10 of 16 (928 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

[ Edited ]

attach the output of "vpstat -z" ..

 

also , %ovinstalldir%\Patches\OMW_00178\patch.log

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Occasional Advisor
Shuvankar
Posts: 15
Registered: ‎08-30-2013
Message 11 of 16 (924 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

rgrds

shuvnkr

Honored Contributor
m_vidyasagar
Posts: 628
Registered: ‎04-21-2011
Message 12 of 16 (918 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

I see the below line in the output of "vpstat -z" :

 

STATUS:

(REQCHK8008) Client running under user account 'emsadmin (TSCB\emsadmin)' does not have administrative privilege on node 'OMWSPIDC001.TSCB.COM'.

 

Please check if the emsadmin user has the admin privileges .. if it does , then run the command prompt as administrator ( Right click on the cmd and then select 'run as administrator' ) and re-run the ovpmutil command again .. 

 

Ll check out the rest of the log and will let you know if any pointers are there ..

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Honored Contributor
m_vidyasagar
Posts: 628
Registered: ‎04-21-2011
Message 13 of 16 (916 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

Surprise !! I see you Operation Agent is 8.60.10 , upgrade the OA to 11.10 or higher  ..

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Occasional Advisor
Shuvankar
Posts: 15
Registered: ‎08-30-2013
Message 14 of 16 (905 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

Issue has resolved thanx buddy :)

 

and for agent asper your suggestion, i have to install 11.10 which i need to publish plz let me know how to publish it? i have the OA 11.10 package. 

Honored Contributor
m_vidyasagar
Posts: 628
Registered: ‎04-21-2011
Message 15 of 16 (901 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

Ohh At last !!  :) , by looking at your screenshot in the first post , I thought somewhere in my mind like you haven't run the command prompt as administrator , but its my fault as I could pin point it , sorry for dragging ..

 

You have OA 11.10 ,  seems like you have registered the OA to mgmt server but not installed it ..

 

(a) First you need to register the agent to mgmt server : 

 

Cscript oainstall.vbs –i –m

 

If you had done this then proceed to the next step ..

 

(b) Install the agent of the mgmt server :

 

Cscript oainstall.vbs –i –a

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Advisor
tbokhary
Posts: 20
Registered: ‎06-27-2011
Message 16 of 16 (627 Views)

Re: OMW9.0 Integration with SM9.30 Using SC Auto

Where can I download SCAuto and manual for OMW integration?

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.