Re: OMU on Solaris 10 (633 Views)
Reply
Honored Contributor
Frank Saxton
Posts: 785
Registered: ‎07-30-2000
Message 1 of 26 (633 Views)

OMU on Solaris 10

Has anyone installed OVO 8.x on Solaris 10? If so,I would love to talk to you! I now have it running but it was a bloody, painful process to get here. And I still have some pretty major problems. HP Support has not been particularly helpful. I'm beginning to suspect that there are very few if any groups actually running this configuration.

Needless to say, there is some MAJOR management unhappiness here regarding how things are going.

Because OVO and Solaris 10 are so popular, I've been going on the assumption that lots of people are running in this configuration. I'd just like to confirm that assumption.

I'd also like to know what the latest version of OVO 8 for Solaris 10 ON CD is. I'm being told that it's 8.1, which is 4 years old and requires a lot of work to install.

My NNM 7.53 CD is three months old. My OVO 8.1 CD is four years old. This seems peculiar to me. Points for useful help, of course
Honored Contributor
Drew Dimmick
Posts: 8,053
Registered: ‎11-16-2002
Message 2 of 26 (633 Views)

Re: OMU on Solaris 10

Fred, please post your support case #'s

8.1 is the latest distribution - no updates - you get those through the patches (8.30 being the latest).

D
I do "Windows"
Advisor
dj tech
Posts: 13
Registered: ‎07-16-2008
Message 3 of 26 (633 Views)

Re: OMU on Solaris 10

I installed OVOU on Solaris 9 last year. It was with Veritas cluster 4 and the DBA at this company had to setup the Oracle server in advance because of company policy. The Oracle server was local in a seperate resource group and I told the install that it was a remote system.

Needless to say I ran in to many issues where the install script would fail (DB setup, cluster recognition ect). To get anywhere fast you will have to pick the install script apart, find out why it fails and fix it accordingly. If you want to post specific issues you've run in to I'll try to help
Honored Contributor
Frank Saxton
Posts: 785
Registered: ‎07-30-2000
Message 4 of 26 (633 Views)

Re: OMU on Solaris 10

This is a Solaris 10 system. As you know, Sun implemented a lot of new features,like the ZFS, that are apparently a problem for the OVO install scripts. As it turned out, doing the Oracle 10g part was a piece of cake compared to getting ovoinstall to work.

We are perfectly capable of picking apart the scripts to troubleshoot and fix the kazillion problems we're having. But management doesn't understand why the software that they paid two million bucks for won't just spin up and install without going through these gyrations. I do not have a credible answer for them, nor can I explain why the four year old 8.1 OVO CD is "the latest we can get"....

What we do has a great deal of Government oversight so our processes need to be hardened and production worthy. Having to pull apart install scripts, deal with outdated documentation with MANY mistakes and having to patch "the latest software we can get" to get it to work raises a lot of eyebrows around here.

What I really need is to talk to someone who has installed this stuff successfully on a Solaris 10 server.
Honored Contributor
Bill Costigan
Posts: 1,427
Registered: ‎09-19-2000
Message 5 of 26 (633 Views)

Re: OMU on Solaris 10

I installed it on Solaris 10 but had to download an updated installation script to get it to work. HP helped me through the process.

Copy the CDs to disk, download the updated scripts and replace some of the items from the CD with the downloaded ones. Once we got to the right level of support within HP it was easy. They even did a web conference with us duing the install to ensure it worked.

The trick was getting the right folks on the phone.
Honored Contributor
Bill Costigan
Posts: 1,427
Registered: ‎09-19-2000
Message 6 of 26 (633 Views)

Re: OMU on Solaris 10

FYI, Here are the steps HP sent us.

Before the OVO installation on Solaris 10, download the dedicated ovoinstall installation script and ovo.info.SunOS.5.10.txt file from the following location:

ftp://ovweb.external.hp.com/pub/cpe/ito/OVO_Sol10_Installer/

1. Copy the dedicated ovoinstall installation script and replace the original located in the OVOCD1 directory (the directory where you put the OVO installation bits) and do the same with the ovo.info.SunOS.5.10.txt file to OVOCD1/Required_OS_Patch_Lists/

2. Add the following line to the /etc/system file (if it is not already present):

set shmsys:shminfo_shmmax=4294967295

After changing the /etc/system file, restart the system.

3. Copy downoloaded SD bits to the /tmp/sd directory. Unzip and untar the package as follows:

# gunzip OVO_Sol10_Installer.tar.gz
# tar xvf OVO_Sol10_Installer.tar
Run the /tmp/sd/sd_install.sol script to install the HP Software Distributor

4. Run OVOCD1/ovoremove and follow the steps to remove the OVOU installation. It is not necesary to deinstall NNM.


Also, if you could please check with your DBA the following:

1. There should be a group under solaris with the following name: oinstall it should have an id greater than 100

2. There should be a group under solaris with the following name: dba it should have an id greater than 100

3. There should be an user under solaris with the following name: oracle it should have korn shell set, the home directory should be /export/home/oracle the primary group assigned to this user should be oinstall and also, it should have dba as a secondary group. The oracle user id should be greater than 100.

4. Run the following commands:

# umask 022

# mkdir -p /opt/oracle/product/10.2.0

# mkdir -p /opt/oracle/oraInventory

# chown -R oracle:oinstall /opt/oracle

Note that the /opt/oracle directories are the ones where oracle was installed in your system. if you change this to something other than /opt/oracle, you should also change them in the above steps.

5. Set the following env variables on both profiles (root and oracle)

export ORACLE_BASE=/opt/oracle

export ORACLE_HOME=$ORACLE_BASE/product/10.2.0

export ORACLE_SID=openview

export ORACLE_TERM=xterm

export PATH=$PATH:$ORACLE_HOME/bin


With this steps we should be ready to do the installation.

We also selected the option to install the OVO patches in the middle of the installation.
Honored Contributor
Frank Saxton
Posts: 785
Registered: ‎07-30-2000
Message 7 of 26 (633 Views)

Re: OMU on Solaris 10

Thanks for the detailed response Bill! This looks pretty close to the steps that we had to take to get things working as well as they are so far. We also had a tough time finding "the right guy" in second level to help us. It was a webex that lasted about two days that gave us essentially the same info that you have. You'd think that all of the support energy required to make this thing work would justify new CDs and scripts/instructions that actually work.

So once we got OMU working, the next problem was that we couldn't install an agent on the OMU server and we could not install the SPIs. We're getting a "cannot find files/unmounted file system error message that sounds like a re-run of the install script not understanding ZFS.

We're still trying to find "the right guy" in HP support to do a webex to make this stuff work. If you'd care to send along the magic steps for that it'll be another 5 points :)


Honored Contributor
Jeroen Peereboom
Posts: 2,732
Registered: ‎06-26-2003
Message 8 of 26 (633 Views)

Re: OMU on Solaris 10

I don't know where and when exactly you get your errormessage, but I used the following command to install some DBSPI's:

swinstall -x mount_all_filesystems=false -s /install_tmp/OVOSSPI/OV_DEPOT/SOLARIS.sdtape DBSPIMSSQL DBSPIOracleHPUX DBSPIOracleNT DBSPIOracleSOL

HtH,

JP
Honored Contributor
Honored Contributor
Jov
Posts: 1,574
Registered: ‎01-12-2000
Message 9 of 26 (633 Views)

Re: OMU on Solaris 10

Hi Frank,

Maybe I've missed something, but I dont follow what you're saying in the following:

>> So once we got OMU working, the next problem was that we couldn't install an agent on the OMU server and we could not install the SPIs.

The OVO/OMU Agent on the Management Server get installed during the installation process. Its not something you install as a post-installation step.

Thus you'd be getting errors during the installation.

Jov
Honored Contributor
Frank Saxton
Posts: 785
Registered: ‎07-30-2000
Message 10 of 26 (633 Views)

Re: OMU on Solaris 10

Thanks Jergen. I'll give that a try. The filesystems=false has helped overcome previous ZFS problems in the past.

I have not worked with the new HTTPS agents yet. When I tried to install templates I got some errors. Looking into those errors it looked like the agent was not completely installed and some daemons were not running. I'm not clear on the replacement commands for what opcagt used to do. Points for a quicky primer :)
HP Expert
Patrik Batsching
Posts: 21
Registered: ‎04-01-2004
Message 11 of 26 (633 Views)

Re: OMU on Solaris 10

Hi Frank,
the OMU8 media kit get updated several times a year, but you are right not so far the OMU8 software itself, but add-on products such as DMA (Dependency Mapping Automation) or PM (Performance Manager) or deployable Performance Agents.
As you are certainly aware, there are updated OMU8 Release Notes coming out with every new OMU8 server patch (most recent OMU8.30 in June 2008), also the OMU8 manuals get updated from time to time - please check http://support.openview.hp.com/selfsolve/manuals for "Operations Manager for UNIX" regularly.
In the OMU8 RN you find all important information how to install OMU8 server on new OS versions, clusters, etc. You also get a short overview about new features delivered with the patch.
In your concrete use case to install OMU8 on Solaris 10, you need an updated ovoinstall package, which you find on http://h20229.www2.hp.com/uploads/ovrd/ovr_l_ovoux_0002.html. That's described in the OMU8 RN of course.
Your actual problem is very likely caused by the ZFS file system, which is NOT yet supported by OMU, because Sun's ZFS implementation is not 100% consistent/transparent (e.g. differences in the df and statvfs calls vs. the "zfs list" call).
If not yet done, I recommend to open a corresponding enhancement request at HP support to get OMU supported on ZFS.
FYI, there are many customers running OMU8 on Solaris 10 - no question - but they might not use ZFS.
HP Expert
Patrik Batsching
Posts: 21
Registered: ‎04-01-2004
Message 12 of 26 (633 Views)

Re: OMU on Solaris 10

Frank,
on the OMU8 server you can only install the HTTPS agent, but NO LONGER the DCE agent.
An overview about the HTTPS agent you get in the "OM - HTTPS Agent Concepts and Configuration Guide" available on http://support.openview.hp.com/selfsolve/manuals.
Honored Contributor
Frank Saxton
Posts: 785
Registered: ‎07-30-2000
Message 13 of 26 (633 Views)

Re: OMU on Solaris 10

Thanks Patrik! I've been trying to get to that upload stuff for weeks. All of the download links error out with page not found.
HP Expert
Patrik Batsching
Posts: 21
Registered: ‎04-01-2004
Message 14 of 26 (633 Views)

Re: OMU on Solaris 10

Hi Frank,
when trying the URLs I've mentioned, please make sure, that there is not "." (period) at the end - sorry, that somehow became part of the URL.
Honored Contributor
Frank Saxton
Posts: 785
Registered: ‎07-30-2000
Message 15 of 26 (633 Views)

Re: OMU on Solaris 10

Did that Patrik. After I provide the download personal info no matter what I click I get a dead link
HP Expert
Patrik Batsching
Posts: 21
Registered: ‎04-01-2004
Message 16 of 26 (633 Views)

Re: OMU on Solaris 10

Frank,

oops that's very strange. It's working for me. Which document could I provide to you - e.g. by email?
Honored Contributor
Frank Saxton
Posts: 785
Registered: ‎07-30-2000
Message 17 of 26 (633 Views)

Re: OMU on Solaris 10

Thanks but we managed to pick this up some place... can't recall where. these are the self monitgoring tools and agent stuff
HP Expert
Patrik Batsching
Posts: 21
Registered: ‎04-01-2004
Message 18 of 26 (633 Views)

Re: OMU on Solaris 10

The agent self-monitoring contrib package you'll also find on http://h20229.www2.hp.com/uploads/ovrd/ovr_l_ovoux_0002.html as well as the OM HTTPS agent for zSeries running SUSE9/10.
Honored Contributor
Frank Saxton
Posts: 785
Registered: ‎07-30-2000
Message 19 of 26 (633 Views)

Re: OMU on Solaris 10

Goes to the same place with tehsame dead links.

And just general info for anyone following this thread.... there is yet another new ovoinstall script just out to fix a problem with installing the 8.30 consolidated patch

Regular Advisor
ChuckM_2
Posts: 172
Registered: ‎04-16-2009
Message 20 of 26 (633 Views)

Re: OMU on Solaris 10

Hi,
Bumping this back up as we're about to install OVOU 8.3 on Solaris 10 on ZFS.

Can anyone provide an update to the procedure discussed here?

Also, there's an enhancement Request out there requesting ZFS support with an HP note that it's coming in the Fall. Does anyone have an update on this?

Thanks.

C.
HP Expert
molinabro1
Posts: 501
Registered: ‎05-09-2007
Message 21 of 26 (633 Views)

Re: OMU on Solaris 10

ZFS on Management Servers will be supported on autumn of 2009

http://support.openview.hp.com/selfsolve/document/LID/QCCR1A60827

itle:
ENH: customer wants installation to work on a Solaris Local Zone with ZFS root file system
Document ID:
QCCR1A60827
Product:
Operations Manager for UNIX
Version:
8.30
OS:
Sun Solaris
Updated:
2009-Aug-24
Severity:
Medium
Classification:
Enhancement Request
Status:
Action
In plan:
Yes
Submitted:
2009-Feb-09

Customer symptom

Enhancement request for server installation to work on a Solaris 10 Local Zone with ZFS root file system.

Customer resolution

Support for whole root non global zone will be available with the OMS release in autumn 2009.

Internal Change Request

QCCR1A60827




Ed Molina
HP Cloud Solution Support Engineer

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution. Also, if you liked this post please consider providing Kudos on the left side.
Regular Advisor
ChuckM_2
Posts: 172
Registered: ‎04-16-2009
Message 22 of 26 (633 Views)

Re: OMU on Solaris 10

Right, should've said I saw that. Just wondering if anyone had anything else to add to it.
Thanks.
HP Expert
molinabro1
Posts: 501
Registered: ‎05-09-2007
Message 23 of 26 (633 Views)

Re: OMU on Solaris 10

Chuck,

Curious, at the same time I posted this info on the forum I sent you an email about this on the support case you opened =D


Ed Molina
HP Cloud Solution Support Engineer

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution. Also, if you liked this post please consider providing Kudos on the left side.
Regular Advisor
ChuckM_2
Posts: 172
Registered: ‎04-16-2009
Message 24 of 26 (633 Views)

Re: OMU on Solaris 10

Hah!
Small world, eh? Still, it's been since Feb. and we have servers on the rack, being built specifically for Solaris10 and OVOU 8.3 now.

This is a big deal for us and we're now watching closely (or trying) the progress of it.

C.
HP Expert
molinabro1
Posts: 501
Registered: ‎05-09-2007
Message 25 of 26 (633 Views)

Re: OMU on Solaris 10

Chuck,

yep, very small world hehe! I do know that Solaris 10 is supported, is just that ZFS is not (at this point).

Eduardo


Ed Molina
HP Cloud Solution Support Engineer

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution. Also, if you liked this post please consider providing Kudos on the left side.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.