Re: Couldn't connect to HP Operations agent database (333 Views)
Reply
Valued Contributor
maf
Posts: 110
Registered: ‎11-11-2010
Message 1 of 3 (338 Views)
Accepted Solution

Couldn't connect to HP Operations agent database

Ive been experimenting with ovowmsgutil.exe -ack on OMW 8.16 + OA 8.60 and and got this error message after restart of server services

ERROR:    Couldn't connect to HP Operations agent database (MSGU400).:

 

vpstat seems to think everything is in order:

 

vpstat -3 -l
============================================================
running: D:\Program Files\HP\HP BTO Software\bin\vpstat.exe
version: A.6.0.74.3 on HPOM
now:     Mon Dec 19 14:57:30 2011
============================================================

============================================================
==================== Services Information ==================
============================================================

Configuration file: D:\Documents and Settings\All Users\Application Data\HP\HP B
  Ver: 0.8.16.000
  Date: Fri Oct 22 15:34:46 2010
  Remark: HP Operation Manager - Performance.

Services on     : LOCAL MACHINE

(NT Services) :
                SERVICE_RUNNING  : OvAutoDiscovery Server ( OvAutoDiscovery Serv
                SERVICE_RUNNING  : OvCtrl ( HP OpenView Ctrl Service )
                SERVICE_RUNNING  : OvDnsDscr ( OvDnsDiscoveryService )
                SERVICE_RUNNING  : OvEpMessageActionServer ( OvEpMessageActionSe
                SERVICE_RUNNING  : OvEpStatusEngine ( OvEpStatusEngine )
                SERVICE_RUNNING  : OvMsmAccessManager ( OvMsmAccessManager )
                SERVICE_RUNNING  : OvOWReqCheckSrv ( OvOWReqCheckSrv )
                SERVICE_RUNNING  : OvowWmiPlatProv ( OvowWmiPlatProv )
                SERVICE_RUNNING  : OvPmad ( OvPmad )
                SERVICE_RUNNING  : OvSecurityServer ( OvSecurityServer )
                SERVICE_RUNNING  : OvServerMonitor ( OvServerMonitor )
                SERVICE_RUNNING  : OVServiceLogger ( OVServiceLogger )
                SERVICE_RUNNING  : OvStoreProv ( OvStoreProv )

                OK: All services : SERVICE_ACTIVE

 

ovc showed all components runing also.

 

Any idea what this could be? I'm curious cause the system has occasional problem when opcmona policies stop executing without any trace in system.txt or service status reports.

Please use plain text.
Frequent Advisor
Anita Roseline L
Posts: 47
Registered: ‎04-08-2011
Message 2 of 3 (333 Views)

Re: Couldn't connect to HP Operations agent database

Hi,

 

If you wanted to use ovowmsgutil to clear acknowledges fromt he database directly, You need to login with the user account, that has access to openview DB.Else you cannot clear mesages from OMW.

 

ovowmsgutil.exe - Tries to connect to openview Db and then clear acknowledged messages directly from Database.If the user account you have logged in does not have proper previledge,you will get the below error.

Please use plain text.
Respected Contributor
Ram_2
Posts: 179
Registered: ‎04-07-2010
Message 3 of 3 (329 Views)

Re: Couldn't connect to HP Operations agent database

Hello

 

This error typically occurs if the OMW database is remote and the user who is running ovowmsgutil command does not have full admin rights for the OMW database instance. Check this self-solve documen that gives you a workaround

 

http://support.openview.hp.com/selfsolve/document/KM1016400

 

Hopefully this will help you.

Regards

Ram

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation