Adding RHEL3 nodes to OML9 (533 Views)
Reply
Frequent Advisor
ABC Unix
Posts: 86
Registered: ‎01-07-1997
Message 1 of 12 (533 Views)
Accepted Solution

Adding RHEL3 nodes to OML9

I'm trying to migrate from OVO8 to OML9 and I have a pretty sizable number of RHEL3 servers (Kernel version 2.4.x), agent version 8.17.

I know that RHEL3 nodes aren't supported in OML9, but does anyone know of any way to get these nodes onto the new OML9 management server? Can I manually add machtypes somehow or something?

Or maybe I'm hooped...meaning no OML9 :(

Thanks,
Ryan
Please use plain text.
Honored Contributor
Drew Dimmick
Posts: 8,053
Registered: ‎11-16-2002
Message 2 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

Lie to it and tell it that it's some other version. I'm not sure if you will be able to upgrade this agent to the current versions, but you should be able to get things "mostly" working

just make sure the assignments, etc for these nodes are restricted...
I do "Windows"
Please use plain text.
Frequent Advisor
ABC Unix
Posts: 86
Registered: ‎01-07-1997
Message 3 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

That will really work? I have to do the client installation manually then correct?

Here's what I did to install the client:

copy contents of /var/opt/OV/share/databases/OpC/mgd_node/vendor/linux/x86/linux24/A.08.10.160/RPC_BBC

on the OVO8 management server to the node, then run opc_inst.

I did all that, added the node to a node group and distributed the policies, it complained saying:

"Distribution was successful.

Additional information:
Node lnx13.abcp.ab.bluecross.ca:
Create distribution data and inform agent...
Warning: HP Operations agent is potentially not installed on node lnx13.abcp.ab.bluecross.ca
(software-installed flag not set in the database). Continuing with
distribution data creation. (OpC40-730)
Done.
"

Also opcmsg doesn't work:

opcmsg -restart
The OVO Message Command is not configured on this system.

# opcagt -status
coda OV Performance Core COREXT (4701) Running
opcmsga OVO Message Agent AGENT,EA Aborted
opcacta OVO Action Agent AGENT,EA (4724) Running
opcmsgi OVO Message Interceptor AGENT,EA (4726) Running
Please use plain text.
Honored Contributor
HaraldPfaender
Posts: 857
Registered: ‎10-29-2008
Message 4 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

Hello,

RHEL3 is not supported any more (with the new agent). But as Drew said you can bring the nodes under management. Therefore you have to "lie" to the OML server and just fake any Linux/OS Type which exists. Then it should be possible to communicate with that node.
Please use plain text.
Honored Contributor
HaraldPfaender
Posts: 857
Registered: ‎10-29-2008
Message 5 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

Another thing: I think there is also a hotfix available which adds the RHEL3 node type. You should get in contact with HP Support for this.
Please use plain text.
Trusted Contributor
Michal Kovacik
Posts: 79
Registered: ‎07-17-2008
Message 6 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

If "lying" about machtype, please also ensure that the instrumentation (if used) of this type is compatible with the actual machine type (or transfer it manually)
Please use plain text.
Frequent Advisor
ABC Unix
Posts: 86
Registered: ‎01-07-1997
Message 7 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

@robert01: I talked to HP Support before and they have no answer for getting RHEL3 nodes working on OML9...seems like I'm getting better support on this free forum haha.

But anyways I'm still having the problem I outlined above, I get messages in the browser saying that "Distribution still pending after 38 minutes for Template Action Command Monitor" for the RHEL3 node I added.
I can't get the opcmsga component to start (after installing using the method I outlined above):

# ./ovc -status
ovcd OV Control CORE (4657) Running
ovbbccb OV Communication Broker CORE (4664) Running
coda OV Performance Core COREXT (4701) Running
ovconfd OV Config and Deploy COREXT (4704) Running
opcmsga OVO Message Agent AGENT,EA Aborted
opcacta OVO Action Agent AGENT,EA (4724) Running
opcmsgi OVO Message Interceptor AGENT,EA (4726) Running

Thanks again guys.
Please use plain text.
Frequent Advisor
ABC Unix
Posts: 86
Registered: ‎01-07-1997
Message 8 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

By the way, if I try to install the agent the proper way (through /opt/OV/bin/OpC/agtinstall/inst.sh on the management server), it will fail if I select the "linux/x86/linux26" node platform (the correct one is linux/x86/linux24, which doesn't exist in OML9 anymore).

The error I get when I try this reads:

WARNING: OVO software version A.08.10.160 does not support linux/x86/linux26
systems running OS release 2.4.21-57.ELsmp. System
lnx13.abcp.ab.bluecross.ca is currently running this OS version.
Please contact your HP representative for the latest OVO version.
ERROR: OVO software has not been installed on Management Server to support
linux/x86/linux26 systems with OS release 2.4.21-57.ELsmp.
Please use plain text.
Honored Contributor
HaraldPfaender
Posts: 857
Registered: ‎10-29-2008
Message 9 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

Hello,

just to clarify: OML9 agent does not support RHEL3/2.4 anymore. Therefore you cannot install the new agent on this platform.
So you can only "use" the old agent with OML9. The only thing is that in OML server you cannot setup a RHEL3 node. Therefore you need either a hotfix which adds the platform type to the server or you setup a different platform for the "old" agent.
Please use plain text.
Trusted Contributor
Amal I K_1
Posts: 290
Registered: ‎10-10-2007
Message 10 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

Try installing the new agent (32 bit 8.6.x ). Even though its not supported , working fine for me.
Please use plain text.
Frequent Advisor
ABC Unix
Posts: 86
Registered: ‎01-07-1997
Message 11 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

@Amal, you're using the 2.6.X Agent version 8.60 on a RHEL3 node?

That's good news, I will try that someday. For now I just want to get my OML9 server working.

Thanks everyone for your help, I finally got a RHEL3 node added on my OML9 management server thanks to you guys and other posts on this forum.

For the record, here are the steps I had to do after installing the agent (vers. 8.17) manually and adding the RH3 node to the mgmt server as a Linux 2.6 machine:

Policy Cleanup on the Managed Node
ovpolicy -remove -all

Stop the Agent
ovc -kill

Certificate Cleanup on the Agent
ovcert -remove

Configuration Settings Cleanup
ovconfchg -ns sec.cm.client -set CERTIFICATE_SERVER
ovconfchg -ns sec.core.auth -set MANAGER
ovcoreid -ovrg server (get core ID on management server)
ovconfchg -ns sec.core.auth -set MANAGER_ID
ovconfchg -ns eaagt -clear OPC_PRIMARY_MGR

Start the Agent
ovc -start

After that I was able to push policies, node info, etc successfully.
Please use plain text.
Frequent Advisor
ABC Unix
Posts: 86
Registered: ‎01-07-1997
Message 12 of 12 (533 Views)

Re: Adding RHEL3 nodes to OML9

See above
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation