Re: Restoring system disk without image backup (412 Views)
Reply
Advisor
Joslovevms
Posts: 24
Registered: ‎10-11-2011
Message 1 of 5 (451 Views)

Restoring system disk without image backup

This migh sound stupid, but im a little curious to test this just wanted to know it there is an option for that.

 

I received a system disk backup which is a non image backup. command used was

  $ backup/ignore=inter sys$sysdevice:[000000...]*.*;*

This was actually taken by mistake on the other end, I will get another image soon with /image qualifier which will server my purpose.

 

In the mean time I wanted to test, whether with this backup we can boot or not. So what I did, I transferrred this save set to my FreeAXP disks and restored it to another disk with no other data except system files *.sys

 

and I got this command from hoff's site and written the boot block.

 

$ RUN SYS$SYSTEM:WRITEBOOT

 

When I gave a try to boot the machine... It booted.

 

And all the normal activities are fine.. all the startup are running, TCp/Ip is starting. I am able to login with the sysuaf restored from that backup.

 

 But if some operation at low level is tried where the RMS and file id referencing is happening. The actual proble shows up.

 

For example:

 

$$ prod install *
%PCSI-E-SYSDIRERR, SYS$SYSDEVICE:[000000]VMS$COMMON.DIR and SYS$SYSDEVICE:[000000]VMS$COMMON.DIR;1 have different File ID numbers
-PCSI-E-CHKSYSDIR, check system directory structure
%PCSIUI-E-ABORT, operation terminated due to an unrecoverable error condition.

 

 

Index file is having different value in the header whereas the actual file is having a different value for File ID.

 

 Is there any way to fix this up. Just out of curiousity...

Please use plain text.
Esteemed Contributor
H.Becker
Posts: 363
Registered: ‎04-09-2009
Message 2 of 5 (436 Views)

Re: Restoring system disk without image backup

I would not spend much time with this and would not rely on any free advice... Do a 

$ sh log sys$sysroot
it should show something like
   "SYS$SYSROOT" = "$1$DGA1:[SYS0.]" (LNM$SYSTEM_TABLE)
        = "SYS$COMMON:"
1  "SYS$COMMON" = "$1$DGA1:[SYS0.SYSCOMMON.]" (LNM$SYSTEM_TABLE)
 
In your output the 'n' in SYSn may be different.
The non-image backup contains a [000000]VMS$COMMON.DIR and a [SYS0]SYSCOMMON.DIR and they have different file IDs. (Actually you have duplicate files under these directories). That's not how a system disk should look like. [SYS0]SYSCOMMON.DIR has to be an alias for [000000]VMS$COMMON.
You don't care about this system disk, anyway, so ...
$ rename sys$sysdevice:[sys0]syscommon.dir delete-me
$ set file/enter=[sys0]syscommon.dir sys$sysdevice:[000000]vms$common.dir
Reboot


Please use plain text.
Frequent Advisor
Eberhard Heuser
Posts: 42
Registered: ‎03-19-2010
Message 3 of 5 (435 Views)

Re: Restoring system disk without image backup

May be your directory structure is a little bit damaged:

 

The sys$sysdevice:[SYSn]syscommon.dir and sys$sysdevice:[000000]vms$common.dir must point to the same file.

 

As an example, if everything is in good shape:

 

$ dir sys$sysdevice:[sys0]syscommon.dir/file_id

gives:

SYS$SYSDEVICE:[SYS0]SYSCOMMON.DIR;1      (42,1,0)

 

This is the same file-id as vms$common.dir:

SYS$SYSDEVICE:[000000]VMS$COMMON.DIR;1     (42,1,0)

 

If this is not the case, delete all trees sys$sysdevice:[SYSn.syscommon...]*.*;* and finally

sys$sysdevice:[SYSn]syscommon.dir;*

and restore the correct directory structure via

$ set file/enter=sys$sysdevice:[sysx]syscommon.dir sys$sysdevice:[000000]vms$common.dir

 

Be warned. control every step very carefully.

 

If  file-id is already identical the procedure does not solve your problem.

 

Hope this helps

Eberhard

Please use plain text.
Honored Contributor
Hoff
Posts: 4,921
Registered: ‎01-29-2006
Message 4 of 5 (412 Views)

Re: Restoring system disk without image backup

See BACKUP Tips: Image and Alias and Saveset Processing and likely some other topics available around the 'net via Google. 

 

Yes, this disk saveset can likely be easily restored, through the addition of the system directory backlinks and rewriting the boot block.   It's not a direct replacement, but it works.  (Things get more interesting with OpenVMS I64 disk structures, as that path really needs (wants) correct use of /IMAGE.)  This centrally involves resetting the directory links though - if you've been running with this for a while - there are potentially other issues here. 

 

Now for the downside of this backup.   It's not the lack of /IMAGE that'll cause you problems (once you know the structures of an OpenVMS system disk).  It's that /IGNORE=INTERLOCK that tends to cause problems with the restoration.

 

If you're going to use BACKUP, please take the time to read the examples in the BACKUP documentation and the BACKUP help text.  BACKUP is one of the most arcane and cryptic tools on OpenVMS, and it's both effective at its task, and can also be a most excellent way to eliminate data integrity.

 

For best results, I'd probably reinstall from distro, and reload the OpenVMS and layered product software, and reset the BACKUP savesets.  More work, but you know what the results are within the OpenVMS system files and structures.  Now as for your local data, the data integrity of that is still questionable.  That'll likely also get you current software versions and (if you take the extra steps) current patches.

 

This forum software still can't manage to edit an embedded link correctly, and it doesn't trim the blanks on the ends of the URL.   Which also points to failures in the testing.

Please use plain text.
Advisor
Joslovevms
Posts: 24
Registered: ‎10-11-2011
Message 5 of 5 (368 Views)

Re: Restoring system disk without image backup

Hi All,

 

 thanks for you replies. Im not getting time to check these things. Will update you all when I check it..

 

Thanks..

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation