Re: update-ux possible problems (413 Views)
Reply
Respected Contributor
Prokopets
Posts: 395
Registered: ‎02-22-2008
Message 1 of 8 (431 Views)
Accepted Solution

update-ux possible problems

Hi!

    I want to update B.11.31.0803 Foundation Operating Environment to latest version of BaseOE. Is it possible? If yes, can it be done without DVD (just copy all files to local disk)?

 

Philipp.

Trusted Contributor
Danny Petterson - DK
Posts: 249
Registered: ‎02-09-2007
Message 2 of 8 (426 Views)

Re: update-ux possible problems

I think you should be able to update, if disk-space and hardware-requirements are ok.

 

You can install from mounted locally mounted  iso-images, using:

 

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=ISOIMAGE-ENH

Respected Contributor
Prokopets
Posts: 395
Registered: ‎02-22-2008
Message 3 of 8 (415 Views)

Re: update-ux possible problems

Thanks for the answer, Danny! And what about changing the OE from FOE to BOE? I think that it shouldn't be a problem, but just want to be sure.

 

Philipp.

Trusted Contributor
Danny Petterson - DK
Posts: 249
Registered: ‎02-09-2007
Message 4 of 8 (413 Views)

Re: update-ux possible problems

According the table in the document below, it should be fine:

 

http://docstore.mik.ua/manuals/hp-ux/en/5992-4165/ch03s02.html

Respected Contributor
Prokopets
Posts: 395
Registered: ‎02-22-2008
Message 5 of 8 (411 Views)

Re: update-ux possible problems

Thanks, Danny!

 

Philipp.

Respected Contributor
Prokopets
Posts: 395
Registered: ‎02-22-2008
Message 6 of 8 (405 Views)

Re: update-ux possible problems

I'm trying now to mount the iso, but got error:

 

# mount -F cdfs /test/hpux/disk1.iso /cdrom
mount: /test/hpux/disk1.iso is an invalid operand
# swlist -l product ISOIMAGE-ENH
# Initializing...
# Contacting target "dbsrv"...
#
# Target:  dbsrv:/
#

# ISOIMAGE-ENH                  B.11.31.06     ISO Image mount Enhancement
  ISOIMAGE-ENH.Iso-Image-Enh    B.11.31.06     cdfs ISO image mount support
# kcmodule cdfs
Module  State   Cause  Notes
cdfs    loaded  auto   auto-loadable, unloadable
#

 i also checked the md5 of iso - it's ok. What i did wrong?

 

Philipp.

Acclaimed Contributor
Dennis Handly
Posts: 25,188
Registered: ‎03-06-2006
Message 7 of 8 (395 Views)

Re: update-ux possible problems

[ Edited ]

>What I did wrong?

 

It appears you haven't loaded the fspd module.

kcmodule fspd=loaded

mount -F cdfs /absolute/path/image.iso /mount/point

 

From the tag cloud:

http://h30499.www3.hp.com/t5/tag/ISO%20image/tg-p/category-id/itrc-117

http://h30499.www3.hp.com/t5/System-Administration/How-can-I-mount-an-iso-file/m-p/4599222

 

Respected Contributor
Prokopets
Posts: 395
Registered: ‎02-22-2008
Message 8 of 8 (377 Views)

Re: update-ux possible problems

[ Edited ]

Hi!

   the solution worked:

 

# kcmodule fspd
Module  State  Cause  Notes
fspd    auto   best   auto-loadable, unloadable
# kcmodule fspd=loaded
     ==> Update the automatic 'backup' configuration first? y
       * The automatic 'backup' configuration has been updated.
       * Future operations will update the backup without prompting.
       * The requested changes have been applied to the currently
         running configuration.
Module            State   Cause     Notes
fspd    (before)  auto    best      auto-loadable, unloadable
        (now)     loaded  explicit
# mount -F cdfs -orr /test/hpux/disk1.iso /cdrom
#

 and it's mounted now finally.

 

Philipp.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.