Re: scons for HPUX (200 Views)
Reply
Occasional Advisor
Mariappan_B
Posts: 9
Registered: ‎07-08-2011
Message 1 of 2 (211 Views)

scons for HPUX

Hi All, Can someone let me know how to install scons on HPUX ? I do not see scons available for HPUX at scons web site , http://www.scons.org/ . Thanks in advance. Thanks & Regards, Mariappan
Please use plain text.
Honored Contributor
Matti_Kurkela
Posts: 6,271
Registered: ‎12-02-2001
Message 2 of 2 (200 Views)

Re: scons for HPUX

scons is Python-based, so it should run on any system that has a working Python interpreter (currently Python version 2.4 or newer is required, and Python 3 is too new).

 

First install a version of Python. It is available in the HP-UX Internet Express kit for 11iv2 and 11iv3 (i.e. can be downloaded for free from software.hp.com). If you have 11iv1, your HP-UX installation media kit should include an Internet Express CD, which might contain a version of Python that is new enough for scons.

 

Alternatively, there is a version of Python available in the Porting Archive.

 

After that, follow the instructions in Chapter 1.3 of the scons User Guide: Building and Installing scons on Any System.

 

If you want scons to be installable using swinstall, you will need to write a Product Specification File for it and use the swpackage command to package it.

MK
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation