Re: hpacucli compatibility with new HPSA driver (3621 Views)
Reply
Occasional Visitor
Rob Spekschoor
Posts: 3
Registered: ‎06-17-2011
Message 1 of 8 (4,383 Views)

hpacucli compatibility with new HPSA driver

We are running several servers with P410i controller. Most servers are installed with older kernels and cciss drivers however, new servers are installed with newer kernel (2.6.38 Gentoo) with hpsa driver only.

Problem we are facing is that hpacucli no longer seems to work in this new combination, even though hpsa.txt states that most of the ioctl should be compatible. Anybody any idea how to get this combination to work?
Please use plain text.
Honored Contributor
Jimmy Vance
Posts: 1,458
Registered: ‎11-27-2006
Message 2 of 8 (4,383 Views)

Re: hpacucli compatibility with new HPSA driver

Some of the older versions of hpacucli wouldn't work properly with the hpsa driver. Downloading the latest version of hpacucli should resolve your issue

HP Array Configuration Utility CLI for Linux
v8.70-8.0

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?swItem=MTX-08be00e0ba8b42ff...〈=en&cc=us&mode=3&

Please use plain text.
Occasional Visitor
Rob Spekschoor
Posts: 3
Registered: ‎06-17-2011
Message 3 of 8 (4,383 Views)

Re: hpacucli compatibility with new HPSA driver

We already tried that version, found it another ticket. This does not seem to work for us.
Please use plain text.
Occasional Visitor
Rob Spekschoor
Posts: 3
Registered: ‎06-17-2011
Message 4 of 8 (4,373 Views)

Re: hpacucli compatibility with new HPSA driver

Anybody anu suggestions? We installed v8.70-8.0 but this outputs:

hpacucli ctrl all show status

Error: No controllers detected.


 

Please use plain text.
4k
Occasional Visitor
4k
Posts: 1
Registered: ‎12-01-2011
Message 5 of 8 (4,101 Views)

Re: hpacucli compatibility with new HPSA driver

Freshly installed 64bit Debian Squeeze on dl160 G6 with a p410 512MB BBWC. And it installs automatically with hpsa. Hpacucli reports "Error: No controllers detected." I have tried loading mopdrobing sg as suggested by some but to no help. Is there any solution?

Please use plain text.
Occasional Visitor
jomlowe
Posts: 1
Registered: ‎01-05-2012
Message 6 of 8 (3,959 Views)

Re: hpacucli compatibility with new HPSA driver

Turns out it doesn't like what uname gives it with >= 3.0 kernels, the temporary solution while they fix this is to lie to hpacucli with a custom uname wrapper that can be found here

 

http://mirror.anl.gov/pub/linux/kernel/people/ak/uname26/

Please use plain text.
Occasional Visitor
SpComb
Posts: 1
Registered: ‎01-08-2012
Message 7 of 8 (3,949 Views)

Re: hpacucli compatibility with new HPSA driver

[ Edited ]
root@0:~/uname26# uname -a
Linux finnix 3.0.6-1-x86-finnix #1 Sun Oct 9 01:32:58 PDT 2011 i686 GNU/Linux
root@0:~/uname26# hpacucli ctrl all show

Error: No controllers detected.

root@0:~/uname26# hpacucli uname -a^C   
root@0:~/uname26# ./uname26 uname -a
Linux finnix 2.6.40-1-x86-finnix #1 Sun Oct 9 01:32:58 PDT 2011 i686 GNU/Linux
root@0:~/uname26# ./uname26 hpacucli ctrl all show

Smart Array P400 in Slot 2                (sn: <snip>)

root@0:~/uname26# ...

 Indeed.. Magical.

Please use plain text.
Occasional Visitor
ojw_ss
Posts: 1
Registered: ‎03-15-2012
Message 8 of 8 (3,621 Views)

Re: hpacucli compatibility with new HPSA driver

It may be necessary to "modprobe sg" first.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation