Re: Problem with the dd command (93 Views)
Reply
Occasional Contributor
Bryan Quinn
Posts: 4
Registered: ‎01-09-2000
Message 1 of 3 (93 Views)

Problem with the dd command

I am using the following command to backup our boot disk before working on the
system next week. I am getting and I/O error. It seems to be reading the boot
disk, I think the problem has something to do with syntax or the tape unit
itself, can someone help?
Here is the command I am using:
dd if=/dev/dsk/c2t11d0 of=/dev/rmt/0mnb bs=1024k
Any thoughts?
Thanks,
Bryan
Frequent Advisor
Evan Day_1
Posts: 38
Registered: ‎03-27-2000
Message 2 of 3 (93 Views)

Re: Problem with the dd command

Is there a particular reason you're using the no-rewind berkeley tape device?
You might try it with /dev/rmt/0m to see if it makes any difference.

I'm not 100% sure, but this may not work so well if the disk is being accessed
by other processes while the dd is running. I moved some logical volumes
around with dd a while back for a database engine and had to bring the engine
down before it would work. You may need to come up on recovery media or an
alternate boot disk.

I assume you're running this as root. Permissions on device files may or may
not block the operation if you run as an unprivileged user.

-Evan
Frequent Advisor
Zhang Zhao gui
Posts: 49
Registered: ‎12-21-1999
Message 3 of 3 (93 Views)

Re: Problem with the dd command

I think you may try /dev/rmt/0mn instead of /dev/rmt/0mnb.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.