PGP for HP-UX 11.11 (187 Views)
Reply
Advisor
Puff
Posts: 20
Registered: ‎06-04-2003
Message 1 of 7 (187 Views)

PGP for HP-UX 11.11

We have some files that are PGP encrypted. I have found GNUPG on the HP-UX Internet Express DVD, but it is for 11iV2 not 11.11. Does anyone know if this version of GNUPG will work on 11.11?

Thanks
Honored Contributor
Tim Nelson
Posts: 3,727
Registered: ‎06-01-2000
Message 2 of 7 (187 Views)

Re: PGP for HP-UX 11.11

Your first trick would be to try and install it. I would suspect it would fail.

Find other sources ?

Archive and porting center ? http://hpux.connect.org.uk/

http://www.gnupg.org/ and compile your own ?

Honored Contributor
Steven Schweda
Posts: 9,096
Registered: ‎02-23-2005
Message 3 of 7 (187 Views)

Re: PGP for HP-UX 11.11

> http://www.gnupg.org/ and compile your own ?

That'd be my suggestion, too. The current
1.x.x version is 1.4.9. (What's on the
Internet Express DVD?) I've done more work
with it on VMS than on any HP-UX version, but
I'd expect few problems. (If you've seen one
UNIX, ...) What could go wrong?

You might also be able to find some real PGP
sources somewhere.
Honored Contributor
Steven Schweda
Posts: 9,096
Registered: ‎02-23-2005
Message 4 of 7 (187 Views)

Re: PGP for HP-UX 11.11

Apparently I did build it on my 11.11 system
(using GCC). I can't find any notes, so it
was probably pretty straightforward.

dy # ./g10/gpg --version
gpg (GnuPG) 1.4.9
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Home: ~/.gnupg
Supported algorithms:
Pubkey: RSA, RSA-E, RSA-S, ELG-E, DSA
Cipher: 3DES, CAST5, BLOWFISH, AES, AES192, AES256, TWOFISH
Hash: MD5, SHA1, RIPEMD160, SHA256, SHA384, SHA512, SHA224
Compression: Uncompressed, ZIP, ZLIB, BZIP2


I never tested it much, but what could go
wrong?
Occasional Visitor
Edward Browne
Posts: 2
Registered: ‎09-25-2008
Message 5 of 7 (187 Views)

Re: PGP for HP-UX 11.11

I'm able to install gnuPG 1.4.9 with out any problems I'm attempting to install gnuPG 2.0.9 (OpenPGP)

gnupg 2.0.9 fails at the make with has anyone gotten 2.0.9 to make cleanly?
Error from make

gcc -DHAVE_CONFIG_H -I. -I.. -I../intl -I/usr/local/include -g -O2 -Wall -Wno-pointer-sign -Wpointer-arith -MT utf8conv.o -MD -MP -MF .deps/utf8conv.Tpo -c -o utf8conv.o utf8conv.c
utf8conv.c: In function 'native_to_utf8':
utf8conv.c:386: error: 'ICONV_CONST' undeclared (first use in this function)
utf8conv.c:386: error: (Each undeclared identifier is reported only once
utf8conv.c:386: error: for each function it appears in.)
utf8conv.c:386: error: expected ')' before 'char'
utf8conv.c: In function 'do_utf8_to_native':
utf8conv.c:652: error: 'ICONV_CONST' undeclared (first use in this function)
utf8conv.c:652: error: expected ')' before 'char'
gmake[2]: *** [utf8conv.o] Error 1
gmake[2]: Leaving directory `/usr/local/gnupg/gnupg-2.0.9/jnlib'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/local/gnupg/gnupg-2.0.9'
gmake: *** [all] Error 2


I'm using GCC 4.2.3.
Honored Contributor
Steven Schweda
Posts: 9,096
Registered: ‎02-23-2005
Message 6 of 7 (187 Views)

Re: PGP for HP-UX 11.11

> I'm able to install gnuPG 1.4.9 with out
> any problems I'm attempting to install
> gnuPG 2.0.9 (OpenPGP)

Sounds like a good reason to start a new
thread with a new subject.

I've assumed that GnuPG 2.x would require no
end of other GNU stuff, and I do most of my
work on VMS, where most GNU stuff involves
one ordeal after another, so I've never
worked up the courage to try it.

Knowing nothing, I'd guess that it's a
"configure" problem. A simple search of
every ".h" file on a local Solaris system did
turn up a few (in odd places, including a few
"config.h" files) which said things like:

#define ICONV_CONST const

which certainly looks plausible. Where it
should appear in your mess is another
question, of course. You could try to slip
it into any GnuPG-generated "config.h" you
can find, and see what happens. (What could
go wrong?)
Occasional Visitor
Aman Sehgal
Posts: 1
Registered: ‎11-27-2008
Message 7 of 7 (187 Views)

Re: PGP for HP-UX 11.11

Hey. Does anyone have binary file (installable) for GnuPG 2.0 for HP-UX 11.11
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.