LDAP doesn't work for one user on one machine out of 30 (11vi3) (201 Views)
Reply
Regular Advisor
marvin51796
Posts: 108
Registered: ‎03-12-2012
Message 1 of 3 (201 Views)

LDAP doesn't work for one user on one machine out of 30 (11vi3)

I have a user that can NOT log into a HP-UX 11vi3 box that is setup with LDAP. We have another 30 box's and it works fine. I have checked everything that I know but I am lost as to what to do next. Does anyone have any ideas of what to check or try.

Thanks

 

Honored Contributor
Matti_Kurkela
Posts: 6,271
Registered: ‎12-02-2001
Message 2 of 3 (183 Views)

Re: LDAP doesn't work for one user on one machine out of 30 (11vi3)

Since you did not tell what you actually had checked, I'm afraid I must start with the basics:

 

Can you ping the LDAP server system?

 

Can you telnet to the appropriate port of the LDAP server system? (typically either 389 or 636, depending on whether SSL/TLS is used or not)

 

If SSL/TLS is used, run "nslookup <LDAP.server.IP.address>". Does it return the expected hostname? This may be required to validate the SSL certificate.

 

 

If you run:

# nsquery passwd <problem username>

# nsquery passwd <problem UID>

do you get the correct results (i.e. the information in LDAP)? If not, do you get wrong information, or no information at all?

 

Also perform the same checks with "nsquery group" and all the relevant group names and GIDs.

 

Does this system contain a local user with the same username or with the same UID?

 

If it does, it might be conflicting with the LDAP entry.

If it is a username-based conflict, it might be possible to just delete the conflicting local user information from /etc/passwd (and from /etc/shadow or /tcb/files/auth/<initial>/<username> if applicable).

If the conflict is with the UID numbers, you need to find out what the local user with the conflicting UID is used for, and then work to reassign one or the other to a different UID.

 

MK
Regular Advisor
marvin51796
Posts: 108
Registered: ‎03-12-2012
Message 3 of 3 (143 Views)

Re: LDAP doesn't work for one user on one machine out of 30 (11vi3)

The Problem ended up being that NTP wasnt working on the system and we had to sync it up..

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.