Re: Apache/2.2.8 startup problem (353 Views)
Reply
Occasional Advisor
ATIL VOLKAN YILDIRIM_1
Posts: 11
Registered: ‎07-18-2008
Message 1 of 5 (353 Views)

Apache/2.2.8 startup problem

Hi experts,
I installed HPUXWS22ATW-B302-64 depot to one of my hpux 11.31 itanium servers, along with OpenSSL_A.00.09.08k.009. When I try to start it, I get a coredump error. I examined related itrc threads but couldn't find so much. I reinstalled everything and tried a couple of different things but still no result. The problem seems to be related to ssl, as without including ssl module, httpd starts just fine...
Any helps would welcome...
Thanks all...

-----
: /opt/hpws22/apache/bin # ./apachectl start
Apache/2.2.8 HP-UX_Apache-based_Web_Server mod_ssl/2.2.8 (Pass Phrase Dialog)
Some of your private key files are encrypted for security reasons.
In order to read them you have to provide the pass phrases.

Server 10.1.121.192:443 (RSA)
Enter pass phrase:

OK: Pass Phrase Dialog successful.
./apachectl[209]: 4659 Memory fault(coredump)

------
: /opt/hpws22/apache/bin # gdb httpd core
HP gdb 5.5.2 for HP Itanium (32 or 64 bit) and target HP-UX 11.2x.
Copyright 1986 - 2001 Free Software Foundation, Inc.
Hewlett-Packard Wildebeest 5.5.2 (based on GDB) is covered by the
GNU General Public License. Type "show copying" to see the conditions to
change it and/or distribute copies. Type "show warranty" for warranty/support.
..
Core was generated by `httpd'.
Program terminated with signal 11, Segmentation fault.
SEGV_MAPERR - Address not mapped to object

warning: Load module /opt/hpws22/apache/modules/mod_ssl.so has been stripped.
Debugging information is not available.

#0 0xc000000002535330:0 in sk_pop_free+0x70 ()
from /usr/lib/hpux64/libssl.so.1

--------
: /opt/hpws22/apache/bin # file core
core: ELF-64 core file - IA64 from 'httpd' - received SIGSEGV

--------
: /opt/hpws22/apache/bin # what core
core:
WSS3.0 Release Apache2.2.8
$ B.11.31 Dec 27 2006 16:35:51 $
WSS3.0 Release Apache2.2.8
OCSP PATCH IS BUILD
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
$ B.11.31 Jun 26 2008 10:06:45 $
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
WSS3.0 Release Apache2.2.8
$Revision: libpthread.so.1: R11.31_BL2008_1209_2
$ B.11.31 Nov 13 2006 19:42:03 $
92453-07 linker dld HP Itanium(R) B.12.52
92453-07 linker uld HP Itanium(R) B.12.52

--------
: /opt/hpws22/apache/bin # ldd httpd
libaprutil-1.sl.2 => /opt/hpws22/apache/lib/libaprutil-1.sl.2
libexpat.sl.1 => /opt/hpws22/apache/lib/libexpat.sl.1
libapr-1.sl.2 => /opt/hpws22/apache/lib/libapr-1.sl.2
librt.so.1 => /usr/lib/hpux64/librt.so.1
libm.so.1 => /usr/lib/hpux64/libm.so.1
libpthread.so.1 => /usr/lib/hpux64/libpthread.so.1
libgss.so => /usr/lib/hpux64/libgss.so
libssl.so.1 => /usr/lib/hpux64/libssl.so.1
libcrypto.so.1 => /usr/lib/hpux64/libcrypto.so.1
libc.so.1 => /usr/lib/hpux64/libc.so.1
libm.so.1 => /usr/lib/hpux64/libm.so.1
/opt/hpws22/apache/lib/libexpat.sl.1 => /opt/hpws22/apache/lib/libexpat.sl.1
/opt/hpws22/apache/lib/libapr-1.sl.2 => /opt/hpws22/apache/lib/libapr-1.sl.2
librt.so.1 => /usr/lib/hpux64/librt.so.1
libgss.so => /usr/lib/hpux64/libgss.so
libssl.so.1 => /usr/lib/hpux64/libssl.so.1
libcrypto.so.1 => /usr/lib/hpux64/libcrypto.so.1
libpthread.so.1 => /usr/lib/hpux64/libpthread.so.1
libc.so.1 => /usr/lib/hpux64/libc.so.1
libdl.so.1 => /usr/lib/hpux64/libdl.so.1
libc.so.1 => /usr/lib/hpux64/libc.so.1
libdl.so.1 => /usr/lib/hpux64/libdl.so.1
libc.so.1 => /usr/lib/hpux64/libc.so.1
libdl.so.1 => /usr/lib/hpux64/libdl.so.1
Respected Contributor
Shinji Teragaito_1
Posts: 212
Registered: ‎12-20-2007
Message 2 of 5 (353 Views)

Re: Apache/2.2.8 startup problem

Can you make a support call to RC ?
Occasional Advisor
ATIL VOLKAN YILDIRIM_1
Posts: 11
Registered: ‎07-18-2008
Message 3 of 5 (353 Views)

Re: Apache/2.2.8 startup problem

Did so.

I found that the problem is caused by "SSLCertificateChainFile" directive in ssl.conf file...I don't understand...When I comment the directive, apache works fine...I need to solve this problem now...

Thanks anyway...
Occasional Advisor
ATIL VOLKAN YILDIRIM_1
Posts: 11
Registered: ‎07-18-2008
Message 4 of 5 (353 Views)

Re: Apache/2.2.8 startup problem

I typed the intermediate certificate in "SSLCACertificateFile" instead...Now everything seems to work...

Thanks..
Occasional Advisor
ATIL VOLKAN YILDIRIM_1
Posts: 11
Registered: ‎07-18-2008
Message 5 of 5 (353 Views)

Re: Apache/2.2.8 startup problem

.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.