HP P2000 G3 VAAI driver for vSphere 5.5 (2687 Views)
Reply
Occasional Advisor
Igor Maksimov
Posts: 8
Registered: ‎03-09-2009
Message 1 of 7 (2,687 Views)

HP P2000 G3 VAAI driver for vSphere 5.5

Hi there,

 

According to this link http://h18004.www1.hp.com/products/servers/software/vmware-esxi/driver_version.html the last customized ESXi image is missing VAAI driver. Any reason?

 

When 5.5 will be supported? Right now vCenter shows Hardware Acceleration: Uknown. 

 

I have tried to upload available hp_vaaip_p2000_210.zip package via VUM, but rejects: Cannot upload file, because it is invalid package. 

 

Thanks for feedback.

 

Igor.

Please use plain text.
Occasional Visitor
David242
Posts: 4
Registered: ‎12-02-2013
Message 2 of 7 (2,625 Views)

Re: HP P2000 G3 VAAI driver for vSphere 5.5

By now you should have figured out that you'd have to unzip the download... and then there is another zipped package in there that actually contains the VAAI PlugIn.  Mine says' "Unknown" as well, I've loaded the package at least 3 times... rebooted, nothing.  Guess it's not "really" supported on the P2000G3 yet.

Please use plain text.
Occasional Visitor
David242
Posts: 4
Registered: ‎12-02-2013
Message 3 of 7 (2,620 Views)

Re: HP P2000 G3 VAAI driver for vSphere 5.5

Just for grins, I did it again... this time via the console.  First I went here and grabbed the package from HP, then copied it to the /tmp directory on my ESXi host.

 

Shutdown all my VM's, manually entered maintenance mode... then jumped on the console:

 

# esxcli software vib install -d /tmp/hp_vaaip_p2000_offline-bundle-210.zip
Installation Result
Message: Operation finished successfully.
Reboot Required: false
VIBs Installed: Hewlett-Packard_bootbank_vmware-esx-hp_vaaip_p2000_2.1.0-2
VIBs Removed:
VIBs Skipped:

 

*Notice it says a reboot is not required above.

 

I exited Maintenance Mode... refreshed my storage display and it still say's "Unknown".  I then re-entered Maintenance Mode and rebooted the host.  When it reconnected, I exited Maintenance Mode - rescanned storage... and nothing has changed, still say's "Unknown".  Oh also, I just installed my new P2000G3 and one host with the latest HP 5.5 ESXi image from VMware... handy to have all the updated drivers anyway.

 

 

Please use plain text.
HP Pro
PAC-MAN
Posts: 38
Registered: ‎02-12-2013
Message 4 of 7 (2,614 Views)

Re: HP P2000 G3 VAAI driver for vSphere 5.5

To support VAAI plugin P2000 G3 has to be updated to any greater version starting from TS203. But if i check the release notes for VAAI plugin i could see only the following as supported.

Version:
VAAI Plug-in for VMware vSphere 4.1: 1.00
VAAI Plug-in for VMware vSphere 5.0: 2.00

Sometime back i heard HP incorporated these plugins within latest HP ESXi image. you can find out that from this page.

http://h18004.www1.hp.com/products/servers/software/vmware-esxi/driver_version.html

ESXi 5.5 does not support VAAI capability is my understanding. check the firmware revision in P2000 G3, if its less than TS230 update to latest revision ie. TS250 may be that would help.
If you feel this was helpful please click the KUDOS! star in the left column!
Please use plain text.
Occasional Visitor
David242
Posts: 4
Registered: ‎12-02-2013
Message 5 of 7 (2,604 Views)

Re: HP P2000 G3 VAAI driver for vSphere 5.5

I did have to reboot my ESXi host again after making some vSwitch changes... turns out it's showing 'Supported' now; maybe I was just a bit impatient before.  So, I would guess the install via Console (above) is the best way to install VAAI into the HP ESXi 5.5 image.

Please use plain text.
Occasional Visitor
David242
Posts: 4
Registered: ‎12-02-2013
Message 6 of 7 (2,603 Views)

Re: HP P2000 G3 VAAI driver for vSphere 5.5

My updated all my firmware before I started... ESXi 5.5 does in fact support their VAAI primitives, it's just not bundled with the HP Image for some reason. 

Please use plain text.
Honored Contributor
Jan Soska
Posts: 1,232
Registered: ‎01-22-2008
Message 7 of 7 (2,063 Views)

Re: HP P2000 G3 VAAI driver for vSphere 5.5

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation