Re: TRIM & SharePoint - Search (568 Views)
Reply
Frequent Advisor
Tones
Posts: 82
Registered: ‎06-06-2010
Message 1 of 5 (867 Views)

TRIM & SharePoint - Search

I have followed the instructions for integrating TRIM 7.0.2 and SharePoint 2010 but I am unable to activate HP TRIM Search in the Site Collection Administration > Features. Following error message pops up:

 

You have attempted to activate the search feaure but failed in creating federated location for the search applications. This can be due to not having enough permission for the application pool account for the search administration database of the search applications.

Error number:

C12101

 

Anyone come across this before?

HP Expert
Neil Summers
Posts: 1,058
Registered: ‎10-08-2008
Message 2 of 5 (867 Views)

Re: TRIM & SharePoint - Search

Did you follow the instructions on page 15/16 of the install guide to the letter? The bit beginning with:

"Member of the db_owner role for the administration database for search service application

This requirement only applies to SharePoint 2010.

To activate the search feature, a federated location must be added to the collection of

federated locations. The application pool account needs to have permission to the

relevant database..."

Neil
Neil


Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.

(Please state the version of TRIM/HPRM you're using in all posts)

HP Software Support Online (SSO): http://support.openview.hp.com
Frequent Advisor
Tones
Posts: 82
Registered: ‎06-06-2010
Message 3 of 5 (867 Views)

Re: TRIM & SharePoint - Search

Neil,

 

followed the instructions (very carefully) still no luck. We do have FAST installed in our environment so does the TRIM integration work with FAST searching or is it tailored for standard SharePoint searching?

Occasional Visitor
gnlds
Posts: 1
Registered: ‎09-17-2013
Message 4 of 5 (585 Views)

Re: TRIM & SharePoint - Search

Hi Neil, Tones,

 

I am having the exactly same issue you gusy had 3 years ago. I have FAST and I am having the exact error message. Di you guys manage to solve it?

 

Thanks.

 

Regards,

 

gnlds

HP Expert
Neil Summers
Posts: 1,058
Registered: ‎10-08-2008
Message 5 of 5 (568 Views)

Re: TRIM & SharePoint - Search

I'm not aware of any specific solution to this issue. As far as I can tell from searching our internal systems, there's no official support for FAST search with SharePoint. I expect it's never been tested with the TRIM integration. If you have no success, you may wish to log a support case so we can get it officially investigated and hopefully get you a definite answer on whether FAST search is causing your problem.

Neil


Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.

(Please state the version of TRIM/HPRM you're using in all posts)

HP Software Support Online (SSO): http://support.openview.hp.com
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.