Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0 (1397 Views)
Reply
Frequent Advisor
Damitha
Posts: 67
Registered: ‎05-05-2010
Message 1 of 13 (1,397 Views)

Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

Hi,

 

I get above error with TRIM 7.2.0 SharePoint integration. I am running everything on one VM.

 

When I set up the integration, I enabled the integration for one site collection. I activated HP TRIM Record Management module and menu item module for the site collection. When I click on any TRIM menu items I get the error.

 

Any ideas?

 

Thanks,

Regards,

Damitha Bogahawatta
Principal Consultant
Talent Consulting Services
Occasional Advisor
Radeesh
Posts: 17
Registered: ‎10-28-2008
Message 2 of 13 (1,298 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

Hey Damitha

 

What is the error message ?

 

Rad

Regular Advisor
Mary Bray
Posts: 157
Registered: ‎12-13-2009
Message 3 of 13 (1,275 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

if it's the same as me:

Error

A problem has occurred:

Site collection settings are not set for this Data Exchnager instance. The site collection settings may have not been entered yet.

error number:

C1034

 

Running TRIM 7.2.1.3085 (64 Bit)

Windows server 2008 (running everything off one box including domain controller)

Using a single service account with admin rights everywhere

Sharepoint server 2010

SQL server 2008

 

I have set up everything I think but when I go into the HP TRIM site Collection Integtration settings page for my site the Site Record and List Record record types are set to the default but if I set the Default container and /or Default Item record types and click OK the page just whirls away for ages then eventually stops without returning to the Site Settings page. If i get out and go back the settings i changed are not there.

 

Then if I try to use any of the TRIM menu items I encounter the error described above.

Advisor
Erik Wold
Posts: 25
Registered: ‎06-09-2009
Message 4 of 13 (1,261 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

Are you able to select the container or item record types from a TRIM web client list? Or are you just typing in the name (text probably turns red, and does not resolve). Take a look at this post, as it appears you are having the same issues. Without default container or item record types, no other menu functions should work.

Regular Advisor
Mary Bray
Posts: 157
Registered: ‎12-13-2009
Message 5 of 13 (1,258 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

no - i get the TRIM lists but they don't stick when i press the OK buton - the explorer window icon spins for ages but nothing happens

Frequent Advisor
Damitha
Posts: 67
Registered: ‎05-05-2010
Message 6 of 13 (1,253 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

Hi Mary,

 

Create two new record types (Folder record type and a document record type). Make sure folder record type has a higher level than the document record type. See whether you could assign these new record types as default record types. 

Regards,

Damitha Bogahawatta
Principal Consultant
Talent Consulting Services
Regular Advisor
Mary Bray
Posts: 157
Registered: ‎12-13-2009
Message 7 of 13 (1,249 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

That did the trick!! The OK button then went to Processing  and completed and the menu itmes now work against my list. But why did the old record types not work? They were the correct types and container levels - are there rules i need to know because we would want to use our standard record types via sharepoint if possible.

 

Thank you Damitha

Frequent Advisor
Damitha
Posts: 67
Registered: ‎05-05-2010
Message 8 of 13 (1,222 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

Hi Mary,

 

Can you check  whether the folder record type you are trying to use has titling method set to 'Classification"?

 

I can set existing record types as long as they are set to free text titling method. HP is investigating the issue. I will let you know what they say.

 

 

Regards,

Damitha Bogahawatta
Principal Consultant
Talent Consulting Services
Regular Advisor
Mary Bray
Posts: 157
Registered: ‎12-13-2009
Message 9 of 13 (1,217 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

Yes Damitha - they were using Classification titling (which we need) - look forward to hearing when it's fixed

Occasional Visitor
JaimieTilbrook
Posts: 1
Registered: ‎06-11-2012
Message 10 of 13 (1,198 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

Thanks for bringing this to our attention everybody.  We are looking into this as to whether we need a code fix or simply some guidance around using classification titled record types in this role.

I will update here when we have finished our research. This will likely take a few weeks for us to get to it.

 

Jaimie Tilbrook
Product Development Manager
HP TRIM SharePoint Integration

Frequent Advisor
Damitha
Posts: 67
Registered: ‎05-05-2010
Message 11 of 13 (1,167 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

Hi Mary,

 

Here is the defect ID. Hopefully it will be fixed in the next release :)

 

QCCR2D45184

 

 

Regards,

Damitha Bogahawatta
Principal Consultant
Talent Consulting Services
Frequent Visitor
bottpl
Posts: 2
Registered: ‎07-23-2012
Message 12 of 13 (904 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

I'm getting the same issue, but am running 7.3.0.  We de-activated the features at the Site Collection level and have deleted the Management Status column (another solution suggestion found online) from the site and we still get the Data Exchanger issue.  Any updates on solutions?

Honored Contributor
EWillsey
Posts: 1,930
Registered: ‎04-20-2010
Message 13 of 13 (897 Views)

Re: Site collection settings are not set for this Data Exchanger instance - TRIM 7.2.0

This was marked as resolved in 7.3.1 build 5351 (though use 5352 instead because there's a defect in that build).

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.