Re: Unable to connect to HP ALM from HP Service Test (2177 Views)
Reply
Occasional Contributor
Harikrishnan Narasiman
Posts: 7
Registered: ‎06-03-2010
Message 1 of 8 (3,907 Views)

Unable to connect to HP ALM from HP Service Test

Hi I am trying to connect to HP ALM 11 from HP Service Test 11.2 through ALM Connector inbuilt in Service Test.

 

1. I go to FILE > ALM / QC Connection

2. I put in my server address "https://<qcserver>/qcbin

3. I put in my "UserName" and "Password"

4. I click "Connect"

 

GUI ERROR: "Failed to update components from server https://<qcserver>/qcbin"

 

LOG ERROR: 2012-05-23 11:08:42,103 [Spider] ERROR HP.ST.Shared.QcConnectionUtils.QcConnection [(null)] - ALM/QC Connectivity helper error:
[ GetSpiderVersionFromServer ] Can't get server version. Can't optain data from server.
   at HP.QC.InternalIntegration.SystemUtils.GetSpiderVersionFromServer(String qcURL, AuthenticationContext authenticationContext)
   at HP.QC.InternalIntegration.SpiderHandler.get_SpiderVersion()
   at HP.QC.InternalIntegration.SpiderHandler.get_SpiderContext()
   at HP.QC.InternalIntegration.QCConnectivityHelper.DownloadAsync()

 

Can someone please help me?

Please use plain text.
Trusted Contributor
Yaron_Naveh
Posts: 113
Registered: ‎05-28-2010
Message 2 of 8 (3,900 Views)

Re: Unable to connect to HP ALM from HP Service Test

Hi

 

I need more information:

 

- do you use an http proxy? 

- which kind of authentication does the server use - basic or ntlm? if there is proxy which kind of auth it use?

 

also please publish (or send me to yaron.naveh@hp.com) the log you get from this:

 

1. install and run DebugView http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx

2. produce the error in ST (while DebugView is runing)

3. send me the log you see in DebugView

 

Yaron

Please use plain text.
Occasional Contributor
Harikrishnan Narasiman
Posts: 7
Registered: ‎06-03-2010
Message 3 of 8 (3,876 Views)

Re: Unable to connect to HP ALM from HP Service Test

Thanks for your assistance, I really Appreciate it

 

This is what I get, and I notice from below that it is trying to read "start_a.js" and fails. Actually should it not be "start_a.jsp" 

 

00000001 0.00000000 [2016] QCConnectivityHelper - Info: [HP.QC.InternalIntegration.QCConnectivityHelper] Creating the QCConnectivityHelper object
00000002 0.03159407 [2016] QCConnectivityHelper - Info: [HP.QC.InternalIntegration.QCConnectivityHelper] Using QC Server URL: https://<server>/qcbin/
00000003 0.03170998 [2016] QCConnectivityHelper - Info: [HP.QC.InternalIntegration.QCConnectivityHelper] Using Download Content Flavor: OTAOnly
00000004 0.03186225 [2016] QCConnectivityHelper - Info: [HP.QC.InternalIntegration.QCConnectivityHelper] Using Setup File: https://<server>/qcbin/setup_a.cab
00000005 0.06427499 [2016] QCConnectivityHelper - Error: [HP.QC.InternalIntegration.QCConnectivityHelper] Exception caught
00000006 0.06451836 [2016] QCConnectivityHelper - Exception caught: Failed reading start_a.js file from server https://<server>/qcbin/. QC Server might be unavailable
00000007 0.06451836 [2016]
00000008 0.06451836 [2016] Inner Exception message:
00000009 0.06451836 [2016] The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
00000010 0.06451836 [2016]
00000011 0.06451836 [2016] Stack Trace:
00000012 0.06451836 [2016] at HP.QC.InternalIntegration.SystemUtils.GetFileAsStrFromServer(String serverURL, AuthenticationContext authenticationContext, String fileName)
00000013 0.06451836 [2016] at HP.QC.InternalIntegration.SpiderHandler.GetSpiderVersion()
00000014 0.06451836 [2016] at HP.QC.InternalIntegration.SpiderHandler.get_SpiderVersion()
00000015 0.06451836 [2016] at HP.QC.InternalIntegration.SpiderHandler.get_SpiderContext()
00000016 0.06451836 [2016] at HP.QC.InternalIntegration.QCConnectivityHelper.DownloadAsync()

Please use plain text.
Occasional Contributor
Harikrishnan Narasiman
Posts: 7
Registered: ‎06-03-2010
Message 4 of 8 (3,872 Views)

Re: Unable to connect to HP ALM from HP Service Test

And we dont use any http proxy to connect. And not sure what kind of authentication we use its "https" if thats what you mean. I could confirm that from Administrator
Please use plain text.
Trusted Contributor
Yaron_Naveh
Posts: 113
Registered: ‎05-28-2010
Message 5 of 8 (3,859 Views)

Re: Unable to connect to HP ALM from HP Service Test

Hari - as we discussed offline this is an issue of untrusted ssl certificate on the qc installation. For example when IE tries to access QC not all is green - there is a certificate warning.

Please use plain text.
Occasional Advisor
Afzal-Shaik
Posts: 9
Registered: ‎02-07-2013
Message 6 of 8 (3,561 Views)

Re: Unable to connect to HP ALM from HP Service Test

Hi ,

 

Its just you need to use http://  not https://

Please use plain text.
Occasional Visitor
GaneshKumarKV
Posts: 2
Registered: ‎12-19-2013
Message 7 of 8 (2,177 Views)

Re: Unable to connect to HP ALM from HP Service Test

Hi...

 

I came across with similar issue recently.

 

Try this: http://support.microsoft.com/kb/2549423

 

Everything started to work great with above fix.

Please use plain text.
Occasional Visitor
RahulBhogle
Posts: 1
Registered: ‎06-11-2014
Message 8 of 8 (1,147 Views)

Re: Unable to connect to HP ALM from HP Service Test

I am unable to connect Vugen to ALM account.

 

When i try to connect ALM through Vugen to modify scripts, i am getting Error -

"Failed to update components from Server"

 

Following client components were not downloaded successfully:

5. WebClient.dll : Access is denied.

 

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation