Server automation 10, partial templates and preserve values option (211 Views)
Reply
Occasional Contributor
brutus300
Posts: 5
Registered: ‎06-11-2012
Message 1 of 2 (211 Views)

Server automation 10, partial templates and preserve values option

Hi!

We started the process of migrating our SA setup to 10.x version (latest and greatest :-)).

 

This is one of the issue we encountered:

 

- on our previous version (9.02) partial templates with preserve value option was great to keep existing values in the file while pushing only values for which there are entries in the value set; the documentation for older releases (7.x and 9.x) said:

"Preserve Values allows the user to specify that any values for a configuration on the server that aren't’t also stored on the core be preserved if at all possible.  This feature is useful if you don’t intend to import all the current values from the config into Opsware, or if you frequently have users or programs modifying configuration files outside of Opsware. 

Obviously we would like you to use Opsware for all of your configuration changes, but we realize this is not always possible."

 


- on the freshly installed 10.0 it  seems that something changed and the online documentation is somehow contradictory; in one part of the documentation we read:

Inherited From: Indicates where the value is inherited from. This column is only displayed when viewing at the server instance level and when you have Show Inherited Values selected.
If the Preserve Values option is set, the configuration file on the server becomes the outermost level of the inheritance hierarchy. That is, if no value exists in the value set, the value in the file will be preserved

while in other part:
Preserve Values: Specifies whether to preserve the values contained in the target configuration file on the managed server if there is no corresponding value in the value set. By default, this option is turned off.
 
Unfortunately it seems that the first quote applies: if we have a configuration templates and we are setting any value in the valueset then the existing values in the host configuration files are not being preserved no  matter the value of preserve values attribute.
 
Please tell me if this is a know feature or bug or if I'm missing something.
Please use plain text.
HP Expert
molinabro1
Posts: 501
Registered: ‎05-09-2007
Message 2 of 2 (181 Views)

Re: Server automation 10, partial templates and preserve values option

Hello,

 

Please be aware that I responded in the customer support forums on this same question.



Ed Molina
HP Cloud Solution Support Engineer

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution. Also, if you liked this post please consider providing Kudos on the left side.
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation