Recover a single server HPSA core on VMware (241 Views)
Reply
Member
JohnsonHays
Posts: 2
Registered: ‎11-08-2011
Message 1 of 3 (241 Views)

Recover a single server HPSA core on VMware

Hi,

 

I have a single server HPSA 9.04 core running on VMware.  I shutdown the the VM guest and used the VMware utility to make a clone.

 

I stared up the clone, the oracle database, and the SA application.  All started ok, and I was able to run a "service opsware-sas health" check on my cloned Redhat 5.6 VM, and it passed.  I then ran a system diagnosis  and it failed.  I tried to restart the application and it failed. 

 

Looking in the logs I saw that it was complaining about SSL certs.  I have applied the SSL patch to the source system, and used the same MAC address on the clone.

 

Does anyone have a good suggestion for DR recovery of a HPSA core running as a VM guest?

 

Thank you for your time.

 

Johnson

Please use plain text.
Member
JohnsonHays
Posts: 2
Registered: ‎11-08-2011
Message 2 of 3 (219 Views)

Re: Recover a single server HPSA core on VMware

All,

 

We believe that we have resolved the issue.

 

When you clone a server in VM, the server's Serial Number, aka bios.uuid, changes.  We edited the .vmx file so that the bios.uuid matched to source server, and SA passed its Web Systems Diagnostics.

 

In the future we will not clone the VM but copy the VM.

 

Johnson

Please use plain text.
Honored Contributor
Todd McDaniel_1
Posts: 1,387
Registered: ‎08-26-2002
Message 3 of 3 (165 Views)

Re: Recover a single server HPSA core on VMware

from where did you get this solution? I have a similar issue for a cloned vm and my webconsole keeps failing to connect. Everything else seems normal.
Unix, the other white meat.
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation