HPSA After SSL certificate update SA agents does not register with SA (1987 Views)
Reply
Occasional Visitor
mrazvann
Posts: 1
Registered: ‎02-04-2013
Message 1 of 3 (1,987 Views)

HPSA After SSL certificate update SA agents does not register with SA

After i updated successfully the SSL Certificate for SA Core with the new patch from HP , I tried to update the agents on workstations, but the agents does not register in SA. I took the workstation under management, install the agent from SA console but nothing is happened. I don’t see the workstation to Managed Servers

Also I tried to uninstall the old agent manually (msiexec.exe /qn /x "C:\Program Files\Opsware\agent\pylibs\cog\uninstall\agent_uninstall_x86.msi" REMOVE_MSI_ONLY=1) and the install the new agent with parameter --force_new_device, but no success.

In the log I got this errors, maybe someone knows how to fix them. To mee it seem to be a python error

Thanks.

 

[04/Feb/2013 13:34:09] [INFO] Setting the system time.

[04/Feb/2013 13:34:09] [TRACE] RunSetTimeScript()

[04/Feb/2013 13:34:09] [TRACE] RunCommand( ""C:\Program Files\Opsware\agent\lcpython15\python.exe" "C:\Program Files\Opsware\agent\pylibs\cog\set_time.pyc" " )

[04/Feb/2013 13:34:10] Traceback (most recent call last):

[04/Feb/2013 13:34:10]   File ".\set_time.py", line 55, in ?

[04/Feb/2013 13:34:10]   File ".\cmdline_method.py", line 180, in __call__

[04/Feb/2013 13:34:10]   File ".\set_time.py", line 46, in execute

[04/Feb/2013 13:34:10]   File ".\synctime.py", line 50, in synctime

[04/Feb/2013 13:34:10]   File ".\spinwrapper.py", line 110, in func

[04/Feb/2013 13:34:10]   File ".\spinwrapper.py", line 241, in getInfoFromServer

[04/Feb/2013 13:34:10]   File "C:\Program Files\Opsware\agent\lcpython15\lib\xmlrpclib.py", line 823, in __call__

[04/Feb/2013 13:34:10]     self._value = 0

[04/Feb/2013 13:34:10]   File ".\xmlrpc\lcxmlrpclib.py", line 113, in __request

[04/Feb/2013 13:34:10]   File "C:\Program Files\Opsware\agent\lcpython15\lib\xmlrpclib.py", line 910, in __request

[04/Feb/2013 13:34:10]    

[04/Feb/2013 13:34:10]   File ".\SSLTransport.py", line 71, in request

[04/Feb/2013 13:34:10]   File ".\asyncssl.py", line 108, in connect

[04/Feb/2013 13:34:10]   File ".\asyncssl.py", line 157, in _connect_inner

[04/Feb/2013 13:34:10]   File ".\asyncssl.py", line 314, in ssl_connect

[04/Feb/2013 13:34:10]   File ".\asyncssl.py", line 339, in _timeout_io

[04/Feb/2013 13:34:10] M2Crypto.SSL.Error: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca

[04/Feb/2013 13:34:10] [TRACE] RunCommand() = 0

[04/Feb/2013 13:34:10] [TRACE] RunSetTimeScript() = 0

[04/Feb/2013 13:34:10] [WARN] Failed to set system time.

[04/Feb/2013 13:34:10] [INFO] Registering server with the Opsware core.

[04/Feb/2013 13:34:10] [TRACE] RunInitialRegScript()

 

 

 

[04/Feb/2013 13:34:17] Traceback (most recent call last):
[04/Feb/2013 13:34:17]   File ".\agent_reg_common.py", line 408, in blockingmainThread
[04/Feb/2013 13:34:17]   File ".\agent_reg_common.py", line 392, in blocking_initial_register_or_update
[04/Feb/2013 13:34:17]   File ".\agent_reg_common.py", line 198, in register_or_update_hardware_initial
[04/Feb/2013 13:34:17]   File ".\spinwrapper.py", line 110, in func
[04/Feb/2013 13:34:17]   File ".\spinwrapper.py", line 239, in getInfoFromServer
[04/Feb/2013 13:34:17]   File ".\xmlrpc\xmlrpclib.py", line 823, in __call__
[04/Feb/2013 13:34:17]     self._value = 0
[04/Feb/2013 13:34:17]   File ".\xmlrpc\lcxmlrpclib.py", line 113, in __request
[04/Feb/2013 13:34:17]   File ".\xmlrpc\xmlrpclib.py", line 910, in __request
[04/Feb/2013 13:34:17]   File ".\SSLTransport.py", line 71, in request
[04/Feb/2013 13:34:17]   File ".\asyncssl.py", line 108, in connect
[04/Feb/2013 13:34:17]   File ".\asyncssl.py", line 157, in _connect_inner
[04/Feb/2013 13:34:17]   File ".\asyncssl.py", line 314, in ssl_connect
[04/Feb/2013 13:34:17]   File ".\asyncssl.py", line 339, in _timeout_io
[04/Feb/2013 13:34:17] Error: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
[04/Feb/2013 13:34:17]
[04/Feb/2013 13:34:17] --------------------------
[04/Feb/2013 13:34:17] Exception exceptions.KeyError: <exceptions.KeyError instance at 0x018E3A30> in <module 'threading' from 'C:\Program Files\Opsware\agent\lcpython15\lib\threading.py'> ignored
[04/Feb/2013 13:34:17] [TRACE] RunCommand() = 0
[04/Feb/2013 13:34:17] [TRACE] RunRegScript() = 0
[04/Feb/2013 13:34:17] [TRACE] RunInitialRegScript() = 0
[04/Feb/2013 13:34:17] [WARN] Full server registration failed (See above for explanation). When started, the Opsware agent will remain in dormant mode until server registration succeeds.
[04/Feb/2013 13:34:17] [INFO] Writing force_new_device_requested file: C:\Program Files\Common Files\Opsware\agent\force_new_device_requested
[04/Feb/2013 13:34:17]

 

 

[04/Feb/2013 13:34:17] [INFO] Registering software inventory with the Opsware core.
[04/Feb/2013 13:34:17] [TRACE] RunSwRegScript()
[04/Feb/2013 13:34:17] [TRACE] RunCommand( ""C:\Program Files\Opsware\agent\lcpython15\python.exe" "C:\Program Files\Opsware\agent\pylibs\cog\bs_software.pyc" " )
[04/Feb/2013 13:34:18] Registering full software inventory information...
[04/Feb/2013 13:34:18] -----Unexpected Error-----
[04/Feb/2013 13:34:18] Traceback (most recent call last):
[04/Feb/2013 13:34:18]   File ".\bs_software.py", line 511, in blockingmainThread
[04/Feb/2013 13:34:18]   File ".\bs_software.py", line 489, in blockingmain
[04/Feb/2013 13:34:18]   File ".\bs_software.py", line 457, in do_software
[04/Feb/2013 13:34:18]   File ".\cmdline_method.py", line 98, in getmid
[04/Feb/2013 13:34:18]   File ".\platform_handler.py", line 87, in getMid
[04/Feb/2013 13:34:18]   File ".\platform_handler.py", line 100, in getFileMid
[04/Feb/2013 13:34:18] IOError: [Errno 2] No such file or directory: 'C:\\Program Files\\Common Files\\Opsware\\etc\\agent\\mid'
[04/Feb/2013 13:34:18]
[04/Feb/2013 13:34:18] --------------------------
[04/Feb/2013 13:34:18] [TRACE] RunCommand() = 0
[04/Feb/2013 13:34:18] [TRACE] RunSwRegScript() = 0
[04/Feb/2013 13:34:18] [WARN] Software inventory reporting failed (See above for explanation).
[04/Feb/2013 13:34:18] [INFO] Writing do_check_reachability file: C:\Program Files\Common Files\Opsware\agent\do_check_reachability
[04/Feb/2013 13:34:18] [INFO] Successfully created do_check_reachability file: C:\Program Files\Common Files\Opsware\agent\do_check_reachability

Senior Member
clbarber
Posts: 1
Registered: ‎03-07-2012
Message 2 of 3 (1,970 Views)

Re: HPSA After SSL certificate update SA agents does not register with SA

I'm not sure where the crypto directory lives on Windows clients, but you might try removing that before re-installing the agent.

I found that I was having similar issues as you, and removing /var/opt/opsware/crypto/agent (Linux clients) before re-running the installer did the trick. 

Frequent Visitor
DougHill
Posts: 2
Registered: ‎12-11-2012
Message 3 of 3 (1,944 Views)

Re: HPSA After SSL certificate update SA agents does not register with SA

I had the same issue... Look at the agent version you are installing.

 

The SSL certificate was updated on the agent installer as well - Look at your SA core for agent installers for the update versions.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.