Agent install errors (707 Views)
Reply
Occasional Contributor
Idontdowindows
Posts: 2
Registered: ‎12-08-2011
Message 1 of 5 (707 Views)

Agent install errors

When installing the agent via command line on my hp-ux B.11.31, I receive errors that the gateway is unreachable. 

When installing the agent via hpsa 9.1 java client, I receive errors "Unable to connet to the Gateway."  While the final act of the script usage (via the java client,)of sudo is incorrect (see below), there are no other details as to why the gateway is unreachable.  

Both servers are able to communicate via IP or server name, I manually added each to the respective hosts file. And the firewall has been disabled on the hpsa server core/satellite.

When I install the agent to communicate with another satellite, it is successful - which leaves me to believe this is a problem/configuration issue on my satellite/core hpsa 9.1 server.

 

Thoughts?????

 

$ \id
uid=xxxxxxxxx gid=xxxxxxxx  (blacked out for security by me)
$ \sudo ; \sudo id
usage: sudo -h | -K | -k | -L | -V
usage: sudo -v [-AknS] [-p prompt]
usage: sudo -l[l] [-AknS] [-g groupname|#gid] [-p prompt] [-U username] [-u
            username|#uid] [-g groupname|#gid] [command]
usage: sudo [-AbEHknPS] [-C fd] [-g groupname|#gid] [-p prompt] [-u
            username|#uid] [-g groupname|#gid] [VAR=value] [-i|-s] [<command>]
usage: sudo -e [-AknS] [-C fd] [-g groupname|#gid] [-p prompt] [-u
            username|#uid] file ...
Last successful login:       Thu Dec  8 05:24:36 CST 2011 uspls100.elabs.eds.com  
Last authentication failure: Wed Dec  7 12:05:29 CST 2011   
uid=0(root)Thu Dec 08 13:06:36 2011: One or more prerequisite checks failed
Thu Dec 08 13:06:36 2011: Prerequisites check failed

Completed.

Please use plain text.
Occasional Contributor
Pasturco
Posts: 4
Registered: ‎06-27-2011
Message 2 of 5 (691 Views)

Re: Agent install errors

Hi,

 

By default, satellite has open 3466 and 3001, from client, could you conect to this ports:

 

telnet xxxxx 3001 3466.

Please use plain text.
Occasional Contributor
KarthikBinnu
Posts: 3
Registered: ‎08-09-2012
Message 3 of 5 (552 Views)

Re: Agent install errors

Hi,

 

Please check the Agent Prerequisites from the server.

 

Agent  Data communication ports 1002 & 3001bi-directional.

 

try to do telnet     Telnet <server name> 1002

 

Regards

Karthik


Idontdowindows wrote:

When installing the agent via command line on my hp-ux B.11.31, I receive errors that the gateway is unreachable. 

When installing the agent via hpsa 9.1 java client, I receive errors "Unable to connet to the Gateway."  While the final act of the script usage (via the java client,)of sudo is incorrect (see below), there are no other details as to why the gateway is unreachable.  

Both servers are able to communicate via IP or server name, I manually added each to the respective hosts file. And the firewall has been disabled on the hpsa server core/satellite.

When I install the agent to communicate with another satellite, it is successful - which leaves me to believe this is a problem/configuration issue on my satellite/core hpsa 9.1 server.

 

Thoughts?????

 

$ \id
uid=xxxxxxxxx gid=xxxxxxxx  (blacked out for security by me)
$ \sudo ; \sudo id
usage: sudo -h | -K | -k | -L | -V
usage: sudo -v [-AknS] [-p prompt]
usage: sudo -l[l] [-AknS] [-g groupname|#gid] [-p prompt] [-U username] [-u
            username|#uid] [-g groupname|#gid] [command]
usage: sudo [-AbEHknPS] [-C fd] [-g groupname|#gid] [-p prompt] [-u
            username|#uid] [-g groupname|#gid] [VAR=value] [-i|-s] [<command>]
usage: sudo -e [-AknS] [-C fd] [-g groupname|#gid] [-p prompt] [-u
            username|#uid] file ...
Last successful login:       Thu Dec  8 05:24:36 CST 2011 uspls100.elabs.eds.com  
Last authentication failure: Wed Dec  7 12:05:29 CST 2011   
uid=0(root)Thu Dec 08 13:06:36 2011: One or more prerequisite checks failed
Thu Dec 08 13:06:36 2011: Prerequisites check failed

Completed.


 

Please use plain text.
Frequent Advisor
Probir
Posts: 48
Registered: ‎11-09-2011
Message 4 of 5 (530 Views)

Re: Agent install errors

Check whether you are able to connect to the gateway from the HP-UX server

 

telnet <sa core ip> 3001

 

Also, agent will use port 1002 to communicate. So make sure that port 1002 is bidirectionally open.

Please use plain text.
HP Expert
tbryceryan
Posts: 13
Registered: ‎01-04-2009
Message 5 of 5 (517 Views)

Re: Agent install errors

Pasturco:

 

Just to be clear, the default SA gateway/satellite configuration only uses port 3001 for agent to gateway communication. Other ports may or may not be open for other purposes on the gateway/satellite server, but the HP SA gateway network default configuration only uses port 3001 for agent communications.

 

It is possible to change this port on a server by server basis, using the gateway's properties file, but this should be planned for and tested, and local documentation and operational procedures should be updated accordingly. And, if the default configuration is changed, any support incidents filed should make special note of that fact. In general, we recommend changing the default agent gateway port only if port 3001 is used for some other widely used service in the customer's installation.

 

 

 

Bryce Ryan

HP Premier Support

If you find this or any post resolves your issues, please be sure to mark it as an accepted solution.
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation