Problem with ssh and preexpired password (371 Views)
Reply
Occasional Visitor
Vaclav Dolezel
Posts: 4
Registered: ‎04-04-2005
Message 1 of 12 (371 Views)
Accepted Solution

Problem with ssh and preexpired password

Hello. I Found on wizard number 9880 same problem like me. But the solutions is not working. I have OpenVMS 7.3-2 and I use PowerTerm Plus Emulation. I try putty last version and this don't work too. But the product Reflection 12.0.6 form WRQ is working. Where is the problem? Thanks for your information. VD
HP Pro
Ian Miller.
Posts: 4,371
Registered: ‎06-03-2003
Message 2 of 12 (371 Views)

Re: Problem with ssh and preexpired password

http://h71000.www7.hp.com/wizard/wiz_9880.html
does say that some clients work and some dont.
Another workaround is to disable forcing
users to change their passwords
in authorize
MOD username/FLAG=DISFORCE_PWD_CHANGE
____________________
Purely Personal Opinion
Occasional Visitor
Vaclav Dolezel
Posts: 4
Registered: ‎04-04-2005
Message 3 of 12 (371 Views)

Re: Problem with ssh and preexpired password

I now, that work. But we need, so as our users don't access to command line. If i set flag DISFORCE_PWD_CHANGE, the users jump to command line. VD
HP Pro
Ian Miller.
Posts: 4,371
Registered: ‎06-03-2003
Message 4 of 12 (371 Views)

Re: Problem with ssh and preexpired password

The TCPIP V5.5 release notes mention setting the option and say that Putty is one the two clients known to work.
____________________
Purely Personal Opinion
HP Pro
Ian Miller.
Posts: 4,371
Registered: ‎06-03-2003
Message 5 of 12 (371 Views)

Re: Problem with ssh and preexpired password

For V5.4
http://h71000.www7.hp.com/doc/732final/aa-rvbua-te/aa-rvbua-te.html
____________________
Purely Personal Opinion
HP Pro
Ian Miller.
Posts: 4,371
Registered: ‎06-03-2003
Message 6 of 12 (371 Views)

Re: Problem with ssh and preexpired password

Note you should be up to date with putty 0.57
http://www.chiark.greenend.org.uk/~sgtatham/putty/
20th February 2005
____________________
Purely Personal Opinion
Occasional Visitor
Vaclav Dolezel
Posts: 4
Registered: ‎04-04-2005
Message 7 of 12 (371 Views)

Re: Problem with ssh and preexpired password

Thanks for your information.I using last version of putty. I change in ssh setings file parameter "DisableLanguageTag" to value YES, but still don't working.
HP Pro
Ian Miller.
Posts: 4,371
Registered: ‎06-03-2003
Message 8 of 12 (371 Views)

Re: Problem with ssh and preexpired password

and you have set AllowNonvmsLoginWithExpiredPw to be YES on the SSH server config file?

What version of TCPIP and which patches?
____________________
Purely Personal Opinion
Occasional Visitor
Vaclav Dolezel
Posts: 4
Registered: ‎04-04-2005
Message 9 of 12 (371 Views)

Re: Problem with ssh and preexpired password

Version of TCPIP patch is 5.4-154,
and parametr AllowNonvmsLoginWithExpiredPw is set to YES.
Occasional Visitor
CadillacCulkin
Posts: 1
Registered: ‎03-14-2006
Message 10 of 12 (371 Views)

Re: Problem with ssh and preexpired password

I am having a very similar problem with expired passwords - I have Version 5.5 of the TCP/IP and the latest version of Putty.

AllowNonvmsLoginWithExpiredPw = YES

Any Suggestions

Thanks for your time.
Occasional Advisor
Anup Kumar
Posts: 7
Registered: ‎01-04-2005
Message 11 of 12 (371 Views)

Re: Problem with ssh and preexpired password

Hi Folks,

I am running tcp/ip V5.4 with latest ECO 5 patchkit. I have got some accounts on server which are supposed to have null password which should not expire with password lifetime set to 30 days. I have seen once pwd lifetime is reached , ssh login prompts user to change the passsword but at the same time telnet login lets the user in with asking to change the password.

In my environment, Its mandatory to set pwd lifetime and we cannot set DISFORCE_PWD_CHANGE flag on accounts. Is there any workaround so that ssh login does not to change the password. I even tried resetting the account as

mos acccountname/nopass/nopwdexp

Still once the pwd lifetime is reached, ssh login prompts to change the passwword but tetlnet login no issues. Please advise ?
JCG
Occasional Visitor
JCG
Posts: 2
Registered: ‎01-09-2007
Message 12 of 12 (371 Views)

Re: Problem with ssh and preexpired password

I got it to work!!
Edit the file:
SYS$SYSDEVICE:[000000.TCPIP$SSH.SSH2]SSHD2_CONFIG.

There is a line in this file that says this:
# AllowNonvmsLoginWithExpiredPw no
Change it to the following:
AllowNonvmsLoginWithExpiredPw yes

Also, if you are using PuTTY, you will need to use the latest "development snapshot", NOT the latest release, it doesn't support SSH-2 password expiry mechanisms.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.