Re: Enabling SSL (port 636) (96 Views)
Reply
Frequent Advisor
Michael Ernstoff
Posts: 89
Registered: ‎09-13-2000
Message 1 of 11 (97 Views)

Enabling SSL (port 636)

I am following someone else's instructions to configure some HP-UX servers (11.00 and 11.11) to be LDAP clients. This is not something I have any experience with.

I install the depot, and copy the key3.db and cert7.db to /etc/opt/ldapux.
When I run /opt/ldapux/config/setup, if I specifiy port 636 then the setup program just hangs. If I leave the default port number of 389 I can run all of the setup program.
636 does not appear in /etc/services.
What do I need to do to enable SSL?
Exalted Contributor
Steven E. Protter
Posts: 33,806
Registered: ‎08-15-2002
Message 2 of 11 (97 Views)

Re: Enabling SSL (port 636)

Shalom Michael,

Copy the /etc/services entry from 443 to 636 to start.

Make sure the ssl.conf file listens on port 636 and there are no other firewall products messing with the product.

Restart networking or the whole box and try again.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Frequent Advisor
Michael Ernstoff
Posts: 89
Registered: ‎09-13-2000
Message 3 of 11 (97 Views)

Re: Enabling SSL (port 636)

Shalom Steven,

There is no entry for 443 in /etc/services and there are no files called ssl.conf
There must be something not loaded or started that the writer of the document assumed would be loaded.
I expect it will be something really obvious, but I don't really know where to start looking.
Frequent Advisor
Michael Ernstoff
Posts: 89
Registered: ‎09-13-2000
Message 4 of 11 (97 Views)

Re: Enabling SSL (port 636)

I should have added:
When I try to connect using
"telnet hostname 636" I get "Unable to connect to remote host: Connection refused"

I think that something very basic is missing. The answer is going to be something simple like "run this command" or "install this depot".
Honored Contributor
Sameer_Nirmal
Posts: 2,108
Registered: ‎02-21-2004
Message 5 of 11 (97 Views)

Re: Enabling SSL (port 636)

Hi,

I suspect SSL is not installed in your server. Check by running
#swlist -l product openssl
If not installed , download it from
http://software.hp.com and install the depot on the server using swinstall.

Port 636 could only be used with you are using SSL protocol.
Frequent Advisor
Michael Ernstoff
Posts: 89
Registered: ‎09-13-2000
Message 6 of 11 (97 Views)

Re: Enabling SSL (port 636)

OpenSSL is not installed on the server.
I went to software.hp.com and did a search on OpenSSL and there is a depot for HP-UX 11i only.
Is there a depot available for 11.00?
Respected Contributor
Sยภเl Kย๓คг
Posts: 526
Registered: ‎08-19-2004
Message 7 of 11 (97 Views)

Re: Enabling SSL (port 636)

Hi,

You can download it from http://mirrors.develooper.com/hpux/downloads.html

Regards,
Sunil
Your imagination is the preview of your life's coming attractions
Frequent Advisor
Michael Ernstoff
Posts: 89
Registered: ‎09-13-2000
Message 8 of 11 (97 Views)

Re: Enabling SSL (port 636)

I have now installed OpenSSL, but still have the same problem as before.
I have not been through any configuration of SSL. It is unlikely that my predecessor would have done this without any documentation on it.
I still think that there is something very simple that I must be missing.
Honored Contributor
Arunvijai_4
Posts: 4,194
Registered: ‎04-07-2005
Message 9 of 11 (97 Views)

Re: Enabling SSL (port 636)

You need configure SSL,generate certificates and pass them to clients.
www.openssl.org for more information.

-Arun
"A ship in the harbor is safe, but that is not what ships are built for"
Frequent Advisor
Michael Ernstoff
Posts: 89
Registered: ‎09-13-2000
Message 10 of 11 (97 Views)

Re: Enabling SSL (port 636)

The certificates have already been configured on the LDAP server, and copied to this HP-UX client.
Occasional Advisor
Brian Miller_9
Posts: 10
Registered: ‎09-06-2005
Message 11 of 11 (96 Views)

Re: Enabling SSL (port 636)

Michael,
You don't specifiy port 636 as part of the initial setup program. You generally need to make an initial connection to port 389 to your LDAP server, and then when asked if you want to use SSL, you will say yes.

In addition, simply copying the certs from the LDAP server is not enough. You also have to run /opt/ldapux/contrib/bin/certutil to actually import the certs to your HP-UX system. My experience is this must be done on each client system; simply copying them from one client to another won't work. When importing certs from our Novell eDirectory, I need to run both of these commands:
â /opt/ldapux/contrib/bin/certutil -N -d /etc/opt/ldapuxâ and â /opt/ldapux/contrib/bin/certutil -A -n ldap -t â TC,C,Câ -u C -d /etc/opt/ldapux -i /etc/opt/ldapux/file.derâ to get the certificates properly imported. Your specific options may vary, but the man page (located under /opt/ldapux/share/man) provides some good detail.

When the certs are properly installed, the setup program will ask if you want to use SSL (but after you have first specified a connection on port 389). After you say yes to SSL, then you are able to specify port 636.

I've attached the documentation I developed for our environment, but since it is specific for Novell eDirectory, you are likely to have to make some changes.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.