OTA version not compatible with the ALM server (24430 Views)
Reply
Occasional Contributor
Aure
Posts: 4
Registered: ‎03-26-2012
Message 1 of 17 (24,430 Views)

OTA version not compatible with the ALM server

Hello,

 

I have an error when I try to use the excel Add IN : "OTA version is not compatible with the ALM server: http://server:port/qcbin/wcomsrv.dll. OTA version: 11, OTA build number:4804. Server version: 11, server build number: 7051".

This message appears when I click on Next button, after having entered my user name and user password.

 

When I see the version on QC(SP03), the OTA client build is 7051. (all the other components have the same version)

I followed the instructions of the Add-in guide to install Add-in Excel.

I use Microsoft Excel 2010 (version 14.0.6112.5000(32 bit)).

The version of the HP ALM Export Wizard is V.11.0.0.36 ...

 

I don't understand ...

 

Thanks for your help

Honored Contributor
Trudy Claspill
Posts: 3,759
Registered: ‎09-09-2010
Message 2 of 17 (24,326 Views)

Re: OTA version not compatible with the ALM server

Prior to installing the Excel Add-in, did you have any previous version of the Excel Add-in, or any other QC related add-in, installed? You would need to uninstall old version before installing current versions.

Did you get the Add-in fresh from the same server you are connecting to for QC?

Did you run the HP ALM Client Registration add-in, as instructed in the Excel Add-in installation instructions?
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Frequent Advisor
Ksan2010
Posts: 45
Registered: ‎05-05-2010
Message 3 of 17 (23,379 Views)

Re: OTA version not compatible with the ALM server

Hi I face the same situation - but the problem is  cannot  log in at all.......

Honored Contributor
Trudy Claspill
Posts: 3,759
Registered: ‎09-09-2010
Message 4 of 17 (23,356 Views)

Re: OTA version not compatible with the ALM server

ksan,

How is your problem the same as the original problem? Are you using the Excel add-in too?

Please provide more details about your issue, like what version and patch level of QC are you using? What has changed in your environment since the last time you did nt have a problem?
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Frequent Advisor
Ksan2010
Posts: 45
Registered: ‎05-05-2010
Message 5 of 17 (23,342 Views)

Re: OTA version not compatible with the ALM server

[ Edited ]
 To  and all
 
"OTA version not compatible with the ALM server" title  is not limited only to Excell add-in but also might touch other aspects  and it was my case - Happily I solved my problem more detailed desctription and solution that worked for me 
  

The problem was with login in to the project not using Excell add-in - Screenshot presenting   error pop up attached,

The problem was that after server upgrade, client machine didn't update build version.

The solution I tried and it worked was deleting folder.

 

c:\users\<userid>\AppData\Local\HP

 

After deleting it - after entering IP address in the browser all new .dll were installed and finally both versions were synchronised.

 

So the solution for my case - desynchronisation of build version between server and client that blocks login in is to reinstall QC.

Advisor
Michael_610
Posts: 22
Registered: ‎02-02-2005
Message 6 of 17 (23,327 Views)

Re: OTA version not compatible with the ALM server

Firstly please ensure you have the latest version of Excel add-in, go to the ad-in page and download the latest Excel add-in, you may need to uninstall the old one.

On the other hand, you need to register your client component again, in add-in page, you can find the link, or use the following link:

http://<server>:<port>/qcbin/start_a.jsp?common=true

Trusted Contributor
visit_alok
Posts: 147
Registered: ‎07-03-2012
Message 7 of 17 (23,324 Views)

Re: OTA version not compatible with the ALM server

Did you install the QC 11 Client component using the MSI?
Are you in QC 11 SP 3 Patch 9?

The root cause of the issue is that the updated OTA client dll was not downloaded and registered into the client machine.

The solution is to remove the client component from the local machine and reinstall. You can do so by deleting the folder c:\users\<userid>\AppData\Local\HP and then access the QC URL and register the client component from the addin page (if you want to integrate QC with other application).

However if any one know why the MSI did not download and register the latest OTA client dll then please do let me know.
Please note :- Any solution or queries expressed in my postings are mine alone, and do not reflect the opinions of my employer.
Frequent Advisor
Ksan2010
Posts: 45
Registered: ‎05-05-2010
Message 8 of 17 (23,323 Views)

Re: OTA version not compatible with the ALM server

[ Edited ]

With regards to HP ALM 11 - to synchronise EXcel add-in - there is a ne procedure described  in Installation guide,

it needs  some  additional steps comparing  to earlier versions of HP QC,:

 

Extaract of  installation steps   in attachment

 

Advisor
Michael_610
Posts: 22
Registered: ‎02-02-2005
Message 9 of 17 (23,317 Views)

Re: OTA version not compatible with the ALM server

To Ksan2010,

I notice that you are using ALM11, so there is no need to register any DLL before you login to the project from IE, so the issue could be related to the way how to deploy ALM/QC client previously. Would you please tell how to install ALM client last time on your client machine? 

You may install the ALM client by the following methods, please tell which way you used:

1. Access ALM page, download and install ActiveX control from IE, then IE downloads all client files and displays the login page

2. Access ALM page, download and install a file called "ALM-platform-loader.msi", then IE downloads all client files and displays the login page

3. You used MSI generator to create a MSI client installation file and then install it on the client machine.

 

Which method did you use?

Frequent Advisor
Ksan2010
Posts: 45
Registered: ‎05-05-2010
Message 10 of 17 (23,312 Views)

Re: OTA version not compatible with the ALM server

Michael I solved my problem, as you  could see in my message  - solution that worked for me was provided to  forum users.

It was also  repeated  by isit_alok

 

Of course your valuable answers are great but .... you are answering answered  questions

 

Occasional Visitor
Rex99
Posts: 2
Registered: ‎04-25-2013
Message 11 of 17 (16,008 Views)

Re: OTA version not compatible with the ALM server

Thanks KSAN, that worked for me.

Frequent Advisor
raghutammina
Posts: 30
Registered: ‎03-08-2010
Message 12 of 17 (14,718 Views)

Re: OTA version not compatible with the ALM server

Even we have same issue after installing patch15.

 

OTA Vesrtion is not comapatible with the Applicatin Lifecycle Management server: http://Server/qcbin/wcomsrv.dll. OTA vesrion : 11,OTA build number:7866.Server version :11,serverbuild number :8258

 

Tried all the options posted in this thread .. still no luck ...

Appreciate if your help.

 

-Raghu

Raghu
Regular Visitor
Gary-ODJFS
Posts: 4
Registered: ‎03-06-2013
Message 13 of 17 (13,240 Views)

Re: OTA version not compatible with the ALM server

[ Edited ]

Installed patch 15 and got the same error on all controllers with ota connection to alm.  You need to go to the addin page and run the HP Quality Center Connectivity (TD connect)  on each host.  If you can not get to the addin page from the host you cna save and copy it to each host from your desktop.

Thanks

Occasional Advisor
jeschwartz
Posts: 10
Registered: ‎05-15-2012
Message 14 of 17 (8,677 Views)

Re: OTA version not compatible with the ALM server

Upgraded to ALM 11.0 Patch 13 last month. Getting reports of people getting the following:

a general error has occurred OTA version is not compatible with the application lifecycle Management server

OTA build number: 6051 server: 11  server build number : 8092

 

I have tried a few of the options listed in other posts, but the problem is many of them require the user to have admin rights for things such as reinstalling the connectivity connector, removing folders, and even running the: 

qcbin/start_a.jsp?common=true page. It worked for me ( although I have admin rights), but my end users are getting a message that administrative rights are required.

 

Any suggestions on how to resolve the problem for users without Admin rights?

Trusted Contributor
anuragjalan
Posts: 284
Registered: ‎03-05-2012
Message 15 of 17 (8,660 Views)

Re: OTA version not compatible with the ALM server

You need to register HP ALM Client registration (qcbin/start_a.jsp?common=true) to resolve this issue for which admin rights are required.

Occasional Contributor
RP_2
Posts: 5
Registered: ‎03-09-2010
Message 16 of 17 (7,470 Views)

Re: OTA version not compatible with the ALM server

This solution of:

 

You would need to uninstall old version of [HP ALM Client Registration] before installing current versions.
A possible solution is deleting folder. c:\users\<userid>\AppData\Local\HP

After deleting it - after entering IP address in the browser all new .dll were installed and finally both versions were synchronised.

 

Helped us out when we migrated from patch 9 to patch 17.

Occasional Visitor
Joyce2014
Posts: 1
Registered: ‎06-09-2014
Message 17 of 17 (7,165 Views)

Re: OTA version not compatible with the ALM server

I have a similar problem now .We want to export the test cases from ALM 11.0 .So  I download a tool ,named Import Export tool for Quality Center .When I connect QC by it ,the problem shows as the attached screenshot .It says  :

 

OTA version is not compatible with the Application Lifecycle Management server: http://172.26.40.100:8080/qcbin/wcomsrv.dll.
OTA version: 11, OTA build number: 7051. Server version: 11, server build number: 7033.

 

 

I try to delete the files under path  C:\Users\{username}\AppData\Local\HP  

and then reinstall OTA by input ALM server URL again .

However it still now work ! 

This tool works well in my workmate's PC ,and we use the same ALM server .

 

Is there anyone can help me ?

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.