Infragistics control testing with QTP 11 (311 Views)
Reply
Occasional Contributor
Tim Costanzo
Posts: 6
Registered: ‎09-02-2010
Message 1 of 4 (311 Views)

Infragistics control testing with QTP 11

I recently upgraded to QTP version 11. Now when I try to record an application that uses Infragistics controls the objects are not properly recognized. Has anybody else ran into this problem? I am using version 9.1 of Infragistics TestAdvantage.
Please use plain text.
Honored Contributor
Rhonda Robinson
Posts: 3,159
Registered: ‎11-13-2007
Message 2 of 4 (311 Views)

Re: Infragistics control testing with QTP 11

What version of the Infragistics development tools (NetAdvantage?) was used? The TestAdvantage version has to match.
Please use plain text.
Occasional Contributor
Tim Costanzo
Posts: 6
Registered: ‎09-02-2010
Message 3 of 4 (311 Views)

Re: Infragistics control testing with QTP 11

I am using version 2009.1 for both NetAdvantage and TestAdvange. QTP was working fine until the AUT was modified to run the 4.0 .NET framework. This is what compelled me to upgrade to QTP 11.

Please use plain text.
Occasional Contributor
Tim Costanzo
Posts: 6
Registered: ‎09-02-2010
Message 4 of 4 (311 Views)

Re: Infragistics control testing with QTP 11

After digging a little deaper it appears that it is just some controls that are not recognized. Mainly combo boxes are the problem.
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation