ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema' (872 Views)
Reply
erl
Occasional Contributor
erl
Posts: 10
Registered: ‎03-28-2012
Message 1 of 3 (872 Views)

ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema'

I'm installing ALM11 at a Linux box. The new ALM11 server will share the database with a QC10 server (which is currently running).

 

During the ALM11 server configuration, I select ' Upgrade a copy of the existing schema ' and hope the application will make a copy of 'qcsiteadmin_db' and then created a new one called 'qcsiteadmin_db_ALM11' (default name).

 

But this step failed with connection error -- ' Database schema "qcsiteadmin_db" exists, but connection to it failed '

 

-------------------------------------------------------------------------------

   Schema name: [qcsiteadmin_db]

   Press 1 for default value, or 2 for no value: [1]

 

   Schema password: [******]

   New schema name: [qcsiteadmin_db_ALM11]

   Press 1 for default value, or 2 for no value: [1]

 

   Press 1 for Next, 2 for Previous, 3 for Cancel, or 4 for Redisplay [1]

   Validating user settings.

--------------------------------------------------------------------------------

   Error

 

   Database schema "qcsiteadmin_db" exists, but connection to it failed.

--------------------------------------------------------------------------------

 

From the error logs, I see the error message is:

 

<td title="Installation category">Installation</td>

<td title="Message">java.sql.SQLNonTransientConnectionException: [Mercury][Oracle JDBC Driver]Error establishing socket. Unknown host: sa_db_host

at com.mercury.jdbc.oraclebase.dda4.b(Unknown Source)......

 

It seems to me a permission issue. We use a password like 'pass123' for both the Database Admin User and for 'qcsiteadmin_db' schema. But when I entered the password (not using the default one), the installation failed again at the same point with the same error message.

 

Does anyboday know what is the issue?

 

Please use plain text.
Occasional Visitor
saravjitkohli
Posts: 3
Registered: ‎08-26-2013
Message 2 of 3 (427 Views)

Re: ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema'

Hi, 

 

We are also facign this issue, please suugest how it resolved for you.

 

Thanks for Help!

 

Sarav

Please use plain text.
Valued Contributor
sdeff
Posts: 96
Registered: ‎02-27-2013
Message 3 of 3 (415 Views)

Re: ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema'

check your qcsiteadmin_db.xml

passwords set here must match the password you set in the siteadmin_db.

 

note : the password in the xml is encrypted, you might want to use this syntax in the db password parameter  "TXT:<password>" where <password> is the actual text password.

 

Also checked the namedpipes connections or tcp connections of your database.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation